Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.33 veröffentlicht (03.01.23)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Hilfeseiten: Frontend = Deutsch / ACP = Englisch
#11
(24.09.2019, 15:45)bv64 schrieb: es sei denn, das dt. Paket bekommt dann auch mal in der Datenbanktabelle die dt. Texte; wäre doch mal eine Maßnahme
Wozu? Die Texte werden doch bereits über die Sprachdateien übersetzt. Im Admin-CP bringt eine Übersetzung keinen Vorteil, da sich die Hilfeseiten dort nicht anpassen lassen (sofern sie über die Sprachdatei übersetzt sind).
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#12
einfach damit es komplett deutsch ist Wink
Und dann sollte es natürlich möglich, auch genau dort die Texte zu ändern; so ist das irgendwie unvollkommen gelöst

Na gut, ich habe bisher noch keinen Grund gehabt die Original-Texte anzupassen, nur ein paar Dutzend eigene verfasst.
Also letztlich darfst du dir für mich die Mühe sparen, Cheffe Big Grin
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#13
Das eigentlich Irreführende ist ja, dass man im ACP ein änderbares Textfeld für die jeweilige Hilfeseite hat, wo aber Änderungen überhaupt keine Auswirkungen auf das Frontend des Forums haben.
Hier kann man nicht von einer Übersetzung sprechen, sondern es ist völlig egal, was man hier reinschreibt, denn der Text für das Frontend des Forums ist fest in einer Sprachdatei definiert.
Wofür dann dieses Textfeld?
Zitieren
#14
(24.09.2019, 21:25)Schnapsnase schrieb: Wofür dann dieses Textfeld?

Zum Ändern des Textes in der Datenbank  Toungue

Die Hilfeseiten waren schon immer etwas eingeschränkt, was die Sprachen betrifft. 

Wenn man ein mehrsprachiges Forum hat, hat man sowieso nur die Möglichkeit der Sprachdateien, selbst wenn man die Hilfeseiten im ACP bearbeiten würde, die Datenbanktabelle bietet keine Möglichkeit, den gleichen Hilfetext für verschiedene Sprachen zu speichern - sowohl für Standard- als auch für eigene Hilfeseiten.

Die Datenbanktabelle der Hilfeseiten hat außerdem eine Spalte "usetranslation", die standardmäßig auf 1 gesetzt ist. Und wenn diese auf 1 steht, werden immer nur die Sprachdateien geladen, für die Datenbank-Einträge müsste sie auf 0 stehen. Und ich konnte bisher keine Einstellung finden, mit der man diesen Wert - außer direkt in der Datenbank - ändert.
Zitieren
#15
Danke, es funktioniert jetzt korrekt.
Wenn mir möglich biete ich Hilfe(n) an, ich bitte nicht darum helfen zu dürfen!
MyBB: 1.8.33 | PHP: 7.4.33 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#16
(24.09.2019, 21:53)doylecc schrieb: Die Datenbanktabelle der Hilfeseiten hat außerdem eine Spalte "usetranslation", die standardmäßig auf 1 gesetzt ist. Und wenn diese auf 1 steht, werden immer nur die Sprachdateien geladen, für die Datenbank-Einträge müsste sie auf 0 stehen.
Habe in der Datenbank auf "0" eingestellt und mal getestet.

Gegeben sind die Sprachen Deutsch und Englisch, somit jeweils helpdocs.lang.php bearbeitet.

In den Dateien helpdocs.lang.php die erforderlichen Anpassungen (dx > hid=Nr) durchgeführt. Zum Testen im Benutzer-CP die Spracheinstellung geändert.

Deutsch wie folgt:
PHP-Code:
$l['dx_name'] = 'Überschrift';
$l['dx_desc'] = 'Erläuterung';
$l['dx_document'] = 'Inhalt'

Englisch wie folgt:
PHP-Code:
$l['dx_name'] = 'Headline';
$l['dx_desc'] = 'Explanation';
$l['dx_document'] = 'Content'

dx_name wird bei Deutsch und Englisch jeweils korrekt angezeigt
dx_desc wird bei Deutsch und Englisch jeweils korrekt angezeigt
dx_document wird bei Deutsch und Englisch nicht angezeigt
Die Variable dx_document wird bei keiner Sprache ausgegeben.

Was läuft da inkorrekt? Muss da im ACP bei der jeweiligen Hilfeseite (hid) im Feld "Seite" etwas besonderes eingetragen werden.

Zusatzfrage:
Wie definiert man die Texte in den heldocs.lang.php für die SIDs (Kategorien) der Hilfeseiten (hier: Name und Desc)?

Vorab besten Dank für eine Hilfestellung.

Muss in der Datenbank in den Tabellen mybb_helpdocs und/oder mybb_helpsections noch etwas angepasst werden?
   
   
Wenn mir möglich biete ich Hilfe(n) an, ich bitte nicht darum helfen zu dürfen!
MyBB: 1.8.33 | PHP: 7.4.33 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#17
Für eigene Hilfeseiten gibt die Dateien customhelpdocs.lang.php und customhelpsections.lang.php. Diese enthalten auch eine Vorlage.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#18
(25.03.2022, 17:10)StefanT schrieb: Für eigene Hilfeseiten gibt die Dateien customhelpdocs.lang.php und customhelpsections.lang.php. Diese enthalten auch eine Vorlage.
Danke für den Hinweis.

Habe die Daten in die angegeben Dateien eingepflegt.

A) Kategorien werden korrekt angezeigt.
B) Ansonsten wie gehabt:
PHP-Code:
$l['d{hid}_name'] = "[b][color=#008E02]Document name[/color][/b]";
$l['d{hid}_desc'] = "[b][color=#008E02]Document description[/color][/b]";
$l['d{hid}_document'] = "[b][color=#C10300]Document text[/color][/b]"// wird nicht angezeigt 
{hid} wurde selbstverständlich durch die reale Ziffer ersetzt.

Noch einen Tipp woran es liegen könnte?
Wenn mir möglich biete ich Hilfe(n) an, ich bitte nicht darum helfen zu dürfen!
MyBB: 1.8.33 | PHP: 7.4.33 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#19
@Gerti

Ich verstehe gerade nicht...
Du hast in der Datenbank "usetranslation" auf 0 gestellt. Somit wird die Datenbank, aber nicht die Sprachdatei abgegriffen. In der Datenbank gibt es aber nur eine Sprache.
Wie soll das dann funktionieren?
Zitieren
#20
Stimmt, habe jetzt usetranslation auf "1" gestellt und es funktioniert.
Mea Culpa, war mein Fehler.

Die jeweiligen Sprachvariablen customhelpdocs.lang.php und customhelpsections.lang.php lang.php werden jetzt korrekt angezeigt, die Sprachvariablen helpdocs.lang.php und helpsections.lang.php habe ich leer gelassen.

Aufgefallen:
alle vier vorgenannten vier Sprachvariablen unterliegen inhaltlich den gleichen Vorgaben.
Fragen hierzu:
Sicherlich nicht ohne Grund gibt es die Sprachvariablen:
a) helpdocs.lang.php und helpsections.lang.php
und
b) customhelpdocs.lang.php und customhelpsections.lang.php

Was ist der Grund für die (vermeintlich) "doppelte" Ausführung und wann soll/muss "a" bzw. "b" verwendet werden?

Danke für die Beantwortung der Frage, welche sicherlich auch für andere User interessant sein dürfte.
Wenn mir möglich biete ich Hilfe(n) an, ich bitte nicht darum helfen zu dürfen!
MyBB: 1.8.33 | PHP: 7.4.33 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
Question ACP -> Hilfeseiten werden nicht in der richtigen Sprache angezeigt Digitalkeeper 2 396 14.10.2022, 17:23
Letzter Beitrag: Digitalkeeper
  Template-Änderung vs. Anzeige im Frontend FlederMaus 2 945 22.11.2020, 02:58
Letzter Beitrag: FlederMaus
  Bilder auf Hilfeseiten lenox 19 3.264 22.07.2019, 20:59
Letzter Beitrag: Schnapsnase
  Forum auf Englisch trotz Deutsch installiert RobertD 11 1.958 20.05.2019, 14:00
Letzter Beitrag: RobertD
  Hilfeseiten nicht bearbeitbar? Gerti 3 1.435 23.02.2018, 12:28
Letzter Beitrag: Gerti