Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Diskussion: MyBB 1.4.1 veröffentlicht
#41
Wenn du dir unsicher bist, kannst du das Update auch erst in einem Testforum durchführen. Die Downloads enthalten seit gestern Abend aktualisierte Versionen des Upgradeskripts, so dass die Fehler nicht mehr auftauchen sollten.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#42
Ich habe inzwischen einen weiteren Upgrade-Versuch unternommen - diesmal erfolgreich. Auf diesem Wege daher herzlichen Dank für den schnellen Bugfix!
Zitieren
#43
(18.08.2008, 22:14)Michael schrieb: Die Downloads enthalten seit gestern Abend aktualisierte Versionen des Upgradeskripts, so dass die Fehler nicht mehr auftauchen sollten.

Na, das ist doch mal ein Wort...
Zitieren
#44
Hallo,
habe bislang Version 1.2.14 benutzt und wollte jetzt auf 1.4.1 upgraden. Ich denke (hoffe), mich nach Anleitung verhalten zu haben.

Das Upgrade-Script forderte mich zum Einloggen auf, fragte aber nicht die Version ab!

Kurz nach dem Start dann das:
Fatal error: [SQL] [1146] Table 'DB[Zahl].[Präfix-DB]_[Präfix-DB]_users' doesn't exist
UPDATE [Präfix-DB]_[Präfix-DB]_users SET `newpms`='0' WHERE uid='1' in /langer Pfad/inc/db_mysql.php on line 544

Nun habe ich absolut keinen Plan. Merkwürdig ist, dass der Datenbank-Präfix in der Fehlermeldung "verdoppelt" wird!!! Was ist das?!? Die Tabellen der Datenbank haben nur einen Präfix.

Erbitte freundlichst Hilfe.
Zitieren
#45
Entweder sind nicht alle Dateien aktuell oder du benutzt ein Plugin, das nicht mit MyBB 1.4.x kompatibel ist.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#46
(20.08.2008, 01:40)Michael schrieb: du benutzt ein Plugin, das nicht mit MyBB 1.4.x kompatibel ist.
Hallo Michael,
Danke für die schnelle Antwort. Tatsächlich benutze ich ein einsames Plugin (CBACK CrackerTracker), welches nicht deaktiviert war. Aber kann das wirklich daher kommen?

Beim Upload der neuen MyBB-Version hatte ich die Dateien überschreiben lassen.

Bin erstmal wieder zurück auf die "alte" 1.2.14. Werde demnächst nochmal probieren.
Zitieren
#47
Nein, dieses Plugin benutzt keine Querys.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#48
Das Upgradescript im Patch funktioniert nicht mit einer PostgreSQL-Datenbank, da dort ein boolean nicht yes beinhalten kann, sondern nur 1.
Zitieren
#49
Das Script ändert doch nichts an der Datenbank-Struktur.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#50
es aendert nix an der struktur, ja, aber es werden solche selects ausgefuehrt
Code:
$query = $db->simple_select("settings", "name,sid", "isdefault='1' OR isdefault='yes'");
(Zeile 717 aus der upgrade.php)
Und yes fuer einen boolean existiert nicht und dadurch kommt nur eine Fehlermeldung.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Diskussion: MyBB 1.8.8 veröffentlicht StefanT 52 1.406 02.11.2016, 01:53
Letzter Beitrag: melancholia
  Diskussion: MyBB 1.8.7 veröffentlicht StefanT 38 2.850 23.04.2016, 13:50
Letzter Beitrag: RebelAce
  Diskussion: MyBB 1.8.6 und 1.6.18 veröffentlicht StefanT 22 2.357 06.01.2016, 18:55
Letzter Beitrag: destrokk
  Diskussion: MyBB 1.8.5 und 1.6.17 veröffentlicht StefanT 48 4.199 25.06.2015, 17:42
Letzter Beitrag: KaSo
  Diskussion: MyBB 1.8.4 veröffentlicht StefanT 67 6.524 14.05.2015, 11:30
Letzter Beitrag: Jockl