Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Diskussion: MyBB 1.2.11 veröffentlicht
#21
Hi, will nur mal sicher gehen.. Toungue

Habe auf ein damals frisch aufgesetztes MyBB 1.2.10 einfach die Dateien von Sicherheitsupdate für MyBB 1.2.10 und von MyBB 1.2.11 Patch eingespielt (also im Grunde nur auf einem 1.2.10 insgesamt 7 Dateien ersetzt).

Jetzt sollte ich doch auf dem aktuellsten Stand sein oder gibt es doch noch Unterschiede zum kompletten 1.2.11?

Danke Smile

EDIT:

Ich habe jetzt nochmal beide Versionen (also ein MyBB 1.2.10 + Sicherheitsupdate für MyBB 1.2.10 + Patchupdate auf 1.2.11 (aktualisierte Dateien) und ein frisches MyBB 1.2.11) miteinander verglichen.

Ergebnis: folgende Dateien sind unterschiedlich und gehören somit eigentlich noch in das Patch-Update auf 1.2.11:

admin/dbtools.php
inc/class_parser.php
inc/functions_post.php
Zitieren
#22
Bei den beiden Patches wurden diese Dateien nicht verändert. Es dürfte also kein Unterschied da sein.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#23
Guten Abend in die Runde.

Bei mir verlief das Update Fehlerlos (was kann eigentlich dabei schiefgehen? *g*) beim update von 1.2.10 auf 1.2.11
Fehler zeigen sich auch nicht dabei. Was will der Mensch mehr?


Kurz um: danke und einen schönen Abend.
rady: css dropdown menü
to do: sleep
Zitieren
#24
Hallo,

ich habe mein Forum erst seit November am Netz und zwar mit Version 1.2.9.

Bislang habe ich mich nicht getraut ein Update zu fahren, weil ich da wirklich total unsicher bin, andererseits komme ich da wohl nicht drum herum.

Ich habe alle Anleitungen gelesen und doch einiges nicht verstanden:

1. Was muss ich jetzt tun: Auf 1.2.10 upgraden mit dem Script und dann die Patches nehmen für 1.2.11? Oder die Komplettversion 1.2.11 nehmen?

2. Kann ich nach dem Upgrade meine Backup Datei einfach wieder aufspielen?

3. Falls ja, ist damit alles wieder "beim Alten" im Hinblick auf Plugins, Templates und Themes? Falls nein, was muss ich tun, damit meine Plugins, Templates und Themes alle wieder bekomme?

Viele Grüsse

Ingrid
Zitieren
#25
1) Du kannst die geänderten Dateien von MyBB 1.2.10, dem Sicherheits-Patch und von 1.2.11 nehmen und dann ein Upgrade ausführen.
Alternativ kannst du das Paket von MyBB 1.2.11 nehmen und alle Dateien bis auf die inc/config.php und die inc/settings.php überschreiben und dann das Upgrade ausführen.
2) Du solltest vorher ein Backup der Datenbank machen. Brauchen wirst du es hoffentlich nicht.
3) Es ändert sich nichts. Du musst nur noch die in den Ankündigungen genannten Templates zurücksetzen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#26
Am besten nimmst du direkt Version 1.2.11, ersetzt alle Dateien auf deinem Server durch die neuen (außer inc/config.php und inc/settings.php) und führst ein Upgrade durch.

Es ist empfehlenswert die Datenbank zu sichern, wobei im Normalfall alle Themen/Beiträge/Themes usw. erhalten bleiben.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#27
Hallo,

ich finde es toll, wie Ihr mir helfen wollt, aber das ganze ist für mich ein wenig "böhmische Dörfer".

Streng genommen könnte ich ja jetzt die erste Update Version auf 1.2.10 nehmen, wo ich nur die Daten austauschen muss und im Anschluss die Patches - das würde ich ja noch hinkriegen. Nur lerne ich es damit ja nicht und wenn dann mal wirklich ein richtiges Update ansteht, dann stehe ich da.-
Zitat:Am besten nimmst du direkt Version 1.2.11, ersetzt alle Dateien auf deinem Server durch die neuen (außer inc/config.php und inc/settings.php) und führst ein Upgrade durch.

Kannst Du mir das bitte mal für Dummies erklären? Big Grin

Also ich lade die Version 1.2.11 runter (habe ich schon) und packe sie aus?
Und ersetze dann alle Dateien die da drin sind mit denen auf meinem Server bis auf die beiden von Dir genannten (inc/config.php und inc/settings.php) - sprich, ich überschreibe sie alle?

Dann mache ich ein Upgrade? Es gibt ja dafür hier eine Anleitung von Euch:

Anleitung

Wenn ich aber vorher die Dateien schon ausgetauscht habe, sehe ich das dann richtig, dass ich Eurer Anleitung erst ab dem Punkt: "Öffnen Sie Ihren Browser und geben Sie die URL zu Ihrem Forum mit dem Zusatz "install/upgrade.php" ein "folgen muss, weil es wäre ja albern wenn ich jetzt alle Daten wieder runter lösche vom Server. Rolleyes:question:

Zum Backup: Das würde ich auf jeden Fall vorher machen. Zusätzlich (sicherheitsorientiert wie ich bin) werde ich den gesamten Ordner, so wie er ist, vom Server auf die Festplatte runterladen.

Das Backup wäre für den Fall, dass mit dem Upgrade was schief läuft? Wenn ich es dann mittels SQL Dumper wieder einspiele, dann wäre in so einem Fall mein Forum wieder so da wie es zum Zeitpunkt der Sicherung war, also Version 2.1.9 mit allen Beiträgen usw.?

Viele Grüsse

Ingrid
Zitieren
#28
siroca schrieb:Also ich lade die Version 1.2.11 runter (habe ich schon) und packe sie aus?
Und ersetze dann alle Dateien die da drin sind mit denen auf meinem Server bis auf die beiden von Dir genannten (inc/config.php und inc/settings.php) - sprich, ich überschreibe sie alle?
Das ist so richtig.
siroca schrieb:Wenn ich aber vorher die Dateien schon ausgetauscht habe, sehe ich das dann richtig, dass ich Eurer Anleitung erst ab dem Punkt: "Öffnen Sie Ihren Browser und geben Sie die URL zu Ihrem Forum mit dem Zusatz "install/upgrade.php" ein "folgen muss, weil es wäre ja albern wenn ich jetzt alle Daten wieder runter lösche vom Server. Rolleyes:question:
Ja, auch das ist so korrekt.
siroca schrieb:Das Backup wäre für den Fall, dass mit dem Upgrade was schief läuft? Wenn ich es dann mittels SQL Dumper wieder einspiele, dann wäre in so einem Fall mein Forum wieder so da wie es zum Zeitpunkt der Sicherung war, also Version 2.1.9 mit allen Beiträgen usw.?
Genau. Das ist aber wirklich nur für den Fall, dass beim Upgrade ein Fehler passiert.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#29
Zitat:Also ich lade die Version 1.2.11 runter (habe ich schon) und packe sie aus?
Und ersetze dann alle Dateien die da drin sind mit denen auf meinem Server bis auf die beiden von Dir genannten (inc/config.php und inc/settings.php) - sprich, ich überschreibe sie alle?

Ich bin es nochmal - hmm so ganz kann das nicht hinhauen, denn ich habe doch einige geänderte Dateien drin. Ihr schreibt ja, dass man den Upload Ordner neu raufladen muss, das würde aber auch den Image Ordner betreffen bei mir und noch diverse andere. Smilies, Buttons etc.

Desweiteren weiss ich, dass ich einige PHP Dateien angepasst habe, aber ich weiss nicht mehr, welche das waren.

Also mein Forum würde nach dem Upgrade in dieser Form auf keinen Fall mehr so laufen wie vorher. Denn dafür habe ich zuviel angepasst.

Also doch besser das Update auf die erste 1.2.10, dann die Patches für 1.2.10 und dann die Patches für 1.2.11??

Viele Grüsse

Ingrid
Zitieren
#30
Naja, das mit den Anpassungen ist immer ein Problem. Am besten dokumentiert man alles, damit man die Änderungen wieder einfügen kann. Grafikdateien musst du natürlich nicht überschreiben, d.h. du musst den gesamten Ordner "images" nicht neu hochladen.
Ob du das Update in einem oder in zwei Schritten durchführst bleibt dir überlassen. Ersetzen musst du die Dateien in beiden Fällen.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Diskussion: MyBB 1.8.8 veröffentlicht StefanT 52 1.351 02.11.2016, 01:53
Letzter Beitrag: melancholia
  Diskussion: MyBB 1.8.7 veröffentlicht StefanT 38 2.815 23.04.2016, 13:50
Letzter Beitrag: RebelAce
  Diskussion: MyBB 1.8.6 und 1.6.18 veröffentlicht StefanT 22 2.337 06.01.2016, 18:55
Letzter Beitrag: destrokk
  Diskussion: MyBB 1.8.5 und 1.6.17 veröffentlicht StefanT 48 4.167 25.06.2015, 17:42
Letzter Beitrag: KaSo
  Diskussion: MyBB 1.8.4 veröffentlicht StefanT 67 6.494 14.05.2015, 11:30
Letzter Beitrag: Jockl