Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Diskussion: MyBB 1.4.5 veröffentlicht
#21
Uups, vertippt! Big Grin
Wer eine Wahrheit verbergen will, braucht sie nur offen auszusprechen - sie wird einem ja doch nicht geglaubt.
(Charles Talleyrand)
Zitieren
#22
Nach dem Update von 1.4.4 auf 1.4.5 habe ich im ACP folgende Fehlermeldung wenn ich einen neu angemeldeten User freischalten möchte und auch beim Ansehen der IP (User die unter dieser IP einen Beitrag geschrieben haben):

Code:
MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
    1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 3
Query:
    SELECT COUNT(u.uid) AS num_results FROM mybb_users u WHERE 1=1 AND u.uid IN()

Please contact the MyBB Group for support.

Dabei wird der Benutzer aber doch aktiviert. Wenn ich den 'admin'-Ordner gegen den der Version 1.4.4 ersetze, funktioniert wieder alles ohne Fehlermeldung!

Waran kann es liegen?
Zitieren
#23
Suche in der admin/modules/user/user.php nach:
PHP-Code:
$ip_uids = array(); 
Ersetzen durch:
PHP-Code:
$ip_uids = array(0); 

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#24
Im der Anleitung steht : Führen sie ein Backup durch.Löschen Sie alle Dateien Ihres Forums vom Server (sichern Sie vorher eigene Dateien, die Sie zusätzlich in den Ordner Ihres Forums hochgeladen haben und den Ordner "uploads" samt Inhalt!).

In der Ankündigung des Upgrade steht: Templates werden angepasst.

Dann steht dort :
Führen sie ein Upgrade durch, mit Link zum Upgrade
https://www.mybb.de/doku/installationakt...erung.html

Bei mir wird nichts angepasst wenn ich alle gelöscht habe ist es weg. Auch der Backup Ordner ist weg. Irgendwas stimmt hier nicht mit der Beschreibung im Upgrade link.

Entweder man hält sich daran, oder man macht es eben nicht, dann brauche ich aber auch kein Link dorthin, wenn im nächsten Satz eine Ausnahme steht. Ungeachtet dessen hat der Upgradeprozess prima funktioniert, alles funzt Prima.
Zitieren
#25
(19.04.2009, 22:38)Michael schrieb: Suche in der admin/modules/user/user.php nach:
PHP-Code:
$ip_uids = array(); 
Ersetzen durch:
PHP-Code:
$ip_uids = array(0); 

Danke! Jetzt funktioniert es auch bei 1.4.5 ohne Fehlermeldung. Smile
Zitieren
#26
Wurde eigentlich ein Mail-Problem behoben?
Zitieren
#27
Vermehrte errors beim Upgrade

Zitat:Fatal error: Class 'installerOutput' not found in /home/root6/public_html/install/index.php on line 71

Zitat:Warning: Unexpected character in input: ''' (ASCII=39) state=1 in /home/teenc/roo77/install/resources/language.lang.php on line 79

Parse error: syntax error, unexpected '<' in /home/teenc/root7/install/resources/language.lang.php on line 79

installationsverzeichniss mehrmals geuploaded.

MfG

//edit
Dannach stürzt der Server ab :x


[+]
[10:09:56] NOOP
[10:09:57] 200 Zzz...
[10:10:27] NOOP
[10:10:27] 200 Zzz...

//edit²:
zudem wird mybb_theme.xml IMMER wieder geuploaded, egal ob FileZilla oder SmartFTP...
vllt. testet Michael oder Garlant es mal das Installationsverzeichniss zu uploaden..


edit last:
Sorry <.< .. sehe grade das der Account das Speicherplatzlimit erreicht hat musste ich erstmal höher setzen.
thx trotzdem
Zitieren
#28
(20.04.2009, 06:36)friendly-teens schrieb: Wurde eigentlich ein Mail-Problem behoben?
Schau mal in der Liste: http://community.mybboard.net/thread-484...#pid339322
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#29
Die Liste ist beeindruckend. Wink

Vielen Dank erst einmal für die Aktualisierung, wobei ich gestehen muss, dass mir vor dieser Arbeit schon wieder graut....Rolleyes

Und wie jedes Mal wieder die Frage: müssen bei diesem Upgrade von 1.4.4 auf 1.4.5 die Plugins deaktiviert werden? Hier in der Doku oder der Ankündigung steht davon nichts, während auf mybboard.net erwähnt wird, dass Plugins zuvor deaktiviert werden müssen. Wenn dem so ist, wie geht Ihr eigentlich vor, vorhandene DB-Einträge der Plugins nach dem Upgrade wieder auf den letzten Stand zu bringen?
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#30
Da die Plugins in der Regel ja die Datenbank-Tabellen löschen, die sie angelegt haben, wäre es am einfachsten ein Backup der entsprechenden Tabellen zu machen und danach einfach einzuspielen.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Diskussion: MyBB 1.8.8 veröffentlicht StefanT 52 1.398 02.11.2016, 01:53
Letzter Beitrag: melancholia
  Diskussion: MyBB 1.8.7 veröffentlicht StefanT 38 2.847 23.04.2016, 13:50
Letzter Beitrag: RebelAce
  Diskussion: MyBB 1.8.6 und 1.6.18 veröffentlicht StefanT 22 2.355 06.01.2016, 18:55
Letzter Beitrag: destrokk
  Diskussion: MyBB 1.8.5 und 1.6.17 veröffentlicht StefanT 48 4.199 25.06.2015, 17:42
Letzter Beitrag: KaSo
  Diskussion: MyBB 1.8.4 veröffentlicht StefanT 67 6.519 14.05.2015, 11:30
Letzter Beitrag: Jockl