Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Diskussion: MyBB 1.2.12 veröffentlicht
#41
Zum Problem mit dem Löschen von Beiträgen:
Das Update-Skript sollte eigentlich den Variable am Ende das JS-Datei ändern. Bei der thread.js scheint das nicht funktioniert zu haben, weil sie dieses Template vergessen haben. Daher laden manche Browser aus dem Cache noch die alte Version. Ihr könnt im Template "showthread" das:
Code:
<script type="text/javascript" src="jscripts/thread.js?ver=121"></script>
durch das ersetzen:
Code:
<script type="text/javascript" src="jscripts/thread.js?ver=1212"></script>
Dann kommt es zu dem Problem nicht.

Zum Attachment-Problem:
Das habe schon schon vor langer Zeit gemeldet: https://www.mybb.de/forum/showthread.php?tid=7268
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#42
Dragon schrieb:Zum Attachment-Problem:
Das habe schon schon vor langer Zeit gemeldet ...

Sorry ... passiert mir normalerweise eigentlich nicht, dass ich bereits gemeldete Fehler übersehe Sad
 
The User, Formerly Known As "En-Gedi"
 
Zitieren
#43
Ersteinmal Danke für das Update Wink

Nachdem ich dann 2x die upgrade.php ausgeführt habe (beim ersten mal ging danach gar nichts mehr) erhalte ich nun diesen Fehler:
Code:
SecureSSI: Das Script (/usr/export/www/vhosts/funnetwork/hosting/[Name]/[Pfad]/index.php) hat versucht, ausserhalb von seinem Userverzeichniss, auf die Datei /proc/loadavg zuzugreifen.
Aus Sicherheitsgruenden ist dies nicht erlaubt!

SecureSSI: Das Script (/usr/export/www/vhosts/funnetwork/hosting/[Name]/[Pfad]/index.php) hat versucht, ausserhalb von seinem Userverzeichniss, auf die Datei /proc/loadavg zuzugreifen.
Aus Sicherheitsgruenden ist dies nicht erlaubt!

Und im Admin CP dies hier:
Code:
SecureSSI: Das Script (/usr/export/www/vhosts/funnetwork/hosting/[Name]/[Pfad]/admin/index.php) hat versucht, ausserhalb von seinem Userverzeichniss, auf die Datei /proc/loadavg zuzugreifen.Aus Sicherheitsgruenden ist dies nicht erlaubt!


mfg
mP765
Zitieren
#44
Das überflüssige Ausführen könnte noch Probleme bereiten.
Zum Fehler: Suche nach SecureSSI!
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#45
Nach dem ersten Mal ging aber gar nichts mehr. Darum musste ich es zweimal ausführen.

Dragon schrieb:Zum Fehler: Suche nach SecureSSI!
Ich wollte nur anmerken, dass dieser Fehler beim Upgrade auftreten kann. Nach einer Lösung suche ich schon, aber die wollte ich hier gar nicht haben Wink


mfg
mP765
Zitieren
#46
Wenn du die geänderte Datei überschreibst, kommt es natürlich wieder zum Fehler. Die Änderung muss in die neue Datei auch rein.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#47
Übrigens hat sich in der inc/funcions.php etwas geändert:
https://www.mybb.de/doku/haeufig-gestell...seite.html

PHP-Code:
function get_server_load()
{
    global 
$lang;
 
    
$serverload = array();
 
    
// DIRECTORY_SEPARATOR checks if running windows
    
if(DIRECTORY_SEPARATOR != '\\')
    {
        if(@
file_exists("/proc/loadavg") && $load = @file_get_contents("/proc/loadavg"))
        {
            
$serverload explode(" "$load);
            
$serverload[0] = round($serverload[0], 4);
        }
        if(!
$serverload)
        {
            
$load = @exec("uptime");
            
$load split("load averages?: "$load);
            
$serverload explode(","$load[1]);
            if(!
is_array($serverload))
            {
                return 
$lang->unknown;
            }
        }
    }
    else
    {
        return 
$lang->unknown;
    }
 
    
$returnload trim($serverload[0]);
 
    return 
$returnload;


so ist es jetzt:

PHP-Code:
function get_server_load()
{
    global 
$lang;

    
$serverload = array();

    if(
my_strtolower(substr(PHP_OS03)) !== 'win')
    {
        if(@
file_exists("/proc/loadavg") && $load = @file_get_contents("/proc/loadavg"))
        {
            
$serverload explode(" "$load);
            
$serverload[0] = round($serverload[0], 4);
        }
        if(!
$serverload)
        {
            
// Suhosin likes to throw a warning if exec is disabled then die - weird
            
if($func_blacklist = @ini_get('suhosin.executor.func.blacklist'))
            {
                if(
strpos(",".$func_blacklist.","'exec') !== false)
                {
                    return 
$lang->unknown;
                }
            }
            
// PHP disabled functions?
            
if($func_blacklist = @ini_get('disabled_functions'))
            {
                if(
strpos(",".$func_blacklist.","'exec') !== false)
                {
                    return 
$lang->unknown;
                }
            }
            
$load = @exec("uptime");
            
$load split("load averages?: "$load);
            
$serverload explode(","$load[1]);
            if(!
is_array($serverload))
            {
                return 
$lang->unknown;
            }
        }
    }
    else
    {
        return 
$lang->unknown;
    }

    
$returnload trim($serverload[0]);

    return 
$returnload;



mfg
mP765
Zitieren
#48
Übrigens gibt es den Fehler mit dem 31. April & Co. im Kalender immer noch. Es war zwar eine neue calendar.php beim Update dabei gewesen, aber geändert hat sich an diesem Fehler nichts.
Was ich aber noch seltsamer finde, ist, dass dieser Fehler nicht bei allen Usern aufzutreten scheint. Zumindest hab ich auch schon einen aktuellen Screenshot erhalten, wo der April tatsächlich "nur" 30 Tage hat. Hier im Forum hab ich aber auch schon festgestellt, dass es noch einen 31. April gibt.

Am einfachsten wäre wohl wieder das Hochladen des Kalenders von MyBB 1.2.9, aber vorher würde ich da gerne noch wissen, ob es sich bei der Version in MyBB 1.2.12 sich nicht um ein Sicherheitsupdate handelt. Oder ist es ungefährlich die alte Version des Kalenders wieder einzuspielen?
Man kann nicht alles haben - zumindest nicht gleichzeitig.
Zitieren
#49
Ich das Update mal auf meinem Test-Server installiert, und hier der gleiche Fehler:

   
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
Zitieren
#50
@mP765: Danke für den Hinweis. Ich habe den Code in der Doku angepasst.

@CKOne: Versuchs mal damit: https://www.mybb.de/forum/showthread.php...8#pid60208

@Murphy: Wurden die Umlaute auf dem Testserver vor dem Update korrekt angezeigt? Es kann vorkommen, dass die Umlaute nach dem Einspielen eines Dumps falsch dargestellt werden. Ich kann nur nochmal sagen, dass es zwischen Version 1.2.11 und 1.2.12 keinen Unterschied gibt was die Kodierung angeht. Da sonst auch niemand ein Problem hat könnte es auch an einer Codeänderung von dir liegen etc.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Diskussion: MyBB 1.8.8 veröffentlicht StefanT 52 1.334 02.11.2016, 01:53
Letzter Beitrag: melancholia
  Diskussion: MyBB 1.8.7 veröffentlicht StefanT 38 2.796 23.04.2016, 13:50
Letzter Beitrag: RebelAce
  Diskussion: MyBB 1.8.6 und 1.6.18 veröffentlicht StefanT 22 2.320 06.01.2016, 18:55
Letzter Beitrag: destrokk
  Diskussion: MyBB 1.8.5 und 1.6.17 veröffentlicht StefanT 48 4.150 25.06.2015, 17:42
Letzter Beitrag: KaSo
  Diskussion: MyBB 1.8.4 veröffentlicht StefanT 67 6.475 14.05.2015, 11:30
Letzter Beitrag: Jockl