Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Diskussion: MyBB 1.2.12 veröffentlicht
Michael schrieb:Führe das Update durch (fall noch nicht geschehen) und sichere vorher deine Datenbank. Nach der Aktualisierung musst du dann auch die neuen deutschen Sprachpakete hochladen. Wenn du diese bearbeiten willst mach das direkt in den Dateien per Editor und nicht über das Admin-CP.

Das habe ich gemacht.
Nur nach dem Upload der neuen Sprachdateien war dieser Fehler da.
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
Zitieren
Dann lade bitte vorerst die alten Dateien wieder hoch. Poste dann bitte einen Link zu deinem Forum oder schicke ihn mir per PN.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
Danke für den Link. Entweder benutzt du sehr alte Sprachpakete oder du hast das Encoding in der Datei inc/languages/*sprache*.php geändert. Auszug aus dem Quelltext deines Forums:
Code:
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
Seit MyBB 1.2.3 werden die deutschen Sprachpakete von uns als UTF-8 ausgeliefert.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
Also soll ich die neusten Sprachpackete runterladen, und die alten komplett ersetzen?
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
Zitieren
Wenn du die Sprachdateien nicht geändert hast, ist das kein Problem. Sonst musst du die Änderungen wieder einfügen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
Ich hab jetzt mal auf den Hinweis von Michael nachgeguckt, und die deutsch_du und deutsch_sie, laufen über iso-8859-1. Die englisch läuft über UTF-8. Und wenn ich via Benutzer-Cp die Sprache auf Englisch änder, bekomme ich wieder die Meldung.
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
Zitieren
Das Ganze wird jetzt etwas komplizierter. Im Allgemeinen solltest du aus Kompatibilitätsgründen UTF-8 verwenden.

Gehe mal bitte per phpMyAdmin in die Datenbank und da in die Tabellenübersicht. Welche Kollation ist dort angegeben (latin1, utf8,...)?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
Also der Test-Server hat, latin1_swedish_ci.
Bei dem richtigen steht: utf8_bin
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
Zitieren
Die Ausgangskodierung auf dem Testserver ist richtig. Versuche nun bitte folgende Schritte durchzuführen. Sichere vorher die Datenbank falls nötig.

1. Lade die aktuellen Sprachpakete hoch. Umlaute im Forum sollten jetzt falsch dargestellt werden.

2. Öffne die Datei inc/config.php und füge am Ende vor dem ?> folgende Zeile ein:
PHP-Code:
$config['db_encoding'] = 'utf8'

3. Gehe ins Admin-CP des Forums und führe die UTF-8 Konvertierung durch. Danach sollte alles wieder stimmen.

Wenn das Ganze so funktioniert, kannst du diese Schritte analog auch in deinem richtigen Forum durchführen. Beachte aber, dass du vorher die Kollation der einzelnen Tabellen per phpMyAdmin auf latin_general_ci setzen musst, damit die Konvertierung erfolgreich durchgeführt werden kann.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
Schuldigung für die späte Antwort.
Das ganze sieht jetzt so aus:

   
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Diskussion: MyBB 1.8.8 veröffentlicht StefanT 52 1.351 02.11.2016, 01:53
Letzter Beitrag: melancholia
  Diskussion: MyBB 1.8.7 veröffentlicht StefanT 38 2.826 23.04.2016, 13:50
Letzter Beitrag: RebelAce
  Diskussion: MyBB 1.8.6 und 1.6.18 veröffentlicht StefanT 22 2.341 06.01.2016, 18:55
Letzter Beitrag: destrokk
  Diskussion: MyBB 1.8.5 und 1.6.17 veröffentlicht StefanT 48 4.178 25.06.2015, 17:42
Letzter Beitrag: KaSo
  Diskussion: MyBB 1.8.4 veröffentlicht StefanT 67 6.505 14.05.2015, 11:30
Letzter Beitrag: Jockl