Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Google SEO
#41
Hallo zusammen,

ich habe mein Server gerade von php 7.0.x auf php 7.2.8 umgestellt und dabei ist mir aufgefallen das mir einige Fehler angezeigt werden wenn ich mich im ACP anmelden möchte,unter anderem von dem SEO Plugin.


PHP-Code:
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - Line14 Fileinc/plugins/applythreadprefix.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/applythreadprefix.php 14 errorHandler->error
/inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - Line24 Fileinc/plugins/applythreadprefix.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/applythreadprefix.php 24 errorHandler->error
/inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - LineFileinc/plugins/tpref.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/tpref.php 6 errorHandler->error
/inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - LineFileinc/plugins/tpref.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/tpref.php 6 errorHandler->error
/inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - Line14 Fileinc/plugins/profilepic.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/profilepic.php 14 errorHandler->error
/inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - Line24 Fileinc/plugins/profilepic.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/profilepic.php 24 errorHandler->error
/inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - Line34 Fileinc/plugins/profilepic.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/profilepic.php 34 errorHandler->error
/inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - Line44 Fileinc/plugins/profilepic.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/profilepic.php 44 errorHandler->error
/inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - Line54 Fileinc/plugins/profilepic.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/profilepic.php 54 errorHandler->error
/inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - Line37 Fileinc/plugins/google_seo/404.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/google_seo/404.php 37 errorHandler->error
/inc/plugins/google_seo.php 311 require_once
/
inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - Line159 Fileinc/plugins/google_seo/url.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/google_seo/url.php 159 errorHandler->error
/inc/plugins/google_seo.php 311 require_once
/
inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2] Use of undefined constant THIS_SCRIPT assumed 'THIS_SCRIPT' (this will throw an Error in a future version of PHP) - Line1101 Fileinc/plugins/google_seo/url.php PHP 7.2.8 (Linux)
File Line Function
/
inc/plugins/google_seo/url.php 1101 errorHandler->error
/inc/plugins/google_seo/url.php 174 google_seo_url_hook
/inc/plugins/google_seo.php 311 require_once
/
inc/class_plugins.php 38 require_once
/
inc/init.php 233 pluginSystem->load
/admin/index.php 18 require_once
Warning [2Cannot modify header information headers already sent by (output started at /homepages/8/d707489081/htdocs/inc/class_error.php:229) - Line24 Fileadmin/index.php PHP 7.2.8 (Linux)
File Line Function
[
PHP  errorHandler->error
/admin/index.php 24 header
Warning 
[2Cannot modify header information headers already sent by (output started at /homepages/8/d707489081/htdocs/inc/class_error.php:229) - Line25 Fileadmin/index.php PHP 7.2.8 (Linux)
File Line Function
[
PHP  errorHandler->error
/admin/index.php 25 header
Warning 
[2Cannot modify header information headers already sent by (output started at /homepages/8/d707489081/htdocs/inc/class_error.php:229) - Line64 Fileadmin/index.php PHP 7.2.8 (Linux)
File Line Function
[
PHP  errorHandler->error
/admin/index.php 64 header
Warning 
[2Cannot modify header information headers already sent by (output started at /homepages/8/d707489081/htdocs/inc/class_error.php:229) - Line1928 Fileinc/functions.php PHP 7.2.8 (Linux)
File Line Function
[
PHP  errorHandler->error
/inc/functions.php 1928 header
/inc/functions.php 1941 my_setcookie
/admin/index.php 532 my_unsetcookie 

Kann man das Plugin anpassen das es auf php 7.2 läuft ?
Zitieren
#42
Welche MyBB-Version benutzt du? Diese Fehleranzeige mit PHP 7.2 u.a. auch durch verschiedene Plugins wurde in MyBB 1.8.16 behoben.
Zitieren
#43
Ein paar Probleme mit PHP 7.2 wurden auf Github bereits behoben: https://github.com/frostschutz/MyBB-Google-SEO
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#44
@doylecc ich nutze noch 1.8.14 da mir die 15 zu viele Fehler hatte von der 16 abgeraten wurde und mit der 17er Version noch nicht geschafft ein Update zu machen.

@Stefan meinst du hier den Code https://github.com/frostschutz/MyBB-Goog.../issues/63

Hab jetzt erst mal zu php 7.1 gewechselt da läuft ja soweit alles und werde dann mal die nächsten Tage schauen ob ich das 17 update schaffe.
Zitieren
#45
Eine neue Version wurde veröffentlicht: Google SEO 1.8.3
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Google SEO MyBB.de Bot 418 45.978 25.02.2016, 10:37
Letzter Beitrag: StefanT
  Google SEO Legacy MyBB.de Bot 0 653 10.08.2011, 17:08
Letzter Beitrag: MyBB.de Bot