Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht (30.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Google SEO
#61
Bin gerade dabei, auf 1.8.4 upzudaten. Habe die neuen Dateien hochgeladen.

Anschließend wollte ich das Plugin deaktivieren und anschließend wieder aktivieren. Das habe ich noch nicht veranlasst, denn ich bekomme folgende Fehlermeldungen:

Im Admin-CP ganz oben auf Startseite:

2); $plugins->remove_hook("pre_output_page", "google_seo_redirect_header", "", 2); $plugins->remove_hook("error", "google_seo_redirect_remove", "", 2); $plugins->remove_hook("no_permission", "google_seo_redirect_remove", "", 2); } /* --- End of file. --- */ ?>

Im Admin-CP auf der Seite Konfiguration:
2); $plugins->remove_hook("pre_output_page", "google_seo_redirect_header", "", 2); $plugins->remove_hook("error", "google_seo_redirect_remove", "", 2); $plugins->remove_hook("no_permission", "google_seo_redirect_remove", "", 2); } /* --- End of file. --- */ ?> ) Redirection settings for the Google Search Engine Optimization plugin."; $l['setting_group_google_seo_sitemap'] = "Google SEO Sitemap"; $l['setting_group_google_seo_sitemap_desc'] = "(Advanced Users) Sitemap settings for the Google Search Engine Optimization plugin."; $l['setting_group_google_seo_tweak'] = "Google SEO Tweaks"; $l['setting_group_google_seo_tweak_desc'] = "(Advanced Users) Tweaks that change Google SEO's default behaviour."; $l['setting_group_google_seo_url'] = "Google SEO URL"; $l['setting_group_google_seo_url_desc'] = "(Advanced Users) URL settings for the Google Search Engine Optimization plugin.";

Das Forum selbst ist nur noch eine weiß Seite. Hat jemand eine Idee, was da schief gelaufen ist?
Zitieren
#62
(12.09.2020, 07:23)falcao1010 schrieb: Bin gerade dabei, auf 1.8.4 upzudaten. Habe die neuen Dateien hochgeladen.

Anschließend wollte ich das Plugin deaktivieren...

Klingt irgendwie merkwürdig.
Kann es sein, dass Du nur die neuen Dateien hochgeladen hast, ohne den Upgrade-Script auszuführen?
Zitieren
#63
Das Plugin hat m.W. kein Upgrade-Skript.

Auszug aus der Info des Plugins:
"The Google SEO plugin can be updated by uploading the new files (as described in the Installing section above). Once all the new files are in place, go to your Admin CP -> Plugins page and deactivate the plugin, then activate it again."

Meine Mybb-Version ist 1.8.24.
Zitieren
#64
Sorry, hier war ich auf einem völlig falschen Pfad.
Ich hatte es so verstanden, dass Du MyBB updaten wolltest.

Mit dem Plugin kenne ich mich nicht wirklich aus.
Sind alle Dateien korrekt hochgeladen und am richtigen Ort?
Zitieren
#65
Ich denke schon, dass es richtig hochgeladen war. Ich habe jetzt erstmal wieder die alte Plugin-Version hochgeladen, damit habe ich keine Probleme.
Zitieren
#66
Da muss was beim Upload schiefgegangen sein oder du hast die Dateien modifiziert.
Anders kann ich mir nicht erklären, wie PHP-Sourcecode in der Ausgabe landen soll.
Hast du das Plugin von der offiziellen Seite heruntergeladen?
Zitieren
#67
(12.09.2020, 14:14)frostschutz schrieb: Da muss was beim Upload schiefgegangen sein oder du hast die Dateien modifiziert.
@frostschutz
* die Changelog.txt endet mit der letzten Info vom 09.12.2012
> hat sich doch etwas geändet weil jetzt V1.8.4 erschienen ist? Was?
* muss beim Update etwas (besonderes) beachtet werden?
> die Frage ergibt sich, weil keine Anleitung für ein Update gegeben ist

Gehe ich recht in der Annahme, dass das bereits installierte PlugIn (hier V1.8.3) lediglich deaktiviert werden muss, die V1.8.4 komplett uploaden und dann das PlugIn wieder aktivieren?
(12.09.2020, 14:14)frostschutz schrieb: Hast du das Plugin von der offiziellen Seite heruntergeladen?
Ist die offizielle Seite diese?

Nebenbei:
1. Ich werde das PlugIn (PlugIn und Sprachdateien) in den nächsten Tagen auf Deutsch übersetzen und die Übersetzung dann hier hoch laden. Du kannst sie dann in Dein Download-PlugIn einbinden bzw. alles Deutsche version anbieten.
2. Der Link in Deiner Signatur verweist auf PlugIns für MyBB 1.6.x - ist das noch zeitgemäß?
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#68
(12.09.2020, 14:14)frostschutz schrieb: Da muss was beim Upload schiefgegangen sein oder du hast die Dateien modifiziert.
Anders kann ich mir nicht erklären, wie PHP-Sourcecode in der Ausgabe landen soll.
Hast du das Plugin von der offiziellen Seite heruntergeladen?

Ja, ich habe das Plugin von der offiziellen Seite heruntergeladen. Ich kann nicht ganz ausschließen, dass ich einen Fehler beim Upload gemacht habe. Modifiziert habe ich die Dateien nicht.
Zitieren
#69
Die neue Version 1.8.4 des PlugIn meldet:
Zitat:Die Datenbank-Kodierung ist 'utf8', sollte aber 'utf8mb4' sein. Bitte aktualisiere MyBB, um überall UTF-8 zu verwenden.
was bei der Vorgängerversion 1.8.3 bisher nicht gemeldet wurde. Das Forum aber ist aktuell = V1.8.24.

Da in der Hilfe zu diesem Fehler keinerlei Hinweise in der Anleitung bzw. im z.B. Abschnitt Fehlerbehebung gegeben sind, hier die Frage ob jemand weiß wie vorzugehen ist um die Fehlermeldung zu beseitigen?

@Nachtrag:
Lösung war, im ACP > Tools & Verwaltung > UTF-8 Konvertierung standen bei:
Zitat:UTF-8 Status = alle auf grün
4-Byte UTF-8 Unterstützung > alle auf Rot
Habe die angebotene Konvertierung durchgeführt und gemäß Rückmeldung in der config.php die Umstellung auf "utf6mb4" getätigt. Danach war die Fehlermeldung verschwunden.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#70
Die Fehlermeldung ist suboptimal, ich werde versuchen direkt einen Link zur UTF-8 Konvertierung mit einzubauen.

(12.09.2020, 14:34)Gerti schrieb: @frostschutz
* die Changelog.txt endet mit der letzten Info vom 09.12.2012
> hat sich doch etwas geändet weil jetzt V1.8.4 erschienen ist? Was?

Siehe https://community.mybb.com/mods.php?acti...og&pid=789 oder die History auf Github oder den Thread im englischen Forum...

(12.09.2020, 14:34)Gerti schrieb: * muss beim Update etwas (besonderes) beachtet werden?
> die Frage ergibt sich, weil keine Anleitung für ein Update gegeben ist

Steht in der Anleitung (google_seo.html bzw. https://github.com/frostschutz/MyBB-Google-SEO#readme https://github.com/frostschutz/MyBB-Google-SEO#updating

In der Regel ist es ein einfaches Deactivate/Activate nachdem die neuen Dateien oben sind. Das erneuert dann die verfügbaren Google SEO Settings sowie deren Beschreibungen.

Ansonsten wird alles im Plugin Status angezeigt (eben sowas wie die UTF-8 Konvertierung etc.)

Übersetzung ist verdammt viel Arbeit und da sich Google SEO zu 99% im Hintergrund hält, auch nicht so umwerfend wichtig :-] vorausgesetzt, der Forenadmin kann Englisch. Überleg dir gut ob du dich da wirklich dranwagen willst, ich nehme es aber ggf. gerne ins Projekt mit auf.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Facebook, Google, Twitter, SEO Metatags MyBB.de Bot 0 389 29.11.2019, 16:10
Letzter Beitrag: MyBB.de Bot
  Google SEO MyBB.de Bot 418 67.592 25.02.2016, 10:37
Letzter Beitrag: StefanT
  Google SEO Legacy MyBB.de Bot 0 1.250 10.08.2011, 17:08
Letzter Beitrag: MyBB.de Bot