Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht (30.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Google SEO
#71
(15.09.2020, 14:17)frostschutz schrieb: Übersetzung ist verdammt viel Arbeit ....
Stimmt, es war viel Arbeit. Die habe ich mir auferlegt und somit durchgeführt.

Die Hilfedatei des PlugIn findet sich gemäß den Originalvorgaben im Ordner ./inc/plugins/google_seo.html. Wird diese Dokumentation aufgerufen, wird der Fehler 403 angezeigt.
Zitat:Fehler 403: Ihr Zugriff auf diese Seite wurde verweigert
Mögliche Ursachen für diesen Fehler sind:
  • Es wurde keine Index-Seite (z.B. index.html oder index.php) hinterlegt
  • Ihre Anfrage wurde von unserer Web Application Firewall unterbunden. Sofern Sie der Betreiber dieser Website sind, können Sie die Web Application Firewall in unserem Control Panel "Hosting-URL" anpassen oder deaktivieren.
Error 403: your request was denied
Possible causes for this error are:
  • No index page (e.g. index.php or index.html) was found
  • Your request was denied by our web application firewall. In case you are the operator of this website, you are able customize or disable the Web Application Firewall in our control panel  "Hosting-URL".
Vorstehende Fehlermeldung erscheint zumindest bei den Hostern: 1und1 / strato / Devago/ All-Inkl.

Da ich die Sprachdateien (wurden um die Spoilerangabe - sie nachfolgend erweitert) inkl. der Hilfedatei auf Deutsch übersetzt habe, habe ich die Hilfedatei daher wie folgt abgelegt:
Deutsch: im Ordner: ./manuals/google_seo_de.html
Englisch: im Ordner: ./manuals/google_seo_en.html
> die dazugehörige CSS-Datei (habe die Style-Anweisungen aus der HTML- herausgenommen) befindet sich im Ordner ./assets/css/google_seo.css
> des Weiteren habe ich das große Fenster (ACP > Einstellungen > PlugIns) mit dem Hinweis bzgl. der Anpassungen in der .htaccess hinter einem Spoiler (Spoilerhinweis wird in der jeweiligen Sprache ausgegeben) gelegt. Sieht jetzt um einiges besser aus.

Alle Ordner und Dateien befinden sich in einem Upload-Ordner. Wie kann/soll ich Dir das gesamte modifizierte PlugIn zukommen lassen? Es wäre sicherlich hilfreich wenn es von Dir auf Github eingestellt würde. Kann es selbstverständlich auch hier auf MyBB.de > Erweiterungen posten.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#72
Uff, ähm, das google_seo.html wird einfach aus der README heraus erzeugt.

Deswegen sieht das in der html Datei auch alles so schön verpanscht aus. ;-)

Du kannst mir die Dateien gerne als Mailanhang schicken, wenn du keinen Pull-Request auf GitHub machen willst.
Zitieren
#73
(17.09.2020, 09:01)frostschutz schrieb: Uff, ähm, das google_seo.html wird einfach aus der README heraus erzeugt.
Innerhalb des PlugIns im ACP wird öfters auf die Dokumentation verlinkt genau da ergibt sich die Fehlermeldung 403

(17.09.2020, 09:01)frostschutz schrieb: Deswegen sieht das in der html Datei auch alles so schön verpanscht aus. ;-)
Darum habe ich es komplett neu geordnet und die Funktion geprüft.

(17.09.2020, 09:01)frostschutz schrieb: Du kannst mir die Dateien gerne als Mailanhang schicken, wenn du keinen Pull-Request auf GitHub machen willst.
Was ist denn ein "Pull-Request"? Habe keinerlei Erfahrung wie man dies durchführt. Gilt die E-Mailadresse welche im Helpfile angegeben ist? Denn die URL dazu lässt sich nicht aufrufen sondern meldet "404 Not Found - nginx" (was immer "nginx" auch bedeutet).
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#74
Ja, kein Problem, dann schicks einfach per Mail. Bei der Adresse bist du schon völlig richtig. Danke!
Zitieren
#75
Hallo,

ich habe mir Google SEO installiert und davor auf Deutsch übersetzt.
Meine Frage wie schaffe ich, dass die URL nicht so ,,https://community.agw-international.com"/forumdisplay.php?fid=4 die URL ist, sondern so ,,https://community.agw-international.com/samsung" aussieht?
Zitieren
#76
Bitte beachte unsere Verhaltensregeln...
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#77
(20.12.2020, 07:17)AGW schrieb: ich habe mir Google SEO installiert und davor auf Deutsch übersetzt.
Die Deutsche Übersetzung habe ich auch ausgeführt (incl. Spolier für die umfassende Thematik ".htaccess") und Frostschutz dazu informiert. Leider kam hierzu bisher kein Feedback.

(20.12.2020, 07:17)AGW schrieb: Meine Frage wie schaffe ich, dass die URL nicht so ,,https://community.agw-international.com"/forumdisplay.php?fid=4 die URL ist, sondern so ,,https://community.agw-international.com/samsung" aussieht?
Das PlugIn führt die von Dir gewünschte Funktion korrekt aus. Denke Du musst im ACP Deine Einstellungen korrekt ausführen bzw. die im ACP angezeigten Anweisungen zur Einbindung in der .htaccess ausführen.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#78
Hallo Gerti,

ich habe es richtig in der .htaccess-Datei hineinkopiert, aber wenn ich auf der Startseite Samsung aufrufe komme ich zu https://community.agw-international.com/.../f-samsung und erhalte Error 404.

Ist es möglich, dass der Link auch nur so https://community.agw-international.com/samsung ist?
Und was habe ich falsch gemacht oder was muss noch geändert werden?

Obwohl ich es auf Deutsch übersetzt habe, werde ich nicht durch die Angaben oder Möglichkeiten (in der Dokumentation) schlauer.
Zitieren
#79
Es ist nicht unmöglich aber halt auch nicht empfehlenswert.

Von Haus aus brauchst du für jeden URL-Type ein eindeutiges Präfix (Forum- Thread- usw.) oder eben ein Postfix. Das um sicherzustellen, daß es keine URL a la Forum-Thread geben kann die sowohl für ein Forum namens Thread oder einen Thread namens Forum stehen könnte (URL-Konflikt). Weil der Rewrite dann nicht weiß ob es an showthread.php oder an forumdisplay.php gehen soll.

Jede URL muss eineindeutig sein. Es gibt bei MyBB kein Routing o.ä. bei dem eine URL /samsung dann entweder ein Forum oder ein Username oder ein Thread sein könnte, je nachdem was zuerst da war.

In der Dokumentation habe ich versucht das hier zu erklären: https://github.com/frostschutz/MyBB-Goog...-conflicts

Wenn du das Forum- präfix weglässt, dann ist es eben nicht mehr eindeutig, und du hast einen Konflikt.

Das kannst du umgehen, z.B. den Forum-Rewrite zur letzten RewriteRule in der .htaccess smachen (damit es die anderen Rewriterules nicht behindert) und die Foren müssen dann eben so benannt sein, daß sie nicht aussehen wie eine Thread- User- Event- usw. URL.

Aber dann wird jeder Aufruf zu deineseite/irgendwas die Fehlermeldung "Unbekanntes Forum" o.ä. zeigen, weil dann alles so aussieht wie eine URL für ein Unterforum, das es eben nicht gibt. Statt eine generische 404 Seite weil gar kein Forum gemeint war.

Alternativ wärs auch möglich, bei einer überschaubaren Anzahl Unterforen, für jedes einzeln eine eigene RewriteRule zu schreiben.

Der Standard ist eben Forum- , das ist eben ein Wort mit dem auch Google was anfangen kann, f- ist dagegen wertlos.

Wenn MyBB nicht solche Probleme mit virtuellen Verzeichnisstrukturen hätte, wäre es wohl einfach /forum/dings geworden ...

@Gerti, bei mir bleibt im Moment ziemlich viel liegen, sorry.
Zitieren
#80
Hallo frostschutz,

danke für die Antwort.

Ich habe die URL wieder wie am Anfang geändert. Nur mein Problem ist, dass wenn ich ein Unterforum aufrufe z.B. Samsung (https://community.agw-international.com/.../f-samsung), dass ich dann Error 404 erhalte. Hauptforen funktionieren ohne Probleme.

Wenn ich ein Beitrag aufrufe z.B. https://community.agw-international.com/...21-geleakt habe ich 2 Mal ,,thread" erhalten, aber warum?

Wie kann ich auch die Unterforen aufrufen?

Den eingefügten Code in der .htaccess-Datei:
Code:
# Google SEO-Problemumgehung für search.php-Highlights:
# Machen Sie diese Regel zur ersten Umschreiberegel in Ihrer .htaccess!
RewriteRule ^([^&]*)&(.*)$ https://community.agw-international.com/$1?$2 [L,QSA,R=301]

# Google SEO 404:
ErrorDocument 404 /misc.php?google_seo_error=404

# Google SEO Sitemap:
RewriteRule ^sitemap\-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Foren:
RewriteRule ^forum\-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Themen:
RewriteRule ^thread\-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Ankündigungen:
RewriteRule ^ankuendigung\-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Benutzer:
RewriteRule ^user\-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Kalender:
RewriteRule ^kalender\-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Veranstaltungen:
RewriteRule ^veranstaltung\-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Facebook, Google, Twitter, SEO Metatags MyBB.de Bot 0 389 29.11.2019, 16:10
Letzter Beitrag: MyBB.de Bot
  Google SEO MyBB.de Bot 418 67.592 25.02.2016, 10:37
Letzter Beitrag: StefanT
  Google SEO Legacy MyBB.de Bot 0 1.250 10.08.2011, 17:08
Letzter Beitrag: MyBB.de Bot