Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.11 veröffentlicht (04.04.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Diskussion: MyBB 1.2.8 veröffentlicht
#41
@Mak: Habe das gemacht, den Fehler habe ich aber immer noch.
- Ersetze ich die 1.2.8er inc/functions.php durch die 1.2.7er geht wieder alles.
- Wenn das PM-Quota nicht 0 (also unbegrenzt ist) tritt der Fehler auf.
- Der Fehler trat bisher in der Benutzergruppe "Administrator" auf.

Wenn man wie folgt das Benutzergruppen-Quota ausliest erhält man als User der Benutzergruppe Administrator mit einem PM-Quota größer als Null auch keine ausgabe. Ist das Quota Null erfolgt eine Ausgabe (0).
Als "Registrierter Benutzer" erhält man allerdings immer eine Ausgabe.

<?
define("IN_MYBB", 1);
require_once "./global.php";
echo $mybb->usergroup['pmquota'];
?>

Update:
Hatte in der Benutzergruppe Administrator bei meinem Account "Administrator" in der Primären sowie Sekundären Benutzergruppe stehen. Entfernt man das zweite Administrator funktioniert alles wie gehabt!

Evtl. beim nächsten Update es nicht weiter ermöglichen Primär und Sekundär die gleiche Benutzergruppe wählen zu können, da dies zu Fehlern führt.

Leider ist bei allen Usern die Primäre und Sekundäre Benutzergruppe identisch weswegen alle mit dem Fehler zu kämpfen haben.

Update2:
Wählt man als Sekundäre Benutzergruppe Admisitrator (wenn man das in der primären auch schon ist) und zusätzlich noch eine andere funktioniert PM wieder!
http://www.profi-webmaster.com - Gratis Webspace ohne Werbung.
Donated $5,00 USD! Cool
Zitieren
#42
Das scheint ein Bug zu sein. Öffne bitte die Datei inc/functions.php und suche nach:
PHP-Code:
if($access == 0)
{
    
$usergroup[$perm] = 0;
}
$zerogreater 1
Ersetzen durch:
PHP-Code:
if($access == 0)
{
    
$usergroup[$perm] = 0;
    
$zerogreater 1;


Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#43
Primäre und Sekundäre Benutzergruppe gleich gestellt, Deinen Bugfix benutzt, und pm geöffnet:
Der Fehler ist verschwunden!
Vielen Dank!!! :-)
http://www.profi-webmaster.com - Gratis Webspace ohne Werbung.
Donated $5,00 USD! Cool
Zitieren
#44
Moin Wink

Beim erstellen von einem Thread, oder beim Antworten in einem Thread, kommt folgende Fehlermeldung:

Depreciated function call: update_thread_attachment_count
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
Zitieren
#45
Stelle sicher, dass alle neuen Dateien übertragen wurden.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#46
Hi zusammen

Ich habe mir jetzt alles durchgelesen,
und bin erschrocken das es viele fehler nachsich ziehen kann das update durchzuführen !

Ich habe jetzt ein bissl respekt davor,
da ich bei mir im Forum sehr viel verändert habe !

Weil irgendwie hab ich da kein bock drauf das update auszuführen,
und dann so viele änderungen erneut vorzunehmen !

Daher wollte ich jetzt nochmals genau nachfragen,
wurden die nachträglichen bugs noch behoben ?
(z.B. der wo Michael Gestern 19:09 gepostet hat)

Dazu habe ich das MkPortal installiert, wird das probleme geben beim update ?

bis gli...
greetz DaStaFlexX
Zitieren
#47
Michael schrieb:Stelle sicher, dass alle neuen Dateien übertragen wurden.

Wurden auf jeden Fall.
Ich habe alle Dateien hochgeladen.
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
Zitieren
#48
Von welcher Version hast du aktualisiert? Wie bist du vorgegangen?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#49
Ich habe von 1.2.6 aktualisiert.

Ich habe die config.php und die settings.php vom Server geladen.
Die Datein von 1.2.8 hochgeladen, und die anderen überschrieben.
Dann die nötigen Rechte den Datein und Ordner gegeben, und die install/upgrade.php ausgeführt.
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
Zitieren
#50
Hast du nur die geänderten Dateien hochgeladen? Du musst

a) die geänderten Dateien von 1.2.7 und dann die von 1.2.8 hochladen
b) alle Dateien von 1.2.8 (außer inc/config.php und inc/settings.php) hochladen.

DaStaFlexX schrieb:Ich habe jetzt ein bissl respekt davor,
da ich bei mir im Forum sehr viel verändert habe !
Naja, auch wenn es sich hart anhört, aber das ist dein Problem. Es gibt wenige kleine Fehler in 1.2.8, für die aber bereits Fixes bereit stehen.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Diskussion: MyBB 1.8.11 veröffentlicht StefanT 29 753 16.04.2017, 21:19
Letzter Beitrag: sjfm
  Diskussion: MyBB 1.8.10 veröffentlicht StefanT 21 1.247 05.02.2017, 22:24
Letzter Beitrag: StefanT
  Diskussion: MyBB 1.8.9 veröffentlicht StefanT 18 1.087 04.01.2017, 12:55
Letzter Beitrag: Licht
  Diskussion: MyBB 1.8.8 veröffentlicht StefanT 52 2.568 02.11.2016, 02:53
Letzter Beitrag: melancholia
  Diskussion: MyBB 1.8.7 veröffentlicht StefanT 38 3.727 23.04.2016, 14:50
Letzter Beitrag: RebelAce