Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Probleme mit Login auf Homepage
#1
Irgendwie funktioniert mit meinen System der Login auf der Homepage nicht

Ich benutze mehrere includes in 1 Index, um alle Seiten gleichzeitig zu aktualisieren

Index lädt "head.php" "header.php" "content.php"

Im "head.php" liegen alle relavanten Daten, als erstes wird natürlich MyBB definiert, doch hier ensteht komischerweiße ein konflikt mit meinen System

Index
PHP-Code:
<!DOCTYPE html>
<
html>
<?
php

   $path 
$_SERVER['DOCUMENT_ROOT'];
   $path .= "/source/inc_head.php";
   include_once($path);

?>

inc_head
PHP-Code:
<?php

   $path 
$_SERVER['DOCUMENT_ROOT'];
   $path .= "/source/config.php";
   include_once($path);
?>

+meta css etc 

config.php
PHP-Code:
<?php

#   |¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯|
#   |                               Forum Login benutzen                                |
#   |_________________________________________________|

       define("IN_MYBB"1);
       require("/forum/global.php");
       
if($mybb->user['uid'] != "0") {
   echo $mybb->user['username'];
} else {
   echo "Du bist nicht eingeloggt";


Auf der Startseite, funktioniert es einwandfrei, es zeigt den Variableninhalt an ( in meinen Fall "Devidra" )

Doch, wenn ich nun "localhost/test/" aufrufe, bekomme ich eine Fehlermeldung, das die Datei "/forum/global.php" nicht vorhanden sei / nicht gefunden werden konnte

Obwohl es ein absoluter Pfad ist, eigentlich sollte es doch funktionieren

Hier mal die Fehlermeldung

Mit Ajax Aufruf
Code:
Notice: Undefined variable: mybb in C:\xampp\htdocs\login\content.php on line 16

Notice: Trying to get property of non-object in C:\xampp\htdocs\login\content.php on line 16

Notice: Undefined variable: mybb in C:\xampp\htdocs\login\content.php on line 17

Notice: Trying to get property of non-object in C:\xampp\htdocs\login\content.php on line 17

PHP-Code:
<?php 
               
if($mybb->user['uid'] != "0") { // Zeile 16
   echo $mybb->user['username'];
} else {
   echo "Du bist nicht eingeloggt";


?>

Index Aufruf
Code:
Warning: require(/forum/global.php): failed to open stream: No such file or directory in C:\xampp\htdocs\source\config.php on line 8

Fatal error: require(): Failed opening required '/forum/global.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\source\config.php on line 8



Weiß gerade nicht ob ich was wichtiges vergessen hab, ich weiß aber echt nicht wieso der in Unterordner die Datei nicht finden / laden kann
Gerade nochwas getestet, wenn ich den wirklichen absoluten Pfad nehme und

PHP-Code:
       define("IN_MYBB"1);
 
   $path $_SERVER['DOCUMENT_ROOT'];
   $path .= "/forum/global.php";
   require($path); 

in die "config.php" einfüge, klappt der Aufruf über index, aber nicht über Ajax

Über Ajax kommt weiterhin der Fehler

Code:
Notice: Undefined variable: mybb in C:\xampp\htdocs\login\content.php on line 16

Notice: Trying to get property of non-object in C:\xampp\htdocs\login\content.php on line 16

Notice: Undefined variable: mybb in C:\xampp\htdocs\login\content.php on line 17

Notice: Trying to get property of non-object in C:\xampp\htdocs\login\content.php on line 17

Gäbe es hier noch ne möglichkeit das hinzukriegen oder ist es echt nicht anders machbar als hier in jeder "content.php"

PHP-Code:
   define("IN_MYBB"1);
 
   $path $_SERVER['DOCUMENT_ROOT'];
   $path .= "/forum/global.php";
   require($path); 

An vorderster Stelle nochmal einzufügen?

Wäre, wenn es nicht anders geht, auch mit dieser möglichkeit zufrieden, also erwarte ich freudig eine Benachrichtigung ob es nicht doch anders geht  Rolleyes
Zitieren
#2
Dein AJAX-Aufruf ruft anscheinend eine Datei auf, die die config.php nicht lädt. Somit wird auch die global.php nicht eingebunden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Ah, ich dachte alles wird, wenn es vorher aufgerufen wird, gespeichert und kann dann abgerufen werden

Ok danke Stefan,  Fehler behoben Big Grin
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Login auf Homepage funktioniert nicht Giga 5 2.354 04.09.2014, 14:18
Letzter Beitrag: Devidra
  Problem mit der Onlinliste auf der Homepage toby01 5 1.872 14.10.2009, 20:05
Letzter Beitrag: toby01
  Login auf Homepage DerBeste 3 1.912 25.06.2008, 13:53
Letzter Beitrag: StefanT