Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.14 veröffentlicht (30.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Diskussion: MyBB 1.6.7 veröffentlicht
#21
Wenn 70 Bugs auisgebssert wurden wurde anscheinen Nr. 71 vergessen.

Falscher Autorisierungscode! Greifen Sie auf diese Funktion auf die übliche Weise zu? Bitte gehen Sie zurück und versuchen Sie es erneut.

Liegt nämlich nicht an den Styles, die wären sonst alle Fehlerhaft, was bei Version 1.5 noch alles Funktioniert hat.

Selbst Smilies lassen sich nach dem Aktualisieren nicht Anklicken für nen Posting.
Zitieren
#22
(02.04.2012, 14:09)forenschreck schrieb: Liegt nämlich nicht an den Styles, die wären sonst alle Fehlerhaft, was bei Version 1.5 noch alles Funktioniert hat.
a) Es gab nie eine Version 1.5.
b) Die Themes nicht nicht fehlerhaft, sie sind veraltet, deswegen hast du diese Probleme. Aktualisierte Templates müssen zurückgesetzt werden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#23
Wo soll das zurrücksetzen gemacht werden ?

EDIT:
Gefunden, aber zurücksetzten geht auch nicht, es lassen sich auch nicht den phpcode änder. Nach Abspeichern ist immer wieder das alte da.
Zitieren
#24
Kannst du das Problem bitte genauer beschreiben?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#25
Ich ändere den Code damit die Anzeige aktualisiert wird, so wie es ja hier beschrieben ist, setzte es ein, speichere es und nichts wird aktualisiert, bleibt alles beim alten.
Zitieren
#26
Was meinst du mit "den Code"? Kannst du die Templates nicht einfach zurücksetzen? Hast du mal einen anderen Browser probiert?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#27
Zu dem Thema gibt es bereits einen aktuellen Thread: https://www.mybb.de/forum/thread-25224-page-2.html
Dort hat Stefan auch bereits beschrieben was gemacht werden muss.
Um dir aber sagen zu können, welches Template genau zurückgesetzt werden muss, müssten wir wissen bei welcher Aktion genau der Fehler auftritt, welchen Style du benutzt und am besten wäre es sogar wenn du uns einen Link zu deinem Forum geben kannst.
Zitieren
#28
Bei mir hat alles soweit problemlos geklappt! Danke für die viele Mühe Smile
Zitieren
#29
Die Aktualisierung hat bei mir auch wunderbar geklappt.
Aaaaber ... beobachtet jemand sonst ebenfalls das Problem, wenn die Login-Option für Benutzer auf Email bzw. Email oder Benutzername eingestellt ist, eine leere Aktivierungsmail versand wird?

Ich habe nun seit etwa 12 Stunden dieses Forum und Google nach den möglichen Gründen für diesen Fehler durchforstet und bin erst beim erneuten Durchlesen der Changelog-Dokumentation darauf gestoßen. Dumm, dass ich - neugierig, wie ich bin - natürlich gleich auf die Doppel-Variante umgeschaltet hatte, nachdem ich aktualisiert hatte ....Blush

Leider führt das eben zu o. g. Problem. Wenn es wieder auf die default-Einstellung (Benutzername als Login-Angabe) eingestellt ist, funktioniert das wieder ohne Probleme!

Leider bin ich vor etwa 10 Minuten erst auf den Trichter gekommen, dass dies an den noch fehlenden Sprachpaketen liegt (und insgeheim vermisse ich doch sehr den ausdrücklichen Hinweis darauf in der Veröffentlichungsankündigung).

Es fehlt im Sprachpaket zu messages.lang.php nämlich für die o. g. neue Option die Definition für die Sprachvariablen email_activateaccount1 und email_activateaccount2!
Ich selbst verwende u. a. Polnisch, Deutsch_Du und Deutsch_Sie.

Analog der Variablendefinition für email_activateaccount ist in der Sprachdatei also der Code entsprechend zu ergänzen, d. h. den unten genannten Code praktisch zu kopieren und mit der erweiterten Variable email_activateaccount1 bzw. email_activateaccount2 sowie den zusätzlichen Optionen zu versehen.

PHP-Code:
$l['email_activateaccount1'] = "Hallo {1},

um die Registrierung bei {2} abzuschließen, musst du die folgende URL in deinem Browser Ã¶ffnen:

{3}/member.php?action=activate&uid={4}&code={5}

Nur wenn der o.a. Link nicht funktioniert, gehe zu:

{3}/member.php?action=activate

Du musst dann die folgenden Daten eingeben:
Deine E-Mail-Adresse
Aktivierungscode: {5}

Vielen Dank,
{2}-Team"


bzw.

PHP-Code:
$l['email_activateaccount2'] = "Hallo {1},

um die Registrierung bei {2} abzuschließen, musst du die folgende URL in deinem Browser Ã¶ffnen:

{3}/member.php?action=activate&uid={4}&code={5}

Nur wenn der o.a. Link nicht funktioniert, gehe zu:

{3}/member.php?action=activate

Du musst dann die folgenden Daten eingeben:
Benutzernamen: {1} oder Deine E-Mail-Adresse
Aktivierungscode: {5}

Vielen Dank,
{2}-Team"


So funktioniert auf jeden Fall dann schon mal die Registrierung mit der neuen Option. Allerdings fehlen noch z. B. die Sprachvariablen für die Anmeldeseite usw. Ich kann daher allen, die das MyBB in der Version 1.6.7 nicht auf englisch nutzen dringend davon ab, das Login mittels E-Mail-Adresse einzuschalten! Es sei denn , Ihr aktualisiert die entsprechenden Sprachdateien ggf. selbständig mit. u. a. den Vorschlag von mir hier (damit hab ich's getestet und hat auch einwandfrei funktioniert).

Greets
Zitieren
#30
Du kannst doch aber hier:
https://www.mybb.de/downloads/
auch nur die deutschen Sprachpakete runterladen, dann kann man es doch in vollem Umfang nutzen, oder verstehe ich da was falsch?
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Diskussion: MyBB 1.8.14 veröffentlicht Jockl 12 834 25.12.2017, 19:17
Letzter Beitrag: bromance
  Diskussion: MyBB 1.8.13 veröffentlicht StefanT 52 2.590 01.12.2017, 22:22
Letzter Beitrag: Amunette
  Diskussion: MyBB 1.8.12 veröffentlicht StefanT 31 3.919 08.10.2017, 17:53
Letzter Beitrag: bv64
  Diskussion: MyBB 1.8.11 veröffentlicht StefanT 29 2.308 16.04.2017, 20:19
Letzter Beitrag: sjfm
  Diskussion: MyBB 1.8.10 veröffentlicht StefanT 21 2.602 05.02.2017, 21:24
Letzter Beitrag: StefanT