Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Ajax Chat Problem
#21
(11.12.2010, 23:18)Michael schrieb: Dass MyBB 1.6 PHP5 benötigt wurde immer öffentlich angekündigt (erstmals bestimmt schon vor einem Jahr).
Ende 2007 wurde das angekündigt, wie auch bei vielen anderen Scripten, da es PHP 5 schon seit 2004 gibt. 2008 wurde die Entwicklung von PHP 4 dann eingestellt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#22
Boah... Leute...Nun mal nichts für ungut. PHP5 & MySQL5 sind doch nicht das Problem.

Ich habe mit keinem Wort gesagt das ich nicht unter PHP5 installieren kann. Wo steht denn dies ? Ich habe auch nicht gesagt das MyBB nichts taugt. Ich habe ausgedrückt das es an Kompatibilität bei den Versionen mangelt. Sicherlich ist der AjaxChat nicht vom MyBB-Team. Aber, bei solchen bekannten Plug-Ins sollte schon geprüft werden ob es Probleme gibt.


Das Problem liegt eindeutig in Versionen von MyBB. Der Ajax-Chat lief hervorragend unter MyBB 1.2nn. Auch die neue Version. Der Chat läuft aber nicht mehr unter 1.4x. Mit unterschiedlichen Fehlermeldungen bei den gängigen Browsern.

Hier gibt es halt diese Probleme. Ist doch hier im Forum nachzulesen. Nur, was nutzt dem geneigten User ein Link nach dem anderen quer durch dieses und andere Foren wo wohl ansatzweise "Lösungen" zu dieser Problematik stehen sollen. Nichts für ungut aber schon mal so 6-7 neue Tabs/Fenster auf gehabt um klar zu kommen wer nun was warum wieso zum und nicht zum Thema schreibt? Gewschweige denn in diesem Fenstergedöns eine eventuell vorhandene Lösung zu finden ?

Zur Fragestellung des Problems kam hier nichts. Aber zum Thema PHP.. da kommen längst bekannte Statements. Naja, immerhin wurde so deutlich das Beiträge gelesen werden.

Thema V1.6:
Ich habe diwe Fehlermeldung nicht mehr im Gedächtnis. Genau deshalb hab ich gerade eine neue DB angelegt um die Installation nochmals nach zu vollziehen.
Zitieren
#23
Dieses Plugin ist wirklich schlecht programmiert, das kannst du aber nicht dem MyBB zuschreiben. Und wenn du unterschiedliche Fehler in verschiedenen Browsern hast, gibt es Probleme mit dem Javascript, worauf das MyBB nun wirklich keinen Einfluss hat.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#24
OK. Die einen schreiben das Ajax ohne Probs läuft, andere haben Probleme.

Dann vielleicht mal eine Frage zu einer guten alternative zum Ajax-Chat. Welcher Chat ist nutzbar und greuift auf in MyBB registrierte Benutzer zurück?

Und eine Frage Thema V1.6:

Folgende Meldung kommt nach der Übertrragung zum Host:
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/25/d13552193/htdocs/WRfrikadlle/forum16/inc/class_core.php on line 18

Zu dieser Meldung gibt es hier im Forum viele Unterschiedliche Antworten. Da es aber bei einer Neuinstallation auftaucht kann es keine Modifikation sein.

Ich habe auch die die htaccess um den Zusatz für PHP5 ergänzt. Hier gibt es ja ebenfalls unterschiedliche Ansätze.
<Files ~ "\.php">
SetHandler x-httpd-php5
</Files>


Mit dem Ergebnis das ich die Install-PHP als Listing angezeigt bekomme. Siehe hier:
http://www.webradio-frikadelle.de/forum16/install/

Das alles passiert auf einem Server von 1und1.
Was kann noch getan werden ?


Auf einem Netclusive-Server reicht die Anweisung
<Files ~ "\.php">
SetHandler x-httpd-php5
</Files>
in der htaccess. Denn dann kommt der Begrüßungsbildschirm. Dumm dabei das sich die Domain bei 1und1 befindet. Sonst hätte ich es bei Netclusive aufgebaut.
Zitieren
#25
Zum php-Handling - versuch's mal mit

Code:
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

in der .htaccess. So klappt's auf meiner Seite, allerdings läuft dort kein MyBB, sondern nur ein CMS.

S. auch http://hilfe-center.1und1.de/hosting/scr...hp/17.html
MfG,
Mithrandir

MyBB 1.6 im Intranet unter Ubuntu 10.04.1 Server
Zitieren
#26
Diese Meldungen kommen, wenn noch PHP4 als Standard läuft... Da gibt es bei jedem Hoster andere Lösungswege. Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#27
(12.12.2010, 14:37)Mithrandir schrieb: Zum php-Handling - versuch's mal mit

Code:
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

in der .htaccess. So klappt's auf meiner Seite, allerdings läuft dort kein MyBB, sondern nur ein CMS.

S. auch http://hilfe-center.1und1.de/hosting/scr...hp/17.html

Korrekt. Hatte ich schon mal probiert. Nur, genau dann gibt es diese Fehlermeldung:

Fatal error: require_once() [function.require]: Failed opening required '/homepages/25/d13552193/htdocs/WRfrikadlle/forum16/inc/class_core.php' (include_path='.:/usr/lib/php5') in /homepages/25/d13552193/htdocs/WRfrikadlle/forum16/install/index.php on line 40

Denn an der Stelle sagt 1und1 eindeutig: ... das parsen zwischen php4 und 5 wird mit dieser Ergänzung gesteuert. Beide PHP-Version benutzen dieselbe PHP.ini

Sollten nach diesem Eintrag noch Probleme ergeben liegt an an der verwendeten Software.
(12.12.2010, 14:38)StefanT schrieb: Diese Meldungen kommen, wenn noch PHP4 als Standard läuft... Da gibt es bei jedem Hoster andere Lösungswege. Wink

Nee, nicht ganz. Andere PRGs laufen in der Art mit php5....
Zitieren
#28
Hast du die Datei inc/class_core.php umbenannt?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#29
Hattest du den Versuch schon beschrieben? Dann hatte ich das überlesen.

Was mich wundert, wenn ich versuche,

http://www.webradio-frikadelle.de/forum1...s_core.php

zu öffnen, springt die Adresse auf
...class_core.php5

um - da scheint irgendetwas noch nicht zu stimmen.


Nachtrag - das war bis vor ein paar Minuten so. Nun sieht's ja besser aus (ich sehe nun unter /forum16/install die Installationsseite).
MfG,
Mithrandir

MyBB 1.6 im Intranet unter Ubuntu 10.04.1 Server
Zitieren
#30
Umbenannt habe ich noch nichts. Ist ja eine Neuinstallation der V1.6 zum testen der Installation.

Dieses kurzzeitige Umbennen in *php5 der Datei war nur ein Test um herauszufinden ob sich dann etwas ändert. Rein theoretisch könnte ich ja alle Dateien in php5 ändern. Dann sollte es auf jeden Fall funktionieren.

Doch. Ich hatte einen Fehler gemacht. Ich hätte die htaccess im Hauptverzeichnis ändern müssen. Das Forum selbst liegt im Unterverzeichnis. Das war mein "Kaspar".....

Werde nun mal testweise installieren um zu sehen ob das Hauptproblem, der Chat dann mit 1.6 läuft...


Tja. Die V1.6 läüft. Das Problem mit dem Ajax-Chat bleibt.

Daher noch mal die Frage:
Welchen Chat kann ich alternativ nehmen ? Immer im Bezug das nur registrierte Benutzer des Forums die nutzen können ?
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Ajax Chat @Frog hkkp 4 323 13.04.2016, 18:25
Letzter Beitrag: Yamek89
  "Who is in Ajax Chat"-Plugin für MyBB 1.8.4? Paccy 11 878 15.09.2015, 18:46
Letzter Beitrag: hkkp
  Wie im AJAX-Chat bestimmte Benutzgruppen ausschließen? Koelner 14 669 20.03.2015, 08:16
Letzter Beitrag: Koelner
  Ajax-Chat - Gäste ausschließen. Koelner 30 4.722 21.09.2014, 00:46
Letzter Beitrag: Dana
  Ajax Chat integration nyukuri 5 1.921 17.03.2014, 11:49
Letzter Beitrag: hkkp