Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Coppermine Bilder Upload Problem
#11
(03.02.2020, 10:36)itsmeJAY schrieb: Die Fehlermeldung kann schon dazu führen das keine Einträge erstellt oder bearbeitet werden können. Desweiteren muss die jeweilige Tabelle einen Primärschlüssel haben und nicht "eine Spalte".

Ich weiß nicht wie das Plugin aufgebaut ist aber es würde theoretisch reichen eine Spalte am Anfang der Tabelle hinzufügen mit z. B. dem Namen "id" als primary key mit auto increment.

Und wie und wo bewerkstellige ich das? Wie gesagt von SQL habe ich wenig Ahnung.

Habe jetzt im phpmyadmin unter Operationen: Analysiere, Überprüfe, Optimiere und Repariere Tabelle ausgeführt da passier aber auch nix.

Wie ich auch gerade gesehen habe besteht das Problem mit " Die aktuelle Markierung enthält keine eindeutige („unique“) Spalte" in allen Coppermine Tabellen, wie undf warum das so ist verstehe ich zwar nicht ist aber so  Big Grin
Zitieren
#12
du hast doch sicher ein Backup (Datenbank UND FTP) von vor dem Update

geh mal zurück auf die alte Version, schau, ob die Tabellen da in Ordnung sind und dann neuer Versuch
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#13
Ich habe das gerade mal bei mir geprüft.
Es hat nahezu jede Tabelle eine ID mit mit auto increment.
Schau Dir mal die Struktur der Tabellen an und dort Zeile 1.

Wahrscheinlich ist es wirklich sinnvoller nochmals ein altes Backup zurückzuspielen.
Zitieren
#14
Ich habe eigentlich die SQL Backup Funktion von mybb im ACP aktiviert aber leider feststellen müssen das die Copperminne Tabellen trotz gleicher Datenbank nicht mit exportiert werden, somit liegt leider kein sql Backup der Galerie vor Angry .

Tabelle pictures sieht in Strukturansicht z. B. so aus

   
Zitieren
#15
puh, da fehlt der Primärkey, die Indizes und das Autoincrement
und du sagst, dass das bei allen Tabellen so ist?

für den Primärkey und die Indizes folgendes ausführen, DEINPRÄFIX natürlich ersetzen:
PHP-Code:
ALTER TABLE `DEINPRÄFIX_pictures`
  
ADD PRIMARY KEY (`pid`),
  
ADD KEY `owner_id` (`owner_id`),
  
ADD KEY `pic_hits` (`hits`),
  
ADD KEY `pic_rate` (`pic_rating`),
  
ADD KEY `aid_approved` (`aid`,`approved`),
  
ADD KEY `pic_aid` (`aid`,`pid`); 

für das Autoincrement folgendes ausführen:
PHP-Code:
ALTER TABLE `DEINPRÄFIX_pictures`
  
MODIFY `pidint(11NOT NULL AUTO_INCREMENTAUTO_INCREMENT=XXX;
COMMIT
das XXX durch die nächste zu vergebende pid ersetzen; wenn die letzte vergebene pid also z.B. 643 ist, setzt du XXX auf 644

Das behebt natürlich nur den Schaden an der pictures-Tabelle, für die anderen Tabellen müsste man dann schauen, was da an Keys, Index, Autoincrement in einer korrekten Installation gesetzt ist. Vielleicht installierst du dir dafür ein zweites Coppermine, dann kannst du die Tabellen vergleichen. Die Befehle oben dann entsprechend anpassen.
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#16
Ja das betrifft irgendwie alle coppermine Tabellen.

Ok danke erstmal bis hier hin, ich werde es mir morgen noch mal genau anschauen und coppermine local neu installieren.
Zitieren
#17
(03.02.2020, 22:38)lenox schrieb: Ich habe eigentlich die SQL Backup Funktion von mybb im ACP aktiviert aber leider feststellen müssen....

Möglich, dass MyBB nur die Tabellen mit den eigenen Präfix sichert.
Schau mal in Dein Webhosting-Paket. Je nach Paket machen die Hoster selbstständig DB-Backups oder auch nicht.
Damit und mit dem Backup der ftp-Daten könntest Du erstmal die alte Version wieder herstellen.
Zitieren
#18
(03.02.2020, 22:38)lenox schrieb: Ich habe eigentlich die SQL Backup Funktion von mybb im ACP aktiviert aber leider feststellen müssen das die Copperminne Tabellen trotz gleicher Datenbank nicht mit exportiert werden...
Ops, das würde ja bedeuten das MyBB nicht die Datenbank zu 100% sichert, sondert sich auf die eigenen Tabellen beschränkt.

Puuh, da bin ich doch froh dass ich seit Beginn einen täglichen Cronjob erstellt und aktiviert habe. Dieautomatische tägliche Sicherung wird automatisch bei einem anderen FTP-Account gespeichert, wo alle Sicherungen (> 10 Tage) automatisch gelöscht werden.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#19
Finde > 10 etwas knapp oder? Ich lass meine BA 3 Monate auf einem separaten Server bis diese automatisiert gelöscht werden.
Zitieren
#20
(04.02.2020, 09:01)Gerti schrieb: Ops, das würde ja bedeuten das MyBB nicht die Datenbank zu 100% sichert, sondert sich auf die eigenen Tabellen beschränkt.

Da gehe ich von aus. Du kannst es testen, indem Du im ACP eine manuelle Sicherung machst.
Hier werden Dir die Tabellen angezeigt, die auswählbar sind.

Grüße
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Coppermine Bridge - Batch Upload Pascal 3 2.129 26.05.2009, 15:08
Letzter Beitrag: Pascal
  Coppermine Problem Hecktro 3 1.347 08.11.2008, 20:37
Letzter Beitrag: eneR
  Coppermine Bridge Login-Problem Domic 7 2.769 26.03.2008, 11:41
Letzter Beitrag: StefanT
  Bilder Upload brudaa 7 1.773 01.10.2007, 18:09
Letzter Beitrag: schwyps
  Upload-Plugin für Bilder bleem 4 1.333 27.04.2007, 01:21
Letzter Beitrag: Michael