Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[G] Behandlung vom Umlauten bei Inlinebearbeitung
#41
Crystal schrieb:
typhos schrieb:Und zwar habe ich inline einen Beitrag bearbeitet, der ein €-Zeichen enthielt. Beim Speichern wurde das €-Zeichen und der komplette Rest des Beitrags einfach abgeschnitten, es wurde also nur der Text vor dem €-Zeichen gespeichert.

Das Bearbeiten per Editor funktioniert allerdings einwandfrei.
Wollte nur bekannt geben, dass exakt der gleiche Fehler bei mir auch auftaucht.
Sowohl unter V1.2.0 als auch unter V1.2.1

Auch bei mir ist das Editieren mit dem Editor und dem Eurozeichen kein Problem, nur die Inline-Bearbeitung schafft es nicht.

Dachte mir gerade, ich melde es auch, damit die Entwickler nicht denken, dass das ein Einzelfall ist. Smile

Entschuldigung, dass ich das hier nochmal aufgreife. Die Probleme mit den Umlauten scheinen ja nun gelöst. Allerdings ist genau obiges Problem mit dem Eurozeichen ("€") noch vorhanden. Gibt es da Hoffnung auf eine Lösung oder ist das ein grundsätzliches Problem. Ich weiß nun aus dem Stehgreif auch nicht, ob bzw. in welcher Form das Eurosymbol im Zeichensatz ISO 8895-1 enthalten ist.

Komisch ist auch, dass alle Zeichen nach dem Eurosymbol (besser: inklusive des "€") nur im Inline-Editor abgeschnitten werden und es im "normalen" Editor jedoch ganz normal funktioniert.

Ab und zu diskutiert man ja über Preise und mir ist es blöderweise schon ein paar Mal passiert, dass ich nach Korrektur eines einfachen Tippfehlers fast den ganzen Text verloren habe, weil ich nicht an das Eurozeichen im Text gedacht habeRolleyes Das ist schon nervig!

Ich weiß, dass das kein direktes Funktionsproblem des MyBB darstellt und auch kein schwerwiegendes und/oder Sicherheitsproblem ist.

Ich wollte nur mal hören, ob dafür überhaupt eine Lösung in Sicht ist.
Das Problem tritt mit allen von mir benutzten Browsern auf (IE6, IE7, Firefox 1.5, Firefox 2.0).

Gruß
Boardie05
#42
Das Eurozeichen, das wird ja bei dem inlinethred bearbeiter abgeschnitten und beim richtigen editor nicht.
Ich glaub das kommt davon weil der inlinethred editor aus javascript besteht und der andere nicht.
Sapd
Eine Arbeit ist nie vollendet, es gibt immer was zu verbessern
#43
Ja gut, aber dann müsste der Inline(-JavaScript)-Editor das Eurozeichen fälschlicherweise quasi als "end of file" (habe leider keine andere Analogie parat...) erkennen, oder? Und wenn das so wäre, dann müsste sich dieses Problem ja recht einfach beheben lassen.

Allerdings ist das alles sehr spekulativ.

EDIT: Habe mich gerade mal im englischen Forum (mybboard.net) umgesehen. Dort ist dieses Problem ja schon gemeldet und wird wohl auch schon länger diskutiert. Scheinbar, wenn ich das alles richtig verstehe, tritt das Prolem mit einer Zeichenkodierung in UTF-8 nicht auf. Wenn das so ist, hat UTF-8 ja in dieser Hinsicht und auch in Hinsicht auf alle möglichen anderen Sonderzeichen einen deutlichen Vorteil, auch weil der Zeihensatz wesentlich umfangreicher ist. Nur: Ich kann ja nicht einfach auf UTF-8 umstellen, weil dann alle bisherigen in ISO 8859-1 kodierten Sonderzeichen und Umlaute falsch dargestellt werden. Wäre vielleicht der Ansatz eines Konverters für MyBB + Datenbank von ISO 8859-1 nach UTF-8 sinnvoll oder überhaupt durchführbar? Dann könnte man in Zukunft UTF-8 nutzen und wäre solche Pobleme los.

Gruß
Boardie05
#44
Ähm nö eigentlich nicht. Beim abschicken der bearbeitung wird das € zeichen nur falsch umgewandelt, denke ich
Sapd
Eine Arbeit ist nie vollendet, es gibt immer was zu verbessern
#45
Boardie05 schrieb:EDIT: Habe mich gerade mal im englischen Forum (mybboard.net) umgesehen. Dort ist dieses Problem ja schon gemeldet und wird wohl auch schon länger diskutiert. Scheinbar, wenn ich das alles richtig verstehe, tritt das Prolem mit einer Zeichenkodierung in UTF-8 nicht auf. Wenn das so ist, hat UTF-8 ja in dieser Hinsicht und auch in Hinsicht auf alle möglichen anderen Sonderzeichen einen deutlichen Vorteil, auch weil der Zeihensatz wesentlich umfangreicher ist. Nur: Ich kann ja nicht einfach auf UTF-8 umstellen, weil dann alle bisherigen in ISO 8859-1 kodierten Sonderzeichen und Umlaute falsch dargestellt werden. Wäre vielleicht der Ansatz eines Konverters für MyBB + Datenbank von ISO 8859-1 nach UTF-8 sinnvoll oder überhaupt durchführbar? Dann könnte man in Zukunft UTF-8 nutzen und wäre solche Pobleme los.

Gruß
Boardie05

Sorry für's pushen dieses Beitrages. Vielleicht wurde auch mein EDIT übersehen, da es sich zeitlich mit Sapd überschnitt.
Meint jemand, dieser Ansatz wäre vernünftig und auch machbar? Soweit ich es dem englischen Board entnehmen konnte, tritt dieser Effekt nicht nur beim Eurozeichen auf, sondern auch bei anderen Sonderzeichen, z.B bei Anführungszeichen. Mit UTF-8 soll es angeblich gehen.

Gruß
Boardie05
#46
Wie du selbst erkannst hast liegt das Problem bei schon vorhandenen Datenbankeinträgen, hier würden alle Sonderzeichen falsch dargestellt werden. Man kann das Encoding der Datenbank ändern, allerdings gibt es dafür kein fertiges offizielles Skript.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#47
Danke für die Antwort, Michael.

Nun frage ich mich natürlich, wie ich meine Datenbank und mein Forum auf UTF-8 umstellen kann.

Ist das so möglich:
  • Ich mache ein Backp aller Datenbank-Tabellen über das MyBB-Admin-CP und lade diese Datei als .gz auf meinen PC herunter
  • Ich mache mir von dieser Datei eine Sicherungskopie, die "für alle Fälle" unverändert bleibt (z.B. in anderem Ordner auf meinem PC).
  • Ich entpacke die in der .gz-Datei enthaltene Datei und hänge ihr die Endung .sql an (oder auch .txt ....)
  • Danach öffne ich diese (Text- bzw. SQL-) Datei in MS Notepad (mein Windows-Editor) (Hinweis: bei mir liegt die Datei bei oben beschriebenem Vorgehen im ANSI-Format vor)
  • In Notepad wähle ich "Speicher unter..." und wähle dort als Format "UTF-8" aus. Dann speichere ich die Datei ab.
  • Nun sollte meine SQL-Datei im UTF-8-Format gespeichert vorliegen
  • Diese SQL-Datei kann ich nun wieder in meine Datenbank importieren (z.B. mit BigDump). Beim Importieren muss ich alle bereits bestehenden Tabellen überschreiben.
  • Nun muss ich im Admin-CP nur noch die Kodierung UTF-8 anstatt ISO-8859-1 einstellen (unter "Sprachpakete verwalten"->Eigenschaften von "Deutsch Du"->Encoding)

Ich habe das noch nicht ausprobiert. Ist das so überhaupt machbar? Ich will es nicht einfach blind an meinen bestehenden Foren ausprobieren.

Gruß
Boardie05
#48
Question 
Hallo, ich bin durch die SuChe auf diesen Beitrag gestoßen, da ich in unserem MyBB das gleiche Problem mit dem Inlineeditor, den Umlauten und dem Eurozeichen habe.

Hat es denn nun geklappt, Boardie, oder gibt es inzwischen eine bessere Lösung ?

Kann mir jemand sagen, wo ich den Inline-Editor KOMPLETT für alle User/Mods/Admins ausschalten kann ?
=>> BLUEMOON'S endgeiles ARCADE-Spiele-Board <<=

[Bild: OBST-BANNER.jpg]

Klick auf das Bild um mit uns um die Highscores zu kämpfen !
#49
Leider hatte ich noch nicht die Zeit zum Ausprobieren. Mein Forum läuft ja ansonsten.
Ich werde dass mal auf einem lokalen Server probieren, aber erst wenn ich die Zeit dazu habe. Momentan wird das leider nichts.
Eine Antwort schreibe ich dann hier rein.

Elrond schrieb:Kann mir jemand sagen, wo ich den Inline-Editor KOMPLETT für alle User/Mods/Admins ausschalten kann ?
Im Admin-CP scheint es keine Möglichkeit dafür zu geben. Vielleicht kann dir jemand vom Support mehr schreiben. Ich weiß auch nicht, wie tief diese Funktion verankert ist oder ob man nur irgendwo eine Variable auskommentieren oder anders setzen muss.

Gruß
Boardie05
#50
Boardie05 schrieb:Im Admin-CP scheint es keine Möglichkeit dafür zu geben. Vielleicht kann dir jemand vom Support mehr schreiben. Ich weiß auch nicht, wie tief diese Funktion verankert ist oder ob man nur irgendwo eine Variable auskommentieren oder anders setzen muss.

Ich hab bisher auch nichts gefunden. Ich werd dann mal in den Templates suchen, ob ich den Link da finde und entfernen kann Smile

Danke für die schnelle Antwort Wink
=>> BLUEMOON'S endgeiles ARCADE-Spiele-Board <<=

[Bild: OBST-BANNER.jpg]

Klick auf das Bild um mit uns um die Highscores zu kämpfen !


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [NG] Inlinebearbeitung löscht Texts aus Posts Tored 40 8.383 12.04.2007, 22:33
Letzter Beitrag: Michael
  [G] Fehler in Inlinebearbeitung Freshmaker_01 3 984 19.11.2006, 13:09
Letzter Beitrag: greg
  [NG] Fehlerhafte Behandlung vom Komma in der Forenbeschreibung Eugenie 6 1.285 14.07.2006, 17:27
Letzter Beitrag: Eugenie