Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.21 veröffentlicht (11.06.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Mitglieder-Karte 1.2
Hi. Hab eben versucht die gesplittete Version von OpenGeoDB bei mir zu importieren, hat auch ganz gut geklappt.. bis auf die letzte Datei. Bei der bekomme ich immer folgenden Fehler:
MySQL-ERROR
Fehler bei der Anfrage:

create index tid_tnames_idx on geodb_type_names(type_id);
MySQL meldet:

INDEX command denied to user 'web84'@'localhost' for table 'geodb_type_names'

Hat da vielleicht jemand eine Idee,was ich falsch gemacht/eingestellt habe? (Hab auch schon versucht die große OpenGeoDB Datei per MySqlDumper zu importieren, bekomme aber den gleichen Fehler).
Zitieren
Das heißt das, was die Fehlermeldung sagt: Du darfst den Befehl "INDEX" nicht ausführen. Wenn die Karte ohne die letzte Datei nicht funktioniert, musst du den Hoster kontaktieren.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
Habe ein wenig herumexperimentiert und jetzt das ganze irgendwie zum Laufen gebracht.
Zwei Fragen:

wenn mehrere Orte gefunden werden, dann werden manche Orte ziemlich klein und fast unleserlich angezeigt. Gibt es da eine Lösung?

Und ich habe jetzt einige Testeinträge auf der Karte. Kann ich irgendwie alle bisher eingetragenen User löschen ohne alles neu installieren zu müssen?

DANKE!
Zitieren
Leere die Tabelle mybb_membermap (mybb_ durch dein Präfix ersetzen).
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
danke!
Zitieren
Hallo Freunde

Habe heute die Mitglieder-Karte 1.1 UTF-8 in meinem Kleinen Forum
www.forum-airbrush.com eingebunden bekommen.
Nach einem steinigen Anlauf, natürlich aus Unkenntnis, klappt es jetzt tadellos.
Habe auch die gesplittete OpenGeoDB verwendet und einzeln der Reihe nach in meinem
mySQL importiert(da lag vorher der Hase im pfeffer)... Alle anderen Dateien wie beschrieben platziert.

Ich habe eingesetzt:

Mitglieder-Karte 1.1 UTF-8
mySQL 5.0.45
PhP 5.22
myBB version 1.2.10

Bis auf das bekannte Problem mit den Umlauten
z.B. Koln anstatt Köln eingeben...
Funktioniert es tadellos...


Ein dickes Lob Michael Richter
Danke Big Grin
Zitieren
Hallo Zusammen,

kann mir vieleicht jemand bei meinem Problem helfen?
Wenn ich den Link "Karte" anklicke bekomme ich folgende
Anzeige: #membermap_locinfo td{

Die Datenbank scheint aber erreichbar zu sein, denn wenn ich folgendes im
Browser aufrufe: http://www.mein-forum.de/forum/membermap.php?q=Ort

erhalte ich diese Anzeige. Was mache ich nur Falsch?!?

Vielen Dank im vorraus
Ralf


Mit dieser XML-Datei sind anscheinend keine Style-Informationen verknüpft. Nachfolgend wird die Baum-Ansicht des Dokuments angezeigt.

?
<results>
?
<result>
<id>35347</id>
<name>Bekkevoort</name>
<trace0>Belgique</trace0>
<trace1>Vlaanderen</trace1>
<trace2>Leuven</trace2>
</result>
?
<result>
<id>32573</id>
<name>Bekkevoort</name>
<trace0>Belgique</trace0>
<trace1>Vlaanderen</trace1>
<trace2>Leuven</trace2>
<trace3>Bekkevoort</trace3>
</result>
?
<result>
<id>35350</id>
<name>Boortmeerbeek</name>
<trace0>Belgique</trace0>
<trace1>Vlaanderen</trace1>
<trace2>Leuven</trace2>
</result>
?
<result>
<id>32694</id>
<name>Boortmeerbeek</name>
<trace0>Belgique</trace0>
<trace1>Vlaanderen</trace1>
<trace2>Leuven</trace2>
<trace3>Boortmeerbeek</trace3>
</result>
?
<result>
<id>32854</id>
<name>Cortil-Noirmont</name>
<trace0>Belgique</trace0>
<trace1>Wallonie</trace1>
<trace2>Nivelles</trace2>
<trace3>Cortil-Noirmont</trace3>
</result>
?
<result>
<id>32855</id>
<name>Cortil-Wodon</name>
<trace0>Belgique</trace0>
<trace1>Wallonie</trace1>
<trace2>Virton</trace2>
<trace3>Cortil-Wodon</trace3>
</result>
?
<result>
<id>35399</id>
<name>Kortemark</name>
<trace0>Belgique</trace0>
<trace1>Vlaanderen</trace1>
<trace2>Diksmuide</trace2>
</result>
?
<result>
<id>33615</id>
<name>Kortemark</name>
<trace0>Belgique</trace0>
<trace1>Vlaanderen</trace1>
<trace2>Diksmuide</trace2>
<trace3>Kortemark</trace3>
</result>
?
<result>
<id>35362</id>
Zitieren
Du kannst mir ja mal die URL geben, dann schau ich mal.
Dieser Satz ist falsch!
Zitieren
http://www.german-woodturners.de/forum/m....php?q=ort
Zitieren
Das Template "map" scheint beschädigt zu sein. Die XML-Ausgabe ist normal. Ersetze das Template mit:
Code:
<html>
<head>
<title>{$mybb->settings['bbname']} - {$lang->nav_membermap}</title>
{$headerinclude}
<script type="text/javascript" src="jscripts/membermap.js"></script>
<script type="text/javascript">
var membermap_isuser = {$membermapisuser};
{$membemap_lang}
</script>
<style type="text/css">
#membermap_locinfo td
{
font-size: 80%;
}
</style>
</head>
<body>
{$header}

<table width="100%">
<tr>
<td valign="top" height="1">

<table width="100%" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" border="0" align="center" class="tborder">
<tr>
<td class="thead" align="center"><strong>{$lang->infos}</strong></td>
</tr>
<tr>
<td class="trow1">
<div id="membermap_mapinfo">
<i>{$lang->infodesc}</i>
</div>
</td>
</tr>
</table>
<br/>
<table cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" border="0" align="center" class="tborder">
<tr>
<td class="thead" align="center"><strong>{$lang->search_loc_user}</strong></td>
</tr>
<tr>
<td class="trow1" align="center"><nobr>
<input type="text" name="q" id="membermap_q" style="width:98%"/><br/>
<input type="button" value="{$lang->search_loc}" onclick="Membermap.search(document.getElementById('membermap_q').value)"/>
<input type="button" value="{$lang->search_user}" onclick="Membermap.searchuser(document.getElementById('membermap_q').value)"/>
</nobr></td>
</tr>
<tr>
<td class="tcat" align="center"><strong>{$lang->found_locs_users}</strong></td>
</tr>
<tr>
<td class="trow2">
<div id="membermap_results" style="padding:4px">
<i>{$lang->found_desc}</i>
</div>
</td>
</tr>
<tr>
<td class="tcat" align="center"><strong>{$lang->loc_details}</strong></td>
</tr>
<tr>
<td class="trow1">
<div id="membermap_locinfo" style="padding:4px">
<i>{$lang->loc_details_desc}</i>
</div>
</td>
</tr>
</table>

</td>
<td width="60%" valign="top">

<table width="100%" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" border="0" align="center" class="tborder">
<tr>
<td class="thead" align="center"><strong>{$lang->map}</strong></td>
</tr>
<tr>
<td class="trow1" align="center" valign="middle">
<img src="?showmap=1" alt="" usemap="#membermap" id="membermap_map"/>
<map name="membermap">
{$membermapareas}
</map>

<div id="membermap_popup" style="position:absolute;display:none">
<table cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" border="0" class="tborder" style="width:200px">
<tr><td class="tcat" align="center"><div id="membermap_popup1"></div></td></tr>
<tr><td class="trow1" align="left"><div id="membermap_popup2"></div></td></tr>
</table>
</div>

<div id="membermap_cross" style="white-space:nowrap;position:absolute;display:none">
<img src="images/membermap/cross.gif" alt="" style="vertical-align:top"/>
<span id="membermap_crosstext" style="background-color:white;padding:1px;border:1px solid #81a2c4"></span>
</div>

</td>
</tr>
</table>

</td>
</tr>
</table>

{$footer}
</body>
</html>
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren