Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Login registrierter User funzt nicht
#41
Tritt das Problem auch bei anderen Benutzern deines Forums auf?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#42
Also ich hab schon sowas versucht bei mir funktionirts
Sapd
Eine Arbeit ist nie vollendet, es gibt immer was zu verbessern
#43
Ich habe gerade umfangreiche Tests zum login klappt nicht / klappt manchmal hinter mir und bin auf folgende Effekte gestoßen:
a: Die Domain in den Cookies (z.B. Domain: forum.mybboard.de/) muß mit der rufenden Domain (URL, oben in der Leiste) übereinstimmen. Der Zugriff z.B. mit xampp lokal bei "localhost" in ./inc/settings.php und der URL "MeinPC" oder 192.168.1.33 erzeugt den Fehler.
b: Damit der Cookie-Eintrag überhaupt und vollständig gemacht wird, muß die URL / der Domainname engen Grenzen genügen, was eher bei lokalen oder LAN-internen Installationen nicht der Fall sein kann. Der Name MUSS die Form aaa.bbb.ccc haben, wobei manchmal auch noch ".ccc" auf Ich habe gerade umfangreiche Tests zum login klappt nicht / klappt manchmal hinter mir und bin auf folgende Effekte gestoßen:
a: Die Domain in den Cookies (z.B. Domain: forum.mybboard.de/) muß mit der rufenden Domain (URL, oben in der Leiste) übereinstimmen. Der Zugriff z.B. mit xampp lokal bei "localhost" in ./inc/settings.php und der URL "MeinPC" oder 192.168.1.33 erzeugt den Fehler.
b: Damit der Cookie-Eintrag überhaupt und vollständig gemacht wird, muß die URL / der Domainname engen Grenzen genügen, was eher bei lokalen oder LAN-internen Installationen nicht der Fall sein kann. Der Name MUSS die Form aaa.bbb.ccc haben, wobei offiziell auch noch ".ccc" auf Toplevel-Zugehörigkeit geprüft wird (.de, .net, etc.). Details finden sich in der Beschreibung http://www.phpcenter.de/de-html-manual/ oder http://wp.netscape.com/newsref/std/cookie_spec.html .

Daraus ergeben sich folgende möglichen Lösungen:
- Wenn die IP des MyBB-Servers fest ist, kann man (durch Eintrag in die hosts-Datei[en]) einen zusätzlichen Namen vergeben (z.B. mybb.unserlan.net). Trägt man diesen auch in die ./inc/settings.php ( 'bburl' und 'cookiedomain') ein, funktioniert's.
- Hat man einen Linux-Server mit DHCP im Heim-Netz laufen und vergibt einen Namen der Form bbb.ccc an sein Netz, dann kann man den MyBB-Server über seinen DHCP-Hostnamen ansprechen: aaa.bbb.ccc .
- man legt, so man einen Zugang hat, MyBB auf einen Server im Internet. Damit sind die Adressen automatisch richtig.


Anmerkung: Die Frage, ob die MyBB-Dateien im root-Verzeichnis oder in einem Unterordner liegen, hat keine Rolle gespielt.

Anmerkung 2 an die Programmierer: Mir ist der Einsatz von Cookies an dieser Stelle unklar. Er bewirkt, daß ich mich nur einmal pro Rechner/Dektop einloggen kann. Ich kann also nicht den Browser nochmal aufmachen und als Administrator was testen; ich werde gleich als der (zuerst angemeldete) User angemeldet. Ich kann aber einen anderes Browserprogramm starten und dann doch mich noch mal anmelden, da die Cookies nur in einem Programm gelten. Habe ich gar Linux, kann ich mich in mehreren Sessions anmelden und beliebig viele User simulieren.
So stellt sich die Frage, was die Begrenzung durch Cookies hier bewirken soll, außer Probleme zu bereiten? Was soll eigentlich begrenzt werden?

Anmerkung 3: auch wenn sich obiges gegenteilig anhören mag: MyBB ist ein tolles Programm. Wenn es nicht so gut wäre, hätte ich mir die viele Mühe mit den Tests erst gar nicht gemacht. So kann ich es jetzt einsetzen.

viele Grüße

Ecki1954
#44
Vielen Dank für die Tests und die Ergebnisse.

Zu Anmerkung 2) Es handelt sich um keine Begrenzung es geht lediglich darum, dass die Cookies eindeutig dem Forum zugeordnet werden können. Wie man sieht gibt es Probleme wenn das nicht der Fall ist (gerade beim IE)

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#45
NetHunter schrieb:Cookie-Domain: .forum.4allplayers.org
Der Pfad ist so in Ordnung.


Also ich verstehe das nicht so genau?

Wo ändert man das denn?

Danke
#46
Admin-CP -> Foreneinstellungen -> Ändern -> Allgemeine Einstellungen.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#47
hi, ich habe das selbe problem. die adresse zum forum lautet: http://besentraeger.be.funpic.de//Spacep.../index.php

Die cookieeinstellungen sind folgende:
Cookiedomain: http://besentraeger.be.funpic.de//Spacepioneers
Cookiepfad: /Cookies/

ich hab mich versuchsweise mal ausgeloggt und komm jetzt nicht mal als admin mehr rein. Ich hab nur noch zugriff auf den admin bereich.

wäre schön wenn mir gemand nen tipp geben könnte.
#48
Deine korrekten Einstellungen:

Cookie-Domain: .besentraeger.be.funpic.de
Cookie-Pfad: /Spacepioneers/Forum/

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#49
hab das jetzt so geändert, hat sich aber nichts daran geändert, dass ich nur gast bin
#50
Lösche die Cookies in deinem Browser und versuche es erneut. Zudem ist der Doppelslash in deiner URL falsch. Korrekt ist: http://besentraeger.be.funpic.de/Spacepi.../index.php

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  PN verschicken, Beiträge schreiben funzt nicht Detlef 1 560 05.05.2008, 22:20
Letzter Beitrag: Michael
  Update von 1.1.2 auf 1.2.2... nun funzt nix Supporter 8 1.100 03.12.2006, 14:16
Letzter Beitrag: Michael
  IMG Tag funzt nicht richtig ??? Jochen2003 2 614 23.04.2006, 21:09
Letzter Beitrag: Jochen2003
  Thema einem Freund senden funzt nicht Fatih 4 1.062 20.01.2006, 22:17
Letzter Beitrag: Fatih
  RSS funzt nicht krafdi 6 1.397 02.09.2005, 16:45
Letzter Beitrag: krafdi