Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Diskussion: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht
#1
Diskussion zu: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#2
danke Stefan, erledigt; war ja zwischen zwei Schluck Limo zu schaffen Wink
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#3
Danke für das Sicherheitsupdate.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.30 | PHP: 7.4.28 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#4
Können die Dateien im laufenden Forum ausgetauscht werden?
Zitieren
#5
Ja, einfach im laufenden Betrieb hochladen und überschreiben, Reihenfolge egal.

[ExiTuS]
MyBB-Forum + innovatives Theme
Live Escape Game Forum
Erste Deutsche und Internationale Community und Diskussionsplattform für Live Escape und Adventure Games.
Unlösbares Problem? -> das Nötel
Zitieren
#6
Hallo Zusammen,

ich habe vor einer Stunde ungefähr von 1.8.27 auf 1.8.30 upgedated.

Auf den ersten Blick scheint alles wunderbar geklappt zu haben, aber aktuell funktioniert nur die index.php und das ACP (und die selbst hinzugefügten Seiten wie das Impressum). Sonst bekomme ich nur eine weiße Seite.

also https://the-storyteller.eu/index.php funktioniert, aber gehe ich z.B. auf https://the-storyteller.eu/stats.php bekomme ich eine weiße Seite mit der Meldung


Zitat:Diese Seite funktioniert nicht

the-storyteller.eu kann diese Anfrage momentan nicht verarbeiten.

HTTP ERROR 500




Ich habe mir die Error Logs schon angeschaut, aber das aktuellste was ich gefunden habe ist

Code:
<error>
    <dateline>1650620979</dateline>
    <script></script>
    <line>0</line>
    <type>42</type>
    <friendly_type>MyBB Error</friendly_type>
    <message>Your board has not yet been upgraded. Please do so before attempting to browse it.</message>
    <back_trace>#0  errorHandler->error() called at [/inc/class_error.php:340]
#1  errorHandler->trigger() called at [/inc/class_core.php:592]
#2  MyBB->trigger_generic_error() called at [/inc/init.php:226]
#3  require_once() called at [/global.php:20]
#4  require_once() called at [/showthread.php:28]
</back_trace>
</error>


und 

Code:
<error>
    <dateline>1650621224</dateline>
    <script></script>
    <line>0</line>
    <type>43</type>
    <friendly_type>MyBB Error</friendly_type>
    <message>The install directory (install/) still exists on your server and is not locked. To access MyBB please either remove this directory or create an empty file in it called 'lock'.</message>
    <back_trace>#0  errorHandler->error() called at [/inc/class_error.php:340]
#1  errorHandler->trigger() called at [/inc/class_core.php:592]
#2  MyBB->trigger_generic_error() called at [/inc/init.php:121]
#3  require_once() called at [/global.php:20]
#4  require_once() called at [/member.php:30]
</back_trace>
</error>


Beides habe ich nochmal überprüft, aber es wird sowohl die aktuellste Version angezeigt, als auch ist eine lock-Datei im FTP vorhanden.

Hat jemand eine Idee, woran das liegen kann? Ich habe das Problem auch im Standardstyle, bin mir aber sicher, dass ich alle Dateien, die seit 1.8.27 geändert wurden, richtig hochgeladen habe.

Danke für eure Hilfe.
Zitieren
#7
Wenn es die Logs von MyBB nichts aufschlussreiches hergeben (bei Fehlern im PHP Code kann das passieren), würde ich in die Logs des Webservers schauen, sofern du darauf Zugriff hast.

Bei vielen Webspaces liegen die Server-Logs griffbereit und können sogar per FTP erreicht werden; bei einem vServer hat man sogar auf Terminal-Ebene Zugriff darauf.

Überprüfe alle tatsächlich geänderten Dateien seit deiner letzten Version. (Hast du die Ursprungsdateien der letzten Version gesichert?)
Welche PHP-Version auf dem Webserver?
Gab es sonstige, serverseitige Änderungen, wie eine Umstellung der PHP-Version?
Was sagt die Dateiverifikation im ACP? Hiermit kannst du korrupte oder geänderte Dateien finden.

[ExiTuS]
MyBB-Forum + innovatives Theme
Live Escape Game Forum
Erste Deutsche und Internationale Community und Diskussionsplattform für Live Escape und Adventure Games.
Unlösbares Problem? -> das Nötel
Zitieren
#8
Zitat:Wenn es die Logs von MyBB nichts aufschlussreiches hergeben (bei Fehlern im PHP Code kann das passieren), würde ich in die Logs des Webservers schauen, sofern du darauf Zugriff hast.

Bei vielen Webspaces liegen die Server-Logs griffbereit und können sogar per FTP erreicht werden; bei einem vServer hat man sogar auf Terminal-Ebene Zugriff darauf.


So wie es aussieht, war das wohl bis gerade deaktiviert, bringt mir also nichts, da vorher nichts geloggt wurde von all inkl. aus



Zitat:Überprüfe alle tatsächlich geänderten Dateien seit deiner letzten Version. (Hast du die Ursprungsdateien der letzten Version gesichert?)

Habe ich bereits gestern getan und alles, was sich unterschieden hat und auch so von mir gewollt war (z.B. Workarounds, Pluginänderungen etc.), habe ich gestern via Patches Plugin dann entsprechend hinterlegt.


Zitat:Welche PHP-Version auf dem Webserver?
Gab es sonstige, serverseitige Änderungen, wie eine Umstellung der PHP-Version?


7.4
Nein - laut ACP läuft das Forum auf 7.4.28

Zitat:Was sagt die Dateiverifikation im ACP? Hiermit kannst du korrupte oder geänderte Dateien finden.

Hab ich gemacht und sehe auch, dass einige Dateien rot sind mit dem Zusatz verändert. Die meisten Dateien stimmen auch, da habe ich z.B. über das Patches Plugin etwas geändert, doch einige Sachen sind dabei, die hab ich nie angefasst (z.B. stats.php-Datei und die englischen language Dateien)
Hilft mir in diesem Fall aber nichts, da ich ja nicht sehen kann, WAS genau verändert/falsch ist.

Sad Hat jemand noch eine weitere Idee?


Edit: hab zum Spaß mal alle Patches rausgenommen und es funktioniert alles. 
Warum, keine Ahnung, muss ich mir jetzt wohl noch mal genau anschauen.

Dennoch Danke für die Hilfe Exitus
Zitieren
#9
(22.04.2022, 14:07)TheStoryteller schrieb:
Zitat:So wie es aussieht, war das wohl bis gerade deaktiviert, bringt mir also nichts, da vorher nichts geloggt wurde von all inkl. aus

Bei All-Inkl (da bin ich seit über 10 Jahren) kannst Du in der .htacces das PHP-Logfile komplett (Ort u. Dateiname) selbst definieren. Ab und an mal ansehen und bei Bedarf löschen. Wird bei weiteren Fehlern wieder automatisch angelegt.

Nebenbei: Das PHP-ErrorLogFile ist weitaus aussagekrägfter und schneller auszuwerten (z.B. keine Timestamps sondern GMT) als das Log-File von MyBB.

Lege somit ein PHP-ErrorLogFile an, rufe die Seite auf und sehe dann im Logfile nach wo das Problem liegt. Dann  hast Du in wenigen Minuten die Ursache lokalisiert.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.30 | PHP: 7.4.28 | SQL: 5.7.37
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#10
Hallo Gerti

das klingt machbar, danke dir Smile
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Diskussion: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht StefanT 24 2.413 17.11.2021, 11:33
Letzter Beitrag: bv64
  Diskussion: MyBB 1.8.28 veröffentlicht StefanT 7 942 01.11.2021, 13:30
Letzter Beitrag: Gerti
  Diskussion: MyBB 1.8.27 veröffentlicht StefanT 43 4.952 03.09.2021, 20:40
Letzter Beitrag: saen
  Diskussion: Sicherheitsupdate: MyBB 1.8.26 veröffentlicht StefanT 14 2.793 26.03.2021, 11:26
Letzter Beitrag: Mentanding
  Diskussion: Sicherheitsupdate: MyBB 1.8.25 veröffentlicht StefanT 14 2.880 23.02.2021, 17:36
Letzter Beitrag: Fiji