Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Admin-CP blockiert durch fehlende invite.lang.php-file
#1
Guten Morgen liebe Community,

ich hoffe ich bin mit dem Problem hier in diesem Forenbereich richtig. 

ich habe folgendes Problem und das wurde vermutlich durch folgendes Plugin verursacht. Ich möchte nicht sagen das es schlecht wäre aber seit ich das Installiert hatte habe ich keinen Zugriff mehr auf den Admin-CP. Da mir eine Fehlermeldung folgendes mitteilt:
Code:
inc/languages/deutsch_sie/admin/../invite.lang.php does not exist

Bevor ich das Plugin installiert hatte, hat alles funktioniert, ich kann es mir also nicht erklären was da schief gegangen sein kann. Ist das Plugin innerhalb der Files komplett oder fehlt da vielleicht etwas? Ich kann es leider nicht genau sagen. 

Ich habe im Internet nach dem Fehler gesucht, jedoch bin ich auf viele andere 'ähnliche' Problemfälle gestoßen, die ich nachprüfen konnte anhand der original Source-Files von mybb entsprechend waren die Dateien jedoch alle vorhanden z.B. global.lang.php was in der Vergangenheit selbst häufiger wohl ein kleines 'Problem' war. 

Das jedoch hat mir nicht dabei geholfen mein oben genanntes Problem zu lösen. 
ich kann also keine Plugins deinstallieren noch sonst etwas im Admin-CP vornehmen, und ein Backup habe ich noch nicht angelegt gehabt, was ziemlich beknackt von mir war. Das weiß ich nun wesentlich besser für die Zukunft. 

Jetzt meine Frage an Euch, wie kann ich das soweit fixen, ohne gleich eine neu Installation vornehmen zu müssen?

Gibt es dazu einen konkreten Datenbankeintrag der ggf. gelöscht werden müsste?

Ich bedanke mich schon einmal im Vorfeld für die Hilfe dazu. 

Lieben Gruß terosa
Zitieren
#2
(04.02.2021, 08:15)terosa schrieb: ich habe folgendes Problem und das wurde vermutlich durch folgendes Plugin verursacht.
Code:
inc/languages/deutsch_sie/admin/../invite.lang.php does not exist
Da muss etwas anderes schief gelaufen sein. Die fehlende Sprachdatei ist nicht Bestandteil des von Dir erwähnten PlugIns (dort lauten die Sprachdateien "export_user.lang.php".

Hier ist Dein Problem bereits in 2015 behandelt worden.

Kopiere die fehlende Sprachdatei aus "deutsch_du" (soweit vorhanden) nach "deutsch_sie". Wie hier zu finden ist, gibt es anscheinend nur die Sprachdatei in "english". Dann kopiere testweise die englische Sprachdatei nach "deutsch_du" und "deutsch_sie", bei Bedarf selbst übersetzen.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#3
Ich habe die Datei kopiert und in das jeweilige "deutsch_du" und "deutsch_sie" Verzeichnis kopiert. Jedoch erfolglos.

Ich bin selbst zum Dateiabgleich mit dem original Dateibestand von mybb ran gegangen und habe es mal hoch geladen in der Hoffnung das es sich so lösen lässt auch ohne Erfolg.

Ich nehme auch sehr stark an, dass das wohl an einer anderen Stelle liegt. Wie bereits erwähnt, funktionierte alles zu vor, und da habe ich das halt angenommen, das es vielleicht durch das Plugin auftrat. :/ ich weiß ehrlich gesagt gerade keinen Rat.

Würde mybb drüber installieren helfen? Theoretisch gehe ich mal davon aus. Weil ja dann aus der theoretischen perspektive betrachtet ja alles wieder in Ordnung sein und die Files alle auf dem Webspace ankommen... Und so betrachtet ja auch alles vorhanden sein.
Zitieren
#4
Neuinstallation des Forums ist nicht zielführend, weil die MyBB-Forensoftware nicht ursächlich für Dein Problem ist.

Deaktiviere alle PlugIns und aktiviere sie wieder nach und nach. Nach jeder Aktivierung teste. Dann hast Du schnell das PlugIn welches die Probleme bereitet gefunden.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#5
Ja, wenn das gehen würde, da mir der Weg ins Admin-CP durch die oben genannte Meldung versperrt ist. Wenn ich im Forum bin, und dann auf Admin-CP klicke, würde ich ja eigentlich in den Konfigurationsbereich kommen wo alles mögliche eingestellt werden kann. Dahin komme ich nicht einmal, weil besagte Meldung erscheint da irgendwo eine Datei fehlt.

Weswegen ich mich ja an euch gewandt habe in der Hoffnung, das ihr mir da weiter helfen könnt.

P.S.

Es lag nicht an der invite.lang.php oder an dem von mir genannten Plugin. 
Es lag an drei Plugins, deren Verzeichnisse unvollständig waren, da ihnen jeweils das Sprachverzeichnis "deutsch_sie" fehlten. 

Also habe ich alles vom FTP geholt und nochmals zerlegt auf der Webseite stets F5 gedrückt und so kam ich dem ganzen auf der Spur.

Ich danke dir dennoch herzlich für deine Hilfe und deine Zeit.
Zitieren
#6
(04.02.2021, 08:54)terosa schrieb: Ja, wenn das gehen würde, da mir der Weg ins Admin-CP durch die oben genannte Meldung versperrt ist. Wenn ich im Forum bin, und dann auf Admin-CP klicke, würde ich ja eigentlich in den Konfigurationsbereich kommen wo alles mögliche eingestellt werden kann. Dahin komme ich nicht einmal, weil besagte Meldung erscheint da irgendwo eine Datei fehlt.

Weswegen ich mich ja an euch gewandt habe in der Hoffnung, das ihr mir da weiter helfen könnt.

Lade Dir die oben verlinkte Sprachdatei "invite.lang.php" herunter und kopiere sie in die drei Sprachorder. Dann kommst Du zumindest wieder ins ACP, weil alle geforderten Dateiwn dann zumindest da sein müssten.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#7
Das hatte schon versucht wie ich weiter oben beschrieben hatte, das hatte auch nichts gebracht warum auch immer. Stutzig wurde ich dann doch, weil er mit /../ genau angezeigt hatte, was wiederum darauf schließen lässt das anders wo etwas fehlt.

Ich habe das Problem schon gelöst und meinen Beitrag entsprechend Editiert gehabt.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Blockiert durch X-Frame - Mybb Fehlermeldung Foxi 4 1.089 02.06.2020, 12:11
Letzter Beitrag: Foxi
  Problem: export_user.lang.php does not exist FlederMaus 10 1.233 06.10.2019, 22:38
Letzter Beitrag: JTD
  YouTube Videos blockiert KaSo 40 4.083 11.06.2017, 21:01
Letzter Beitrag: KaSo
  Seltsame Zeichen in config_settings.lang.php Reggie 0 686 28.01.2017, 11:01
Letzter Beitrag: Reggie