Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Datenbank wechseln
#41
(30.09.2020, 19:50)Schnapsnase schrieb: Ich bin auch bei Strato.
Ich kann Euch anbieten, die ftp-Daten und die DB mal bei mir zu testen.
Ansonsten fällt mir momentan nichts weiter dazu ein.

Danke für das Angebot, wenn bis zum WE nichts geht, melde ich mich dazu bei Dir. Wir haben gemeinsam eh schon viele Probleme bewältigt. Cool
Vielleicht hat StefanT einen Lösungsweg dem Fehlverhalten auf die Schliche zu kommen.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#42
(30.09.2020, 17:05)Gerti schrieb: Fakt war, sie war nicht zu 100% einspielbar, MSD-MYSQLDumper meldete immer einen Error = mehrmals: "kann mybb_tabellenname" nicht lesen". Wenn ich wüßte was wie warum, würde ich es gerne mitteilen. Ein netter Bekannter war mir freundlicherweise via Teamviewer behilfich die Datenbank wieder zu vervollständigen. Was wie etc. er genau gemacht hat (er arbeite mit Tool-Progarmmen welcher er am Ende, aus Lizenzgründen, wieder löschte) entzieht sich meiner Fachkompetenz. Jeden Schritt hier auf MyBB zu dokumentieren hätte doch nur noch für mehr Verwirrung gesorgt. Es war so genug Zeitaufwand.
Ein Support-Forum dient auch als Wissensdatenbank. Sollte jemand mit einem ähnlichen Problem diesen Thread finden, helfen solche Aussagen halt nicht weiter. Aber gut, das scheint ja erledigt zu sein.
(30.09.2020, 17:05)Gerti schrieb: Du hast meinen Lagebericht gelesen? Da steht doch alles haarklein. Von PHP5.6 immer weiter bis zu PHP7.4 > jeder Schritt ohne Probleme. Was war jetzt daran falsch?
Warum unterstellst du mir ständig, dass ich deine Beiträge nicht lesen würde? Mir sind noch einige Sachen unklar, die in deinem Lagebericht definitiv nicht (eindeutig) beschrieben sind.

Ich hätte jedoch empfohlen erst den ursprünglichen Fehler genau zu analysieren und zu beheben. Danach hätte man die Datenbank reparieren, später MyBB aktualisieren und als aller letztes die PHP-Version ändern können. Nach jedem Schritt hätte man dann das Ergebnis überprüfen können. So hast du im blödesten Fall in jedem Schritt noch ein zusätzliches Problem eingebaut und merkst es erst ganz am Schluss. Das erspart zwar nicht die Arbeit, erleichtert die Fehlersuche aber ungemein.
(30.09.2020, 17:05)Gerti schrieb: Sorry, ich habe in den letzten beiden Tagen genug mit dem SQL-Helfer sowie mit dem OP kommuniziert. So viel Zeit konnte ich nicht aufbringen um noch auf MYBB jeden Schritt (zur Dokumentation?) zu schreiben. Etwaige Hilfestellungen/Ratschläge hierzu wären sicherlich gut gemeint gewesen hätten aber zusätzlichen Zeitwand bedeutet.
Nicht jeden Schritt, aber ein paar zentrale Punkte (kaputte DB, andere MyBB-Version, etc.) wären schon hilfreich gewesen.
(30.09.2020, 17:05)Gerti schrieb: Mach doch bitte mal zum Thema innerlich einen Neustart, was vorher war ist Vergangenheit ...vergesse die Logs.  Es ist nur nachstehendes Problemstellung zu lösen.
Warum soll ich die Logs vergessen, wenn sich darin wahrscheinlich der entscheidende Hinweis befindet; dafür sind diese Logs ja da. Ohne eine genaue Fehlermeldung kann es alles mögliche sein und man kann nur raten. Logs sind ja anscheinend vorhanden und auch recht umfangreich, wenn ich mich korrekt an den gelöschten Beitrag erinnere.

Abschließen hätte ich noch ein paar Fragen:
Es gab also 2 getrennte Datenbank verschiedener MyBB-Versionen? Was ist mit denen passiert, dass offenbar beide defekt waren (vielleicht ist ja auch am Webspace was kaputt gegangen)? Hat der Hoster keine Backups für solche Fälle? Auch wenn die Datenbank nun repariert ist, wäre das gut um den Hintergrund zu verstehen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#43
(30.09.2020, 20:19)StefanT schrieb: Hat der Hoster keine Backups für solche Fälle?...

Strato macht genügend Backups für den Webspace.
Um Backups der DB sollte man sich selbst kümmern.

Ansonsten bin ich hier bei Stefan...
Zuerst hieß es: "DB gelöscht und gegen ein Backup ausgetauscht..."
Es kam nie eine Info, warum die originale DB gelöscht wurde und warum davon vorher wohl auch keine Sicherung gemacht wurde.
Ebenso kam nie eine total veraltete MyBB-Version ins Spiel...
Zumindest sind die gesamten Informationen zum Problem mehr als fragwürdig. Man kann hier schon kaum noch mitdenken. Rolleyes
Zitieren
#44
Ich bin jedenfalls definitiv der falsche Ansprechpartner. Auch ich hatte nur den Stand hier aus dem Forum. Alles weitere habe ich mir in mühevoller Kleinarbeit erabeitet und letztlich auch hier (gut gemeint) niedergeschrieben. Dafür wurde ich sogar angemacht (so mein Empfinden) und musste mich gar dafür rechtfertigen. Werde wohl umsichtiger sein müssen solche MyBB-Erfahrungen im MyBB-Forum zu schreiben.

(30.09.2020, 20:19)StefanT schrieb: Abschließen hätte ich noch ein paar Fragen:
Es gab also 2 getrennte Datenbank verschiedener MyBB-Versionen? Was ist mit denen passiert, dass offenbar beide defekt waren (vielleicht ist ja auch am Webspace was kaputt gegangen)? Hat der Hoster keine Backups für solche Fälle? Auch wenn die Datenbank nun repariert ist, wäre das gut um den Hintergrund zu verstehen.

Es gabe mehrere Datenbanken welche ich downgeloaded habe. Alle mit Angabe der MyBB-Version 1.2.2 (warum auch immer) in der Tabelle "mybb_settings".

Was wie wo warum weshalb passiert entzieht sich meiner Kompetenz und somit schlußfolgernd auch meiner Kenntnis. Ich bin froh dass das Forum auf der Testplattform, nach nicht unerheblichem Aufwand und Dank dritter Hilfe, endlich perfekt funktioniert.

Bevor ich auch nur annähernd den zusätzlichen Zeitaufand für eine etwaige Ursachenforschung (wobei man selten einen findet der die Schuld auf sich nimmt, da muss man einges "Beweisen") aufwende, will ich erst das Forum auf der Strato-Plattorm in Funktion bekommen.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#45
(30.09.2020, 21:09)Gerti schrieb: Dafür wurde ich sogar angemacht (so mein Empfinden) und musste mich gar dafür rechtfertigen. Werde wohl umsichtiger sein müssen solche MyBB-Erfahrungen im MyBB-Forum zu schreiben.
Du musst dich nicht gegenüber mir rechtfertigen, ich habe dich ja sogar für deinen Einsatz gelobt. Ohne Fehlermeldung muss ich nun einmal die Umstände genau untersuchen um zielgerichtete Tipps geben zu können. Das ist wie bei einem Puzzle; ich habe zwar viele Teile, diese passen aber noch nicht zusammen.
"Ich habe die Datenbank gelöscht und ein Backup eingespielt" ist halt etwas komplett anderes als "keine der Datenbanken war nutzbar".
(30.09.2020, 21:09)Gerti schrieb: Es gabe mehrere Datenbanken welche ich downgeloaded habe. Alle mit Angabe der MyBB-Version 1.2.2 (warum auch immer) in der Tabelle "mybb_settings".
Ist das ein Schreibfehler? In der Tabelle wird die Version nicht gespeichert.

Daher nochmal ein Frage an spezii:
Was war mit der ursprünglichen Datenbank? Gab es damit schon eigentliche Probleme? Wenn ja, welche?
Was ist mit dem angesprochenen Backup? Funktionierte das? Wenn nicht, welche Probleme gab es damit?
Gab es vor Einspielen des Backups schon Probleme? Der Zusammenhang zwischen deinem Datenbank-Problem und dem 500er Fehler wäre für uns ganz wichtig.
Wenn die Logs nicht weiterhelfen, aktiviere bitte die Anzeige von PHP-Fehlern, damit die Fehlermeldung direkt im Browser angezeigt wird. Siehe Strato-FAQ:
Zitat:Bitte beachten Sie: Der Parameter display_errors ist in PHP 5.x bei STRATO standardmäßig deaktiviert (display_errors = off).
Um Fehler nachvollziehen zu können, ist es empfehlenswert, diesen Parameter zu aktivieren. Die Aktivierung können Sie mit einem entsprechenden Eintrag in Ihrer php.ini vornehmen. Fügen Sie Ihrer php.ini-Datei daher bitte folgende Einträge hinzu:

error_reporting = E_ALL
display_errors = On

Nach der Evaluierung des Fehlers ist es ratsam, diese Einstellung wieder zu deaktivieren.
https://www.strato.de/faq/hosting/haeufi...-scripten/

@Gerti: Außerdem nennt die Doku von Strato falsche Dateirechte als mögliche Ursache. Hast du diese einmal geprüft?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#46
Vielleicht kann ich zur Klärung beitragen.
Ich bin etwas bestürzt, dass die Angelegenheit solche Wellen schlägt.

Vom funktionierendem Forum im Directory "forum2", Vers. 1.82 habe ich die zugrunde liegende Datenbank gelöscht. (Blöd, ich weiß).
Ich habe eine neue Datenbank erstellt, und in diese ein sehr frühes Backup der gelöschten DB eingespielt. Entsprechend der Anleitung zum Umzug eines Forums habe ich die Datenbank ins Forum eingebunden.
Ergebnis: Der Whitescreen!
Bei diesem Stand habe ich mich an euch gewendet, siehe hier erstes Posting.

Während der Bearbeitung durch euch kam das alte Forum (Vers. 1.2) ins Spiel. Dieses liegt im Directory "forum".
Dieses lief öffentlich wegen php5.x nicht mehr, ist aber technisch i.O. und voll funktionsfähig, mit intakter Datenbank.

Hier wurden dann leider beide Dinge vermengt, obwohl das alte 1.2er Forum mit dem Whitescreen nicht das Geringste zu tun hatte.

Glücklich bin ich, dass die Daten aus dem 1.2er Forum jetzt in einem 1.8er Forum zur Verfügung stehen können. Eine ganz großartige, nicht für möglich gehaltene Leistung. Das wird auch die bis zu 2000 User des 1.2er und 1.8er Forums sehr freuen, die durch den Stop des Forums im Augenblick keine Austauschmöglichkeit mehr haben.

Nur der Whitescreen stört.

(01.10.2020, 09:51)StefanT schrieb: Daher nochmal ein Frage an spezii:
Was war mit der ursprünglichen Datenbank? Gab es damit schon eigentliche Probleme? Wenn ja, welche?
Was ist mit dem angesprochenen Backup? Funktionierte das? Wenn nicht, welche Probleme gab es damit?
Gab es vor Einspielen des Backups schon Probleme? Der Zusammenhang zwischen deinem Datenbank-Problem und dem 500er Fehler wäre für uns ganz wichtig.
Wenn die Logs nicht weiterhelfen, aktiviere bitte die Anzeige von PHP-Fehlern, damit die Fehlermeldung direkt im Browser angezeigt wird. Siehe Strato-FAQ:
Zitat:Bitte beachten Sie: Der Parameter display_errors ist in PHP 5.x bei STRATO standardmäßig deaktiviert (display_errors = off).
Um Fehler nachvollziehen zu können, ist es empfehlenswert, diesen Parameter zu aktivieren. Die Aktivierung können Sie mit einem entsprechenden Eintrag in Ihrer php.ini vornehmen. Fügen Sie Ihrer php.ini-Datei daher bitte folgende Einträge hinzu:

error_reporting = E_ALL
display_errors = On

Nach der Evaluierung des Fehlers ist es ratsam, diese Einstellung wieder zu deaktivieren.
https://www.strato.de/faq/hosting/haeufi...-scripten/

@Gerti: Außerdem nennt die Doku von Strato falsche Dateirechte als mögliche Ursache. Hast du diese einmal geprüft?

Ursprüngliche Datenbank (1.82): keine Probleme.
Backup (1.82) wurde nicht ausprobiert ob es funktionierte.
Vor Erstellen neuer DB und Einspielen des Backups (1.82) gab es die Fehlermeldung sich an den Admin zu wenden.
Nach Einspielen und Einbinden der neuen DB: Whitescreen
Dateirechte wurden geprüft entsprechend der Anleitung Umzug Forum, war OK.

Gerti hat alle Rechte, ich ändere keine PHP-Datei.
Zitieren
#47
(01.10.2020, 10:05)spezii schrieb: Ich bin etwas bestürzt, dass die Angelegenheit solche Wellen schlägt.
Mach Dir mal keine Sorgen.
Es schlägt keine Wellen, sondern wir versuchen nur zu helfen.

(01.10.2020, 10:05)spezii schrieb: Vom funktionierendem Forum im Directory "forum2", Vers. 1.82 habe ich die zugrunde liegende Datenbank gelöscht. (Blöd, ich weiß)....
...Ursprüngliche Datenbank (1.82): keine Probleme.
Hier muss ich nochmal nach dem "warum gelöscht" fragen.
Zitieren
#48
@spezii:
Vielen Dank für die Aufklärung. Ich war die ganze Zeit davon ausgegangen, dass Gerti die kaputte Datenbank als Fehlerursache ausgemacht hatte. Dass er stattdessen unabhängig vom eigentlich Problem das andere Forum aktualisiert, war mir nicht klar. Daher kann man natürlich alle Theorien in Richtung Server-Störung abhaken.

Die Tipps in Richtung Logs und Fehleranzeige aktivieren, sind hier wohl am zielführendsten.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#49
(01.10.2020, 10:24)Schnapsnase schrieb: Hier muss ich nochmal nach dem "warum gelöscht" fragen.

Streu noch Salz in die Wunde!
Ich schrieb doch schon, dass das blöd war.  Ich wusste, in einem Anfall geistiger Umnachtung, nicht, was ich da tat.
Zitieren
#50
Das hat nichts mit Salz... zu tun. Ich wollte einfach nur wissen, was vorher nicht funktionierte, dass man so einen Schritt geht.
Ich kann mich aber auch gern aus Deinem und Gertis Problem heraushalten.
Zitieren