Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.21 veröffentlicht (11.06.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Automatische Leerzeilen nach Post-Edit
#11
Das Problem mit den Leerzeilen habe ich gelegentlich auch wenn ich hier im MyBB-Forum schreibe (meist wenn PHP- und/oder Code-Informationen enthalten sind) und die Vorschau verwende, Inhalt korrigiere und nochmals die Vorschau verwende.

Dann muss ich immer die nicht von mir stammenden Leerzeilcen entfernen udn hoffen das beim Absenden diese nicht wieder eingefügt werden.

Es scheinen auch hier dieselben Bugs enthalten sein. Alternativ handelt es sich um ein übergeordnetes globales Problem?
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Wer nicht weiß wohin er will, darf sich nicht wundern wenn er woanders ankommt.
Aktive Version: MyBB: 1.8.21 | PHP: 7.2.19 | SQL: 5.6.44
Zitieren
#12
(23.06.2019, 02:13)Nighthawk schrieb: Somit ist nun zweifelsfrei bewiesen, dass der Fehler an MyBB liegt!

Wenn überhaupt, dann liegt der Fehler nicht an MyBB sondern am Editor, und dieser ist nunmal nur ein Plugin.
Einen ähnlichen Fehler hat es beim SCeditor wohl schon mal vor Jahren gegeben.
Dies habe ich dazu gefunden: https://github.com/samclarke/SCEditor/issues/294

Seltsamerweise habe ich keine Probleme und/oder habe sie bisher nicht reproduzieren können.
Zitieren
#13
(23.06.2019, 17:24)Schnapsnase schrieb:
(23.06.2019, 02:13)Nighthawk schrieb: Somit ist nun zweifelsfrei bewiesen, dass der Fehler an MyBB liegt!
Wenn überhaupt, dann liegt der Fehler nicht an MyBB sondern am Editor, und dieser ist nunmal nur ein Plugin.

Seltsamerweise habe ich keine Probleme und/oder habe sie bisher nicht reproduzieren können.
Hatte das Problem gerade eben in diesem Beitrag. Klick auf Vorschau und schonwaren sie da. Habe sie belassen dami man sich um eine Lösung bemüht. Ihr wisst hinreichend, das ich meine Beiträge eigentlich sauber poste.
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Wer nicht weiß wohin er will, darf sich nicht wundern wenn er woanders ankommt.
Aktive Version: MyBB: 1.8.21 | PHP: 7.2.19 | SQL: 5.6.44
Zitieren
#14
Ich habe mich hier jetzt etwas länger zurückgehalten, der Fehler ist aber auch im offiziellen MyBB Forum da. Ich habe vor kurzem den Beitrag für mein Plugin bearbeitet und plötzlich waren Leerzeichen da. Erst durch editieren den Quellcodes waren sie weg.
My  PHP-Version: 7.3.1 | MySQL-Version: 5.7.21
My  Plugins: See all
------
Es gibt nur 10 Arten von Menschen. Die, die binär verstehen - und die, die es nicht tun
Zitieren
#15
Ich habe mal etwas getestet. Der Fehler entsteht (auch bei mir) beim Entfernen einer Leerzeile.
Beispiel:
test1

test2

test3
Wenn ich jetzt z.B. die Leerzeile zwischen test1 und test2 entferne entsteht das Problem.
Genauso entsteht das Problem, wenn ich in einem Text eine Zeile markiere und entferne. Dadurch entsteht eine Leerzeile. Entferne ich diese dann, habe ich den Salat.
Wenn man sich den Quellcode ansieht, fällt auf, dass nach dem Löschen der Leerzeile ein zusätzliches </br> eingefügt wird.
Zitieren
#16
hey, das Problem ist aber vorhanden, und liegt nicht am TE

das gleiche Problem habe ich hier direkt auf der Seite auch inline-bearbeiten ist sauber der Editor zum bearbeiten bringt zusätzliche leerzeilen:

https://www.mybb.de/forum/thread-36496-p...#pid239801
Zitieren
#17
Noch niemand eine Lösung/Fix gefunden?
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Probleme mit settings.php nach ACP edit (nach Umzug) Funkenregen 3 849 06.05.2015, 09:52
Letzter Beitrag: Funkenregen