Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Nach Updates suchen Forum und Plugins
#1
Hallo zusammen,

ich habe das "Problem", dass seit 1.8.11 / 1.8.12 die Updatesuche (egal ob Forum oder Plugins) immer "Es gab ein Problem mit der Verbindung zum Server. Bitte versuchen Sie es in ein paar Minuten erneut" ausgibt. Mit 1.8.10 hatte ich das Problem noch nicht.

Dazu gibt es ja schon einige Threads, die immer auf PHP setting oder "wird vom Provider nicht unterstützt" raus laufen.

Ich habe einen VPS den ich frei konfigurieren kann. Die Firewall habe ich testweise komplett deaktiviert - das hat aber nichts gebracht. Weiterhin steht der Parameter allow_url_fopen auf:

PHP Version
7.1.5


Directive
Local Value
Master Value

allow_url_fopen
On
On


Die PHP Logdatei habe ich auch gecheckt. Das ist nichts zu sehen, nachdem die Meldung auftritt. Irgendwer Ideen dazu? Ich habe bereits verschiedene PHP Versionen und auch die Deaktivierung von fastscript probiert. Das hat aber alles keine Änderung gebracht. 
Zitieren
#2
Steht auch die openssl-Erweiterung zur Verfügung? Funktionieren Zugriffe auf andere über HTTPS erreichbare Seiten mit PHP?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Danke für die Antwort


Zwei mal ja. Habe mit folgendem Code getestet:


Code:
<?php
$datei = fopen ("https://www.example.com/", "r");
if (!$datei) {
    echo "<p>Datei konnte nicht geöffnet werden.\n";
    exit;
}
while (!feof ($datei)) {
    $zeile = fgets ($datei, 1024);
    /* Funktioniert nur, wenn Titel und title-Tags in einer Zeile stehen */
    if (preg_match ("@\<title\>(.*)\</title\>@i", $zeile, $treffer)) {
        $title = $treffer[1];
        break;
    }
}
echo $title;
echo $zeile;
echo $datei;
echo $treffer;
echo $treffer[1];

fclose($datei);
?>

Ergebnis:
Example Domain Resource id #3ArrayExample Domain
Zitieren
#4
Möglich ist auch, dass die IP-Adresse deines Servers von Cloudflare geblockt wird.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Danke.

Das habe ich jetzt für die Domain getest ohne zu wissen was im Hintergrund genau passiert. Die Domain lässt sich aber aufrufen mir vorherigem PHP:

Cloudflare - The Web Performance & Security Company | Cloudflare Resource id #3ArrayCloudflare - The Web Performance & Security Company | Cloudflare
Zitieren
#6
Da sollte aber nichts von Cloudflare kommen. Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Planung des Updates auf Version 1.9 falcao1010 10 1.512 11.10.2019, 20:12
Letzter Beitrag: Schnapsnase
  Wo winde ich die Dateien die geändert werden müssen wegen des Updates? Daniel44 3 1.061 05.09.2018, 09:33
Letzter Beitrag: StefanT
  Updates itsmeJAY 1 1.723 01.09.2014, 21:11
Letzter Beitrag: Jockl