Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Warnung nach Update
#1
Hallo,

ich war lange nicht mehr hier..

Habe aber nichts gefundenn, was meinem Problem entspricht.

Nach dem Update von 1.6.1 auf .18  habe ich Zugriff auf das offline gestellte Forum im Archivmodus.
Bin als Admin angemeldet.

Aber es erscheint folgende Fehlermeldung:


PHP-Code:
[b]Folgende Warnungen sind aufgetreten:[/b]
Warning [2Invalid argument supplied for foreach() - Line331 File: global.php PHP 5.3.3-7+squeeze19 (Linux)

[
size=x-small]File[/size]
[
size=x-small]Line[/size]
[
size=x-small]Function[/size][size=x-small]/global.php[/size]
[
size=x-small]331[/size]
[
size=x-small]errorHandler->error[/size]
[
size=x-small]/misc.php[/size]
[
size=x-small]19[/size]
[
size=x-small]require_once[/size]


Ich weeißdass ich das ganz am Anfang auch schon mal hatteaber nicht mehrwie das Problem
zu lösen ist
.

Vielleicht wißt Ihr Rat?

Vielen DAnk  und sorryfalls ich irrtümlich ein entssprechendess vorhandenes Thema übersehen haben sollte
Zitieren
#2
(16.02.2015, 13:10)Haustein schrieb: Nach dem Update von 1.6.1 auf .18  habe ich Zugriff auf das offline gestellte Forum im Archivmodus.
Bin als Admin angemeldet.
Welche Version meinst du mit .18? Bei der Fehlermeldung fehlt im Übrigen die eigentliche Fehlermeldung, so kann ich leider nicht viel damit anfangen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
'tschuldigung  - es ist natürlich die neueste Forensoftware gemeint .1.8.1.


Es erscheint die Meldungen über Zwei Warnungen und darunter sind die entsprechenden Dateien gelistet.

Die Meldung sieht so aus:

F
Zitat:olgende Warnungen sind aufgetreten: 
Warning [2] Invalid argument supplied for foreach() - Line: 331 - File: global.php PHP 5.3.3-7+squeeze19 (Linux)

File
Line
Function
/global.php
331

errorHandler->error
/misc.php
19
require_once



Mehr kann ich dazu leider auch nicht sagen. 
Es könnte sein, dass das Forum trotzdem funktioniert und sich updaten lässt . Unter 1.6. hatte ich das am Anfang auch, und funktioniert hat dennoch Alles.
Irgendwie habe ich damals den Fehler beseitigen können - ich weiß nur nicht mehr wie. 
Ich meine, ich hätte die entsprechende Datei sogar geändert, weiß aber leider nicht mehr wie.


Das Admin-CP lässt sich nicht mehr Betreten.

Beim Versuch sich dort anzumelden erscheint die folgende Meldung:

Zitat:MyBB has experienced an internal SQL error and cannot continue.

SQL Error:1054 - Unknown column 'useragent' in 'field list'Query: INSERT INTO newmybb_adminsessions (`sid`,`uid`,`loginkey`,`ip`,`dateline`,`lastactive`,`data`,`useragent`) VALUES ('30f30506204860500abe0ccafeb3ec07','1','5nTgOLhLWSmdOR8rdVqLjWQdaCKsNZTyNkUkTFWVp8OycsZy6Y',X'5898ba40','1424089713','1424089713','a:0:{}','Mozilla/5.0 (Windows NT 6.3; Win64; x64; Trident/7.0; rv:11.0) like Gecko') 

Ich habe mich natürlich wie gewohnt mit üblichem Benutzernamen und Passwort angemeldet.
Zitieren
#4
(16.02.2015, 14:20)Haustein schrieb: 'tschuldigung  - es ist natürlich die neueste Forensoftware gemeint .1.8.1.
Aktuell ist MyBB 1.8.1 aber schon länger nicht mehr...

Das Problem scheint irgendwie mit den Themes zusammenzuhängen. Sind diese mit MyBB 1.8 kompatibel? Hast du schon einmal die Caches im ACP erneuert?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Nicht?
Jedenfalls habe ich die 1.8.1 - ohne das Sicherheitsupdate.

Den Cache leeren - wäre eine Möglichkeit, so ich ins Admin CP käme.

Ich bekomme ja nicht einmal die Meldung über ein fehlerhaftes Log in.

Ich könnte mich natürlich auf dem Server durcharbeiten und versuchen, das installierte Theme zu finden und diese Dateien zu löschen - so es daran liegen sollte. Alle anderen Erweiterungen haben ich deaktiviert - nur eben dieses Theme nicht.
Ein Abgleich der Dateien ist ja mit Filezilla möglich - auch wenn dieses beim Hochladen gezickt hat.

Kann es helfen, die Chmod auf 777 zu setzen - so dass auch ohne Login das Admin CP aufgerufen und ausgeführt werden kann?
Zitieren
#6
Wie hast du denn das Forum offline gesetzt, wenn du nicht ins Admin-CP kommst? Wurde überhaupt ein Upgrade ausgeführt (und dabei die korrekten Versionen ausgewählt)? Mir ist aktuell nicht klar, was du gemacht hast und seit wann das Problem auftritt.
Hast du das schon mit der aktuellen MyBB-Version probiert?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
Das Forum habe ich vorher offline gesetzt - also bevor ich das Upgrade ausgführt habe - also die Dateien entsprechend hochgeladen habe.
Im Forum selber bin ich auch als Admin angemeldet - aber offenbar nicht im Admin -CP.

Ich habe das Forum ein Backup gemacht, die Plugins deaktiviert- und das Forum offline gestellt.
Danach habe ich die aktuelle Forensoftware - das ganze Paket auf den Server geladen - und nach einem entsprechenden Hinweis den Ordner "Install" gelöscht.
Ich kann aktuell das Forum im Archivmodus aufrufen - aber nicht wieder online stellen, weil ich mich nicht ins Admin CP einloggen kann. Beim Klick auf das Feld "Admin-Cp" - erscheint der Login - und sobald mich dort mit Benutzername und richtigem Passwort einloggen will besagter Fehler mit der Adresse: http://shaustein.de/admin/index.php .

Das Forum Seite lässt sich auch erst aufrufen, nachdem ich die Schreibrechte in der Index-Datei auf 777 gesetzt habe, obwohl ich als admin eingeloggt war und bin - deswegen komme ich darauf, dass es vielleicht daran liegen könnte.
Zitieren
#8
Die Fehlermeldungen deuten darauf hin, dass das Upgrade nicht oder unvollständig ausgeführt wurde, oder eine falsche Version beim Upgrade ausgewählt wurde.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
Heißt ich müsste noch einmal schauen, ob ich eine der anderen Versionen hätte nehmen müssen?

Vielleicht hätte ich von 1.6.11 zunächst auf 1.6.16 aktualisieren müssen - um dann im nächsten Schritt auf 1.8.4 aktualisieren zu können?

In dem Fall müsste ich wohl zunächst wieder downgraden, oder?

Ich kann wie gesagt 1.6.11 nicht finden - und habe deswegen das ganze Paket 1.8.4 gewählt.
Zitieren
#10
So - inzwischen habe ich einen downgrade auf 16.16 durchgeführt.
Das Forum www.shaustein.de läßt sich aufrufen - sieht auch gut aus - ist aber noch geschlossen.

Als Admin kann ich es betreten.
Da sSchreiben von PN und Beiträgen ist möglich, aber das Absenden - also hochladen der Dateien ist nicht möglich, was daran liegen kann, dass das Forum geschlossen ist.

In Admin-CP komme ich zwar bis zu der Aufforderung mich anzumelden - aber nach dem Einloggen erscheint wieder bereits erwähnte Fehlermeldung.

Es ist als ob das System den Account nicht kennte. Ist es möglich, dass ein Wechsel des Computers und damit der IP-Adresse damit zu tun hat?

Das Forum installierte ich damals mit anderem PC - inzwischen habe ich einen anderen Laptop.

Könnte ein Upgrade auf 1.8.3 Abhilfe schaffen?

Lieben Gruß

Haustein
Zitieren