Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Lightbox 2-Einbau
#11
(15.09.2008, 18:56)rmburger schrieb: Super Anleitung - Danke!

Nur eine Frage, normalerweise verfärbt sich der Hintergrund schwarz, bei mir nicht. Wie kann man dieses einstellen
Da es hier funktioniert, liegt es wohl nicht an der Anleitung. Kannst du einen Link zu einem Beispiel posten?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#12
Ich hab auch nicht geschrieben, das es an der Anleitung liegt

Habe mittlerweile das Problem gelöst.

Wenn man (Firefox 3) den Code für "lighbox.css" direkt aus diesem Forum in die Maske kopiert entsteht:
Code:
#lightbox{    position: absolute;    left: 0; width: 100%; z-index: 100; text-align: center; line-height: 0;}

#lightbox img{ width: auto; height: auto;}

#lightbox a img{ border: none; }



#outerImageContainer{ position: relative; background-color: #fff; width: 250px; height: 250px; margin: 0 auto; }

#imageContainer{ padding: 10px; }



#loading{ position: absolute; top: 40%; left: 0%; height: 25%; width: 100%; text-align: center; line-height: 0; }

#hoverNav{ position: absolute; top: 0; left: 0; height: 100%; width: 100%; z-index: 10; }

#imageContainer>#hoverNav{ left: 0;}

#hoverNav a{ outline: none;}



#prevLink, #nextLink{ width: 49%; height: 100%; background-image:
url(data:image/gif;base64,AAAA); /* Trick IE into showing hover */
display: block; }

#prevLink { left: 0; float: left;}

#nextLink { right: 0; float: right;}

#prevLink:hover, #prevLink:visited:hover { background: url(images/prevlabel.gif) left 15% no-repeat; }

#nextLink:hover, #nextLink:visited:hover { background: url(images/nextlabel.gif) right 15% no-repeat; }



#imageDataContainer{ font: 10px Verdana, Helvetica, sans-serif;
background-color: #fff; margin: 0 auto; line-height: 1.4em; overflow:
auto; width: 100%    ; }



#imageData{    padding:0 10px; color: #666; }

#imageData #imageDetails{ width: 70%; float: left; text-align: left; }    

#imageData #caption{ font-weight: bold;    }

#imageData #numberDisplay{ display: block; clear: left; padding-bottom: 1.0em;    }            

#imageData #bottomNavClose{ width: 66px; float: right;  padding-bottom: 0.7em; outline: none;}         



#overlay{ position: absolute; top: 0; left: 0; z-index: 90; width: 100%; height: 500px; background-color: #000; }
Die Leerzeichen werden in " " gewandelt.

Jetzt habe ich den Code erst in einen Texteditor kopiert und aus dem Texteditor in die Maske.

Damit funktioniert es.
Zitieren
#13
Funktioniert bei mir nicht, er öffnet Bilder weiterhin in einem neuen Fenster.
Bitte um Hilfe! Smile

Link: http://www.thestormtroopersites.de/board...73#pid4473

EDIT: rel="lightbox[preview]" fehlt... Kann das etwas bedeuten?
Microsoft zertifizierter Entwickler in HTML 5, CSS 3 und Javascript.

MybbAddons - Plugins, Themes und MyCodes für dein MyBB

[Bild: zaiendosig.php] - mein Lieblingsforum
Zitieren
#14
Das sind ja auch keine Attachments.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#15
Wie gesagt, funktioniert wunderbar die Anleitung !

Nur eine Anliegen hätte ich noch.
Ist es möglich das die Bilder auch auf der MyBB Portal Seite in der Lightbox geöffnet werden ?
Weil dort werden sie weiterhin normal geöffnet (also neue seite).

Wäre echt perfekt wenn das irgendwie auch noch machbar ist !

mfg DaStaFlexX

*EDIT*
Hatte hier eben eine Fehlermeldung.
Nach der Vorschau wollte ich den Beitrag absenden, da kam eine Meldung das irgendwas nicht gefunden wurde.
Der Beitrag wurde aber trotzdem veröffentlicht.

Gerade nochmals, hier ein Screen:
   
Zitieren
#16
Hallo,

die Anleitung funktioniert wunderbar! Smile Soweit, sogut.

Leider hat der Einbau der Lightbox (und jedes anderen Abkömmlings davon) einen entscheidenden Nachteil: Ist man nicht eingeloggt bzw. hat man nicht die Rechte Attachments anzusehen (die volle Version des Bildes), dann erscheint beim Klick auf ein Thumbnail nicht die Login-Seite, sondern die Lightbox öffnet sich... und das war es dann auch.
Das Bild wird nicht angezeigt, aber der Kreisel dreht bis in die Ewigkeit!

Wenn dafür noch eine Lösung gefunden wird, werde ich so etwas auch nutzen. Wink

Idee: Es gibt ja Boxen, welche auch andere Dinge (per AJAX) einblenden können. Vielleicht wäre da ein Login möglich. Siehe hier: http://www.gregphoto.net/lightbox/ (auf Local element klicken).
Zitieren
#17
(26.09.2008, 11:18)DaStaFlexX schrieb: Wie gesagt, funktioniert wunderbar die Anleitung !

Nur eine Anliegen hätte ich noch.
Ist es möglich das die Bilder auch auf der MyBB Portal Seite in der Lightbox geöffnet werden ?
Weil dort werden sie weiterhin normal geöffnet (also neue seite).
Dazu musst du nur die portal.php beim Stylesheet hinzufügen. Ich habe das auch in der Anleitung oben ergänzt.
(26.09.2008, 11:18)DaStaFlexX schrieb: Hatte hier eben eine Fehlermeldung.
Nach der Vorschau wollte ich den Beitrag absenden, da kam eine Meldung das irgendwas nicht gefunden wurde.
Der Beitrag wurde aber trotzdem veröffentlicht.
Siehe: https://www.mybb.de/forum/thread-20779.html
(26.09.2008, 15:18)querschlaeger schrieb: Hallo,

die Anleitung funktioniert wunderbar! Smile Soweit, sogut.

Leider hat der Einbau der Lightbox (und jedes anderen Abkömmlings davon) einen entscheidenden Nachteil: Ist man nicht eingeloggt bzw. hat man nicht die Rechte Attachments anzusehen (die volle Version des Bildes), dann erscheint beim Klick auf ein Thumbnail nicht die Login-Seite, sondern die Lightbox öffnet sich... und das war es dann auch.
Das Bild wird nicht angezeigt, aber der Kreisel dreht bis in die Ewigkeit!

Wenn dafür noch eine Lösung gefunden wird, werde ich so etwas auch nutzen. Wink

Idee: Es gibt ja Boxen, welche auch andere Dinge (per AJAX) einblenden können. Vielleicht wäre da ein Login möglich. Siehe hier: http://www.gregphoto.net/lightbox/ (auf Local element klicken).
Das hatte ich nicht bedacht. Hier werde ich mal schauen, ob ich eine Lösung finde.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#18
(26.09.2008, 16:02)Dragon schrieb:
(26.09.2008, 11:18)DaStaFlexX schrieb: Wie gesagt, funktioniert wunderbar die Anleitung !

Nur eine Anliegen hätte ich noch.
Ist es möglich das die Bilder auch auf der MyBB Portal Seite in der Lightbox geöffnet werden ?
Weil dort werden sie weiterhin normal geöffnet (also neue seite).
Dazu musst du nur die portal.php beim Stylesheet hinzufügen. Ich habe das auch in der Anleitung oben ergänzt.
Ok habe jetzt portal.php auch noch angeheftet.

Und zwar so:
   

Funktioniert noch nicht, wird immer noch auf neuen Seite geöffnet !

Vielen Dank für deine mühe Wink
grüsse DaStaFlexX
Zitieren
#19
Ok, ich habe Punkt 6 eingefügt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#20
Du solltest hier im Forum noch irgendwo schreiben:
"Vorsicht, rasend schneller Support" Smile

Wunderbar, jetzt funktionierts auch auf der Portal-Seite !

Vielen dank Dragon
Mist doch nicht ganz!

Wenn ich wie in Punkt 6 beschriebenen Code im portal template eingefüge,
krieg ich mit dem IE einen Error angezeigt:
Zitat:Die Internetseite XXX kann nicht geöffnet werden.
Vorgang abgerochen.
Dann wird das laden der Seite abgerochen und es wird gar nichts mehr angezeigt !

Der Error kommt nur auf der Portalseite, nicht in den Foren Beiträgen.

Aber im FF funktionierts einwandfrei !

Hilfe Huh
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Lightbox für 1.8 bwlures 3 498 12.06.2017, 20:05
Letzter Beitrag: Jockl
  Lightbox in Portal verwenden Vespa 8 617 15.04.2017, 20:18
Letzter Beitrag: Vespa
  FancyZoom für MyBB (weil Lightbox ja blöd ist^^) querschlaeger 12 3.203 23.06.2013, 10:59
Letzter Beitrag: Yessie
  Lightbox und ezGallery ? RedBull 1 1.094 01.07.2011, 21:21
Letzter Beitrag: Robby125
Photo Lightbox benutzen um Thumbnails (angehängte Bilder) zu öffnen! querschlaeger 14 5.693 16.11.2010, 23:05
Letzter Beitrag: Manni