Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
ThankYou
#61
Hallo Liebe Gemeinde habe da mal wider eine Frage an euch.Und zwar geht es um das Thank you 3.7 Plugin.Es geht alles wunderbar,aber was mich stört ist das man ein Danke wider Entfernen kann.Meine Frage gibt es eine Möglichkeit das zu ändern.
Zitieren
#62
Das Plugin habe ich noch nicht verwendet, aber in der plugin-Datei gibt es folgenden Code:
PHP-Code:
if($mybb->user['uid'] != && $mybb->user['uid'] != $post['uid']) {
    if(!
$b)  //show thank button 
        
$post['thanks'] = "<a id=\"a{$post['pid']}\" onclick=\"javascript: ThankYou.thx({$post['pid']}); return false; \" href=\"showthread.php?action=thank&tid={$post['tid']}&pid={$post['pid']}\">
        <img src=\"
{$theme['imgdir']}/postbit_thx.gif\" border=\"0\" alt=\"$lang->thx_main\" id=\"i{$post['pid']}\" /></a>";
    else 
        
$post['thanks'] = "<a id=\"a{$post['pid']}\" onclick=\"javascript: ThankYou.rthx({$post['pid']}); return false; \" href=\"showthread.php?action=remove_thank&tid={$post['tid']}&pid={$post['pid']}\">
        <img src=\"
{$theme['imgdir']}/postbit_rthx.gif\" border=\"0\" alt=\"$lang->thx_remove\" id=\"i{$post['pid']}\" /></a>";


Du könntest ja mal probieren, diese Code wie folgt zu ändern und sehen, ob das Löschen immer noch möglich ist.
PHP-Code:
if($mybb->user['uid'] != && $mybb->user['uid'] != $post['uid']) {
    if(!
$b)  //show thank button 
        
$post['thanks'] = "<a id=\"a{$post['pid']}\" onclick=\"javascript: ThankYou.thx({$post['pid']}); return false; \" href=\"showthread.php?action=thank&tid={$post['tid']}&pid={$post['pid']}\">
        <img src=\"
{$theme['imgdir']}/postbit_thx.gif\" border=\"0\" alt=\"$lang->thx_main\" id=\"i{$post['pid']}\" /></a>";
    
/*else 
        $post['thanks'] = "<a id=\"a{$post['pid']}\" onclick=\"javascript: ThankYou.rthx({$post['pid']}); return false; \" href=\"showthread.php?action=remove_thank&tid={$post['tid']}&pid={$post['pid']}\">
        <img src=\"{$theme['imgdir']}/postbit_rthx.gif\" border=\"0\" alt=\"$lang->thx_remove\" id=\"i{$post['pid']}\" /></a>";*/

viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#63
Habe es gemacht wie hier beschrieben aber ohne Erfolg. Es gab keine Änderung. Die Option Danke Entfernen war immer noch da und ging nach wie vor.



scheint so also leider nicht zu funktionieren Sad
if i had a fussel, a fussel in the morning ...
Zitieren
#64
Mist, ich habe einen idiotischen Fehler gemacht. Ich hatte die alte Version 3.0.6 noch drauf und statt nur die neue thx.php in den inc-Ordner zu laden, habe ich erst das alte PlugIn deaktiviert und dann das neue wieder aktiviert. Zwar sind noch alle Danke-Punkte in der Datenbank. aber trotzdem werden nur Null Dankepunkte bei jedem angezeigt. Sad
Was kann ich tun, damit die Punkte wieder richtig aus der Datenbank angezeigt werden?
VG,
Susanne
Zitieren
#65
Versuchs mal mit der Cache diese zu leeren.
Zitieren
#66
Danke für deine Hilfe, aber ich hab's aufgegeben. Da war zu viel, was nicht funktionierte. Jetzt benutze ich ThankyouLike und bin zufrieden.....bisher. Big Grin
VG,
Susanne
Zitieren
#67
Ich finde dieses Plugin wirklich gut

aber ist es irgendwie möglich das sich die Seite nach dem Bedanken allein neu lädt

wenn ja was muss ich da wo ändern

Danke für eure Hilfe
Zitieren
#68
Bei mir geht das Tool nicht, ich habe es auf den FTP geladen und Aktiviert alles ohne Probleme, und nun, es erscheint kein Problem, aber es erscheint kein "Thanks" oder so unter dem Post eines anderen.
Aber an der Seite steht:

Code:
Thanks: 0
0 thank was given in 0 posts
Zitieren
#69
Das wurde hier schon einmal angesprochen: https://www.mybb.de/forum/thread-20719-p...#pid145124
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#70
(23.07.2010, 17:00)StefanT schrieb: Das wurde hier schon einmal angesprochen: https://www.mybb.de/forum/thread-20719-p...#pid145124

Bei mir ist es anders, bevor ich das Forum vorhin neu aufgesetzt hatte, ging alles.
Nur jetzt, ich hab genau alles gleich gemacht, geht es nicht, es erscheint kein "Thanks" unter dem Post, ich finde auch die Lösung in den andern Threads hier nicht.
Ich habe es installiert & aktiviert.
Keine Fehler.
Nur das "Thanks" erscheint halt nicht.(Wär mir egal ob mit oder ohne Button).
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Thankyou MyBB System MyBB.de Bot 40 2.771 29.09.2018, 12:20
Letzter Beitrag: MyBB.de Bot
  Thankyou/Thanks button MyBB.de Bot 0 757 10.10.2010, 17:01
Letzter Beitrag: MyBB.de Bot