Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Shoutbox
Hallo also es muss an diesem Code liegen...aber wo?
PHP-Code:
<?php
/**
 * Shoutbox Plugin for MyBB
 * Copyright © 2007 MyBB Mods
 *
 * By: Musicalmidget
 * Website: http://mods.mybboard.net/
 */

/* YOU MAY TRANSLATE THIS FILE FOR YOUR OWN PERSONAL USE,
 * AND DISTRIBUTE IT AS YOU WISH.  HOWEVER, YOU MAY NOT
 * DISTRIBUTE ANY FILES FROM THIS PLUGIN OTHER THAN TRANSLATED
 * LANGUAGE FILES WITHOUT THE PRIOR CONSENT OF THE AUTHOR.
 * SEE THE INCLUDED README.TXT FOR FURTHER DETAILS.
 */

$l['shoutbox'] = 'Shoutbox';
$l['shout_refresh'] = 'Abschicken / Aktualisieren';
$l['edit'] = 'Bearbeiten';
$l['enable'] = 'Enable';
$l['disable'] = 'Disable';
$l['edit_shout'] = 'Eintrag bearbeiten';
$l['delete_shout'] = 'Eintrag löschen';

$l['shout_hover'] = "Posted: {1} {2}{3}";
$l['shout_hover_ip'] = ', IP Address: {1}';
$l['auto_refresh'] = '{1} Auto Refresh';

$l['confirm_shout_delete'] = 'Willst du diesen Eintrag wirklich löschen?';

$l['error_no_permission'] = 'Du bist nicht Berechtigt, auf die Shoutbox zuzugreifen!';
$l['error_no_shout'] = 'Du bist nicht berechtigt Einträge in der Shoutbox zu verfassen!';
$l['error_no_shouts'] = 'Zur Zeit sind keine Shoutbox Einträge verfügbar.';
$l['error_flood'] = 'Du hast die Grenze für maximal aufeinander folgene Einträge erreicht!  Du musst warten, bis ein anderer User einen Eintrag verfasst hat, bevor du wieder schreiben kannst.<br /><a href="{1}">Zurück zur Shoutbox</a>';
$l['error_shout_too_long'] = 'Dein Eintrag ist zu lang.  Die maximale Länge eines Eintrages beträgt {1} Zeichen.<br /><a href="{2}">Zurück zur Shoutbox</a>';
$l['error_shout_too_short'] = 'Dein Eintrag ist zu kurz.  Die minimale Länge eines Eintrages beträgt {1} Zeichen.<br /><a href="{2}">Zurück zur Shoutbox</a>';
$l['error_invalid_shout'] = 'Ungültiger Eintrag.';

$l['redirect_shout_edited'] = 'Der Eintrag wurde erfolgreich bearbeitet!<br />Du wirst nun zur Shoutbox weitergeleitet.';
$l['redirect_shout_deleted'] = 'Der Eintrag wurde erfolgreich gelöscht!<br />Du wirst nun zur Shoutbox weitergeleitet.';
?>
Zitieren
Ändere mal diese Zeile


$l['shout_hover'] = "Posted: {1} {2}{3}";


in


$l['shout_hover'] = 'Posted: {1} {2}{3}';
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
(01.08.2013, 15:46)MrBrechreiz schrieb: Ändere mal diese Zeile


$l['shout_hover'] = "Posted: {1} {2}{3}";


in


$l['shout_hover'] = 'Posted: {1} {2}{3}';

Nö...das war es auch nicht...immer noch die gleiche Fehlermeldung
Zitieren
Was nicht weiter erstaunlich ist, denn die Änderung ist sinnlos, da beides äquivalent ist...
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
Öffne die Datei noch einmal mit Notepad++, überprüfe die Kodierung, setze sie auf "UTF-8 ohne BOM" und speichere die Datei erneut ab.
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
(01.08.2013, 21:12)Jockl schrieb: Öffne die Datei noch einmal mit Notepad++, überprüfe die Kodierung, setze sie auf "UTF-8 ohne BOM" und speichere die Datei erneut ab.


Super...Danke...es hat geklappt alles funktioniert...THX...

Also kann man davon ausgehen...das wenn was nicht funktioniert...man mit b.z.w ohne BOM abspeichern muss...müsste...?
Zitieren
Bevor ich mir jetzt das forum zerschiesse frage ich erstmal hier.
Topic says all.

Oder gibt es eine aktuelle funktionierende Shoutbox?
Zitieren
Wenn da steht mit 1.6 kompatible dann ist sie mit jeder 1.6 Version kompatible.
Wenn das da nicht steht dann wohl nicht Wink
Und auch wenn es passiert sonst nix, wenn du aktivieren klickst kommt dann einfach das die Version nicht kompatible ist.
Crashen kannst du nix Toungue
Zitieren
Dieser Benutzer erhält keinen Support, da eines seiner Foren nicht unseren Foren-Regeln entspricht!

Also ich habe shoutbox 2.2 heruntergeladen..auf den Server verschoben und dann wollte ich im admin Panel unter plugins installieren und dann kam folgender mysql Datenbank fehler (siehe bíld)


Angehängte Dateien Thumbnail(s)
   
Mit freundlichen Grüßen
Jonas
Zitieren
In der Installationsfunktion muss "TYPE=MyISAM" in "ENGINE=MyISAM" geändert werden.
Allerdings wird das nicht der einzige Fehler sein. Die Shoutbox 2.2 ist für MyBB 1.4, da wird so einiges nicht mehr mit dem aktuellen MyBB 1.8 funktionieren, zumindest der Admin CP Teil des Plugins wird ohne weitere Codeänderungen gar nicht erst sichtbar sein.
Zitieren