Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
custom header logo > weiße Seite > internal server error
#1
Hallo

ich habe mir jetzt die Finger wund gesucht und weiß auch das hier kein direkter Support für mods gegeben wird. Da mein Englisch aber nicht gut genug ist im Englischen Board zu schreiben hoffe ich das man mir hier eventuell auf den Weg helfen kann.

Mal ein paar Daten vorab.

Forenversion: 1.6.3 letzter Stand
PHP Version 5.2.11
MySQL 5.0.51a
Plugin Custom Header Logo for Forums 0.3

Die Installation und Aktivierung verläuft einwandfrei. Die wechselnden Headerbilder werden auch korrekt angezeigt beim Aufruf des entsprechenden Forums.
Klicke ich dann allerdings auf einen Beitrag erscheint eine weiße Seite ohne Meldung.
Im Error-Log des Servers finde ich dann:
Zitat:PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 130836434 bytes) in /xxx/xxxx/xxxx/xxxx/xxxxx/inc/plugins/customforumlogo.php on line 183

Zeile 183 der customforumlogo.php

Code:
$page = preg_replace("!{$theme['logo']}!i", "{$customlogo}", $page);

Das max. memorylimit steht in der php ini auf 128mb und die Headerbilder sind zwischen 50 und 100kb groß.

Und nu komme ich nicht weiter und finde im ganzen weiten Netz nichts dazu.

Falls ich hier völlig verkehrt bin schiebt den Thread in den Müll. Ich hoffe jedoch das man mir hier ein paar Tipps geben kann die mir dann zur Not das Schreiben im Englischen Board erleichtern.

Gruß vom Niederrhein
Zitieren
#2
Wow, das habe ich ja noch nicht gesehen. Tatsächlich scheinen die 128MB nicht auszureichen. Wenn ich das richtig sehe will alleine das Plugin 124MB haben, das wird natürlich eng. Dem Code nach ist das auch nicht optimal: Es wird die gesamte Ausgabe geparst, nur um das Logo auszutauschen.

Wenn du dich ein Wenig mit PHP auskennst, würde ich das Zufallslogo in eine Variable schreiben und diese ins Template header einfügen, das sollte wesentlich effizienter sein.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
(26.04.2011, 21:22)Michael schrieb: Wow, das habe ich ja noch nicht gesehen. Tatsächlich scheinen die 128MB nicht auszureichen.
Wahrscheinlich eine Endlosschleife. Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#4
Danke erstmal für die Antworten soweit aber ich bin kein Coder. Kann den Code einigermassen interpretieren und habe damit bis jetzt die meisten Hürden umschiffen können. Lesen, vergleichen, copy, paste.

Zitat:ein Wenig mit PHP auskennst, würde ich das Zufallslogo in eine Variable schreiben

Da scheitert es dann leider. Naja mal schauen welche Alternative ich finde die Headerbilder zu wechseln.

Gruß vom Niederrhein
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Weise Seite nach 'Button in Editor einfügen'..? ianthinarum 3 436 27.06.2013, 22:03
Letzter Beitrag: MrBrechreiz
  500 - Internal Server Error Lukαs 5 1.967 18.05.2011, 14:54
Letzter Beitrag: StefanT
  500 Internal Server Error Hollow 3 993 29.10.2010, 16:55
Letzter Beitrag: StefanT
  Eigene Seite mit custom Code MH_Razen 12 2.251 29.06.2010, 15:41
Letzter Beitrag: MH_Razen
  Weiße Seite beim löschen - User Guestbook RhymeFront 6 1.775 09.03.2009, 20:11
Letzter Beitrag: RhymeFront