Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Problem mit AJAX Chat
#1
Tag Leute,
ich habe mir heute den AJAX Chat installiert.
Nun möchte ich mich anmelden und erhalte folgenden Error:
Code:
Query: SELECT userID, userName, userRole, channel, UNIX_TIMESTAMP(dateTime) AS timeStamp, ip FROM db1177003-main.ajax_chat_online ORDER BY userName; Error-Report: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-main.ajax_chat_online ORDER BY userName' at line 9 Error-Code: 1064

Woran liegt es?
Wie löse ich es?

Ich hoffe ihr könnt mir helfen.

Gruß,
Funky
Zitieren
#2
Ist der Name der Datenbank wirklich db1177003-main?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
Jo so heißt die Datenbank, ist bei Kilu gehostet
Zitieren
#4
Ich denke, du musst den Datenbanknamen in Anführungszeichen setzen. Versuche die entsprechende Stelle im Code zu finden und anzupassen.
Code:
SELECT userID, userName, userRole, channel, UNIX_TIMESTAMP(dateTime) AS timeStamp, ip FROM `db1177003-main`.ajax_chat_online ORDER BY userName;

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#5
Wo kann ich denn diese Stelle finden?! o.o
Also in der config ist alles in Anführungszeichen gesetzt.
Zitieren
#6
also der fehler sagt die ja das die mysql abfrage bei -main falsch ist. soweit ich weiss kann php kein - in einer mysql abfrage verarbeiten. zumindest hat das bei mir öfter mal den fehler ausgelöst^^ probier mal das - durch einen _ zu ersetzen
Zitieren
#7
Da ist doch gar kein PHP drin...
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#8
ich nutze mysql aber nur im verbund mit php aber die mysql syntax ist ja eigentlich dieselbe Wink vor allem wenn der fehler vom mysql query ausgelöst wird
Zitieren
#9
Das kann ich ja nicht ändern, Kilu legt die Datenbanknamen selber fest.
Zitieren
#10
kannst du die nicht nachträglich noch irgendwo ändern? wenn nicht kann man das eigentlich auch mit einem php script machen.

but back to topic:

habe mal nach dem fehler gegoogelt und direkt beim ersten treffer folgendes gefunden:
'check the manual that corresponds to your MySQL server version' heisst dass du einen "veralteten" befehl bzw abfrage benutzt.
Quelle
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Ajax Chat @Frog hkkp 4 320 13.04.2016, 18:25
Letzter Beitrag: Yamek89
  "Who is in Ajax Chat"-Plugin für MyBB 1.8.4? Paccy 11 874 15.09.2015, 18:46
Letzter Beitrag: hkkp
  Wie im AJAX-Chat bestimmte Benutzgruppen ausschließen? Koelner 14 664 20.03.2015, 08:16
Letzter Beitrag: Koelner
  Ajax-Chat - Gäste ausschließen. Koelner 30 4.710 21.09.2014, 00:46
Letzter Beitrag: Dana
  Ajax Chat integration nyukuri 5 1.917 17.03.2014, 11:49
Letzter Beitrag: hkkp