Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehler beim Upgrade 1.2.9 auf 1.4
#1
Hallo,

möchte von 1.2.9 auf 1.4 upgraden. Habe mich strikt an die Anleitung gehalten, aber irgendwie will es nicht laufen:

1. Fehler

Folgende Fehlermeldung:
Fatal error: [SQL] [1054] Unknown column 'isdefault' in 'where clause'
SELECT name,sid FROM mybb_settings WHERE isdefault='1' OR isdefault='yes' ...

Dann habe ich folgenden SQL-Befehl (in einem anderen Post erwähnt) ausgeführt:

Code:
ALTER TABLE mybb_settings ADD isdefault char(3) NOT NULL default '';

Das hatte zur Folge, daß ich einen Schritt weiter gekommen bin, irgendwas wurde synchronisiert. Und dann kam Fehler Nr. 2:


2. Fehler

Jetzt kommt immer folgende Fehlermeldung und ich komme nicht weíter:

Erstellung der Caches
Fatal error: [SQL] [1146] Table 'db219950148.mybb_stats' doesn't exist
REPLACE INTO mybb_stats SET `dateline`='1217800800',`numusers`='12',`numthreads`='50',`numposts`='160' in /homepages/31/d37281982/htdocs/notarzt/forum/inc/db_mysql.php on line 544

Jedesmal, wenn ich nun das Upgrade-Script neu starte, bleibe ich hier hängen - und synchronisiert wird auch nichts mehr.

Was soll ich weiter tun? Danke für Euere Hilfe ...
#2
Bitte starte das Upgradeskript nochmal und wähle als Ausgangsversion MyBB 1.2.14. Läuft es jetzt durch?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
hi,

ja, mit 1.2.14 ist es durchgelaufen.

Jetzt habe ich aber folgende Probleme im Forum:

1. Einige der Links funktionieren nicht mehr richtig. So zielen viele Links z.B. auf das Hauptverzeichnis, obwohl das Forum doch im 2. Unterordner gespeichert ist. Logischerweise findet es natürlich im Hauptverzeichnis dann die Zieldatei auch nicht.

2. Im ACP / Forum Online-Offline habe ich nun 2x diesselben Optionsfelder samt Text. Ich denke, daß sich durch den Befehl:

"Code:
ALTER TABLE mybb_settings ADD isdefault char(3) NOT NULL default '';"

irgendwas verschoben hat. Kann ich den wieder rückgängig machen?[/align]
#4
Zu 1) Stelle sicher, dass in der allgemeinen Konfiguration im Admin-CP die richtige URL hinterlegt ist.

Zu 2) Gehe per phpMyAdmin in die Datenbanktabelle settings und lösche einfach die doppelten Einträge.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Hallo Michael,

danke für Deine Hilfe.

Habe nochmals den Original-Ausgangszustand von 2.1.9 hergestellt und dann das Upgrade-Script, allerdings von 1.2.14 aus (als Angabe vom Upgrade-Script), darüberlaufen lassen.
Hat alles wunderbar geklappt, Forum funktioniert.

Muß ich dann jetzt noch irgendetwas beachten. Sind auch so alle notwendigen Dateien geändert worden?

Danke
#6
Da du alle Dateien neu hochladen musst, sind alle Dateien aktuell. Das Upgradeskript nimmt nur Änderungen in der Datenbank vor. Diese sollte jetzt auch bei dir korrekt sein. Wenn nochmal ein Problem auftreten sollte, kannst du dich natürlich wieder melden. Wink

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#7
Schade. Ich dachte ich komme auch so weiter....Sad

Also:
Ich habe die komplette DB auf dem Server gelöscht und mit dem SQL-Backup wieder eingespielt mit PHPAdmin.

Dann habe ich auf dem Server auch komplett alle Dateien vom Forum gelöscht und die schon eingedeutschte 1.4-Version hochgespielt. Die beiden inc-Dateien haben die korrekte chmod mit 666 und die uploads-Verzeichnisse 777.

Wenn ich jetzt das Updatescript starte kommt:

server schrieb:Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /usr/export/www/hosting/arcticbears/forum/inc/class_session.php on line 291

Und im Fenster erscheint:
Fehler
You do not have permissions to run this process.

Was ist denn nu???


Liegt es evtl. daran, dass ich das DB-Backup in der Zeichencodierung utf8 eingespielt habe? Es gab aber keine Fehlermeldung.
#8
Versuche mal bitte den folgenden Code aus der install/upgrade.php zu entfernen und das Upgrade dann zu starten:
PHP-Code:
    else if($mybb->usergroup['cancp'] != && $mybb->usergroup['cancp'] != 'yes')
    {
        
$output->print_error("You do not have permissions to run this process.");
    } 
Eine Frage nebenbei: Warum hast du die Datenbank gelöscht und dann wieder eingespielt?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#9
Ups. Hast Du da ungefähr eine Zeilennummer? Sonst suche ich mich ja tot. Mit Kate findet man die Zeile schneller...
Ok. Schon gefunden und auskommentiert.

(06.08.2008, 23:26)Michael schrieb: Eine Frage nebenbei: Warum hast du die Datenbank gelöscht und dann wieder eingespielt?

Jo. Weil das Update mit dem Tip von 1.2.14 das Update zu starten ja schon durchgelaufen war, aber ich dann mich nicht einloggen konnte. Die Fehlermeldung habe ich aber leider wohl verbasselt. Hätte ich gerne gepostet, aber ich hatte hier im Forum arge Probleme mich anzumelden. Sorry.
Die DB war also schon mit dem Update-Skript geschreddert. Also warum nicht wieder das Backup für einen erneuten Versuch?



So. Nun lief das Update auch durch, zwar immer mit o.g. Fehlermeldung, aber immerhin. Das ist nach4 Stunden ja schon mal ein Erfolg.Wink
Bloss: Ich komme immer noch nicht ins Admin-CP (gleicher Fehler von vorhin!):
Fatal error: Cannot redeclare memory_get_peak_usage() in /usr/export/www/hosting/arcticbears/forum/inc/functions_compat.php on line 120

So. Dann war ich mal so frei und habe die lock-Datei wieder entfernt und das Upgrade-Script nochmal gestartet. Komisch. Diesmal ohne die Fehlermeldung (Warning: array_merge() [function.array-merge]: Argument #1 is not an array ...on line 291)

Trotzdem o.g. get_peak-Meldung....Sad
#10
Siehe: https://www.mybb.de/forum/thread-10140.html

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Upgrade 1.4.7 auf 1.4.8 = Fehlermeldung beim bearbeiten von Beiträgen Fidel 4 893 11.07.2009, 13:41
Letzter Beitrag: Fidel
  Fehler beim Upgrade chris14465 2 838 02.12.2008, 15:53
Letzter Beitrag: chris14465
  fehler beim upgrade Michel071276 7 2.052 05.08.2008, 21:39
Letzter Beitrag: Michael