Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Problem beim Integrieren des Forums in Site
#1
Hallo,ich will mein fertiges Forum nun in meine Site einfügen, und bin dabei nun erstmal vorgegangen wie hier bereits beschrieben:
Den Code dort wo das Forum rein soll teilen, oberhalb des headers den oberen Teil meines Site-Scripts einfügen und beim Footer das ganze unterhalb.

Allerdings scheint es Probleme zu geben, weil mein CSS Stylesheet, das in meinem Seitendesign aufgerufen wird, nicht richtig integriert wird.

Mein Stylesheet habe ich bei den Templates hinzugefügt, und die benötigten Bilder in den Ordner images kopiert.

Hier mein Code:
Code:
<div id="contents">
<div id="main">
<TABLE WIDTH="900" BORDER="0" CELLSPACING="0" CELLPADDING="0">
    <TR>                        
        <TD ALIGN="left" VALIGN="top" background="images/bg_ob1.jpg">                        
        <TABLE SUMMARY="Topnavigation" HEIGHT="78" BORDER="0" CELLSPACING="0" CELLPADDING="0">    
            <TR>
                <TD ALIGN="left" VALIGN="top"><IMG SRC="images/blank.gif" WIDTH="38" HEIGHT="25" BORDER="0" ALT=""></TD>                
                <TD ALIGN="left" VALIGN="middle"><P CLASS="hell">
                <script language="JavaScript"><!--
                var Datum = new (Date);
                var Tag = Datum.getDate();
                var Wochentag = Datum.getDay();
                var Monat = Datum.getMonth();
                var Jahr = Datum.getFullYear();
                var Tagname = new Array("Sonntag", "Montag", "Dienstag", "Mittwoch", "Donnerstag", "Freitag", "Samstag");
                var Stunde = Datum.getHours();
                var Minute = Datum.getMinutes();
                if(Minute < 10)
                {
                    Minute = "0" + Minute;
                }
                if(Stunde < 10)
                {
                Stunde = "0" + Stunde;
                }
                if(Monat < 10)
                {
               Monat = "0" + Monat;
                }
                document.write(Tagname[Wochentag]+", "+Tag+"."+Monat+"."+Jahr+" <BR> "+Stunde+":"+Minute+" Uhr");
                //--></script></P>
                </TD>
            </TR>
            </TABLE>
        </TD>        
                <TD ALIGN="left" VALIGN="top"><IMG SRC="images/bg_ob3.jpg" WIDTH="198" HEIGHT="78" BORDER="0" ALT=""></td>
    </TR>    
    <TR>
        <TD ALIGN="left" VALIGN="top">
        <div class=navBlock>
            <div class="listnavleft" style="display:block;">
                  <h1 class="navBlockUeberschrift"><a href="#">HOME</a></h1>
            </div><div class="listnavleft" style="display:block;">
                  <h1 class="navBlockUeberschrift"><a href="#">IDEE</a></h1></div><div class="listnavleft" style="display:block;">
                  <h1 class="navBlockUeberschrift"><a href="#">STUDIO SUCHEN</a></h1></div><div class="listnavleft" style="display:block;">
                  <h1 class="navBlockUeberschrift"><a href="#">STUDIO HINZUFÜGEN</a></h1></div><div class="listnavleft" style="display:block;">
                  <h1 class="navBlockUeberschrift"><a href="#">STUDIO BEWERTEN</a></h1></div><div class="listnavleft" style="display:block;">
                  <h1 class="navBlockUeberschrift"><a href="#">NUTZUNGSBEDINGUNGEN</a></h1>
                  </div><div class="listnavleft" style="display:block;">
                  <h1 class="navBlockUeberschrift"><a href="#">KONTAKT / IMPRESSUM</a></h1></div>
        </div>        
        </td>
        <TD ALIGN="left" VALIGN="top"><IMG SRC="images/willkommen_bild.jpg" WIDTH="503" HEIGHT="174" BORDER="0" ALT=""></td>
        <TD ALIGN="left" VALIGN="top"><IMG SRC="images/willkommen_bild2.jpg" WIDTH="198" HEIGHT="174" BORDER="0" ALT=""></td>
    </TR>    
    <TR>
        <TD ALIGN="left" VALIGN="top">
            <TABLE SUMMARY="linkeseite" BORDER="0" CELLSPACING="0" CELLPADDING="0">
                <TR>
                    <TD ALIGN="left" VALIGN="top"><IMG SRC="images/blank.gif" WIDTH="20" HEIGHT="20" BORDER="0" ALT=""></TD>
                    <TD ALIGN="left" VALIGN="top"><IMG SRC="images/blank.gif" WIDTH="160" HEIGHT="20" BORDER="0" ALT=""></TD>
                    <TD ALIGN="left" VALIGN="top"><IMG SRC="images/blank.gif" WIDTH="20" HEIGHT="20" BORDER="0" ALT=""></TD>
                </TR>
                <TR>
                    <TD ALIGN="left" VALIGN="top"><IMG SRC="images/blank.gif" WIDTH="20" HEIGHT="20" BORDER="0" ALT=""></TD>                
                    <TD ALIGN="left" VALIGN="top"><P>Google-Anzeigen:</P>
                  </TD>            
                    <TD ALIGN="left" VALIGN="top"><IMG SRC="images/blank.gif" WIDTH="20" HEIGHT="20" BORDER="0" ALT=""></TD>                            
                </TR>                                                                                                                                    
            </TABLE>
        </TD>
        <TD COLSPAN="2" ALIGN="left" VALIGN="top">        <table summary="Inhalt" border="0" cellspacing="0" cellpadding="0">
          <tr>
            <td align="left" valign="top"><img src="images/blank.gif" width="23" height="14" border="0" alt=""></td>
            <td align="left" valign="top"><img src="images/blank.gif" width="140" height="16" border="0" alt=""></td>
            <td align="left" valign="top"><img src="images/blank.gif" width="290" height="14" border="0" alt=""></td>
            <td align="left" valign="top"><img src="images/blank.gif" width="48" height="14" border="0" alt=""></td>
            <td align="left" valign="top"><img src="images/blank.gif" width="200" height="14" border="0" alt=""></td>
          </tr>
          <tr>
            <td align="left" valign="top"><img src="images/blank.gif" width="23" height="16" border="0" alt=""></td>
            <td colspan="2" align="left" valign="top">
    <a name="top" id="top"></a>
    <div id="container">
        <div id="header">
                        <div class="menu">
                <ul>
                    <li><a href="{$mybb->settings['bburl']}/search.php"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/search.gif" alt="" />{$lang->toplinks_search}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/memberlist.php"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/memberlist.gif" alt="" />{$lang->toplinks_memberlist}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/calendar.php"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/calendar.gif" alt="" />{$lang->toplinks_calendar}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/misc.php?action=help"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/help.gif" alt="" />{$lang->toplinks_help}</a></li>
                </ul>
            </div>
            <hr class="hidden" />
            <div id="panel">
                {$welcomeblock}
            </div>
        </div>
        <hr class="hidden" />
        <br class="clear" />
        <div id="content">
            {$bannedwarning}
            {$bbclosedwarning}
            {$unreadreports}
            <navigation>
            <br class="clear" />

Code:
<br />
            <div class="bottommenu"><span class="smalltext"><a href="{$mybb->settings['contactlink']}">{$lang->bottomlinks_contactus}</a> | <a href="{$mybb->settings['homeurl']}">{$mybb->settings['homename']}</a> | <a href="#top">{$lang->bottomlinks_returntop}</a> | <a href="#content">{$lang->bottomlinks_returncontent}</a> | <a href="<archive_url>">{$lang->bottomlinks_litemode}</a> | <a href="{$mybb->settings['bburl']}/misc.php?action=syndication">{$lang->bottomlinks_syndication}</a></span>
            </div>
            </div>
        <hr class="hidden" />
            <div id="copyright">
                <div id="debug"><debugstuff></div>
                <!-- You may NOT remove, modify or hinder the visibility of the MyBB copyright at any time.
                     It must contain the links to the MyBB website and be formatted appropriately.

                     Failure to comply with the above will result in prosecution to the full extent of the law.
                     This is free software, support us and we'll support you. -->
{$lang->powered_by} <a href="http://www.mybboard.net" target="_blank">MyBB</a> {$mybbversion}<br />
                {$lang->copyright} &copy; 2002-{$copy_year} <strong><a href="http://www.mybboard.net" target="_blank">MyBB Group</a></strong>
                <!-- End copyright -->
                <br />
<br class="clear" />
        </div>
        </div>
</td>
            <td align="left" valign="top"><img src="images/blank.gif" width="48" height="16" border="0" alt=""></td>
            <td align="left" valign="top"><img src="images/blank.gif" width="48" height="16" border="0" alt=""></td
          ></tr>
          <tr>
            <td align="left" valign="top"><img src="images/blank.gif" width="23" height="16" border="0" alt=""></td>
            <td colspan="2" align="left" valign="top"><p><blink>
                <marquee scrollamount="5" scrolldelay="1">
                </marquee>
            </blink></p>
                </td>
            <td align="left" valign="top"><img src="images/blank.gif" width="48" height="16" border="0" alt=""></td>
            <td align="left" valign="top"><img src="images/blank.gif" width="48" height="16" border="0" alt=""></td>
          </tr>
        </table></TD>
    </TR>
    </TABLE>
</div>
<div id="footer"><p>&nbsp;</p></div>
</div>
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
</script>
<script type="text/javascript">
_uacct = "UA-2900066-1";
urchinTracker();
</script>

<script type="text/javascript" src="google_javascript/wagt_maps.js">/*wagt*/</script>

Bitte sagt mir was da falsch ist, dreh gerade echt am Rad, so kurz vor dem Ziel...!
Vielen Dank!
Zitieren
#2
Kannst du einen Link zum Forum posten?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
Ich habe das Ganze gerade erst auf localhost zum laufen gebracht, daher konnte ich noch keinen Link einstellen.

Hier der Link zu meiner Site, die ist schon online und verwendet das gleiche Design, vielleicht hilft das ja:
http://www.studio-bewertungen.de/
Zitieren
#4
Jetzt habe ich mal die Forensoftware versucht auf meinen Webspace zu spielen, und es genauso nochmal gemacht.
hier der link:
http://www.studio-bewertungen.de/upload
Zitieren
#5
Liegt wohl daran, dass das MyBB-CSS die Einstellungen Deiner Seite (bzw. umgekehrt - je nach Reihenfolge) überschreibt.

Ich würde so vorgehen: Im Admin-CP unter

Foreneinstellungen --> Ändern --> Server- und Optimierungs-Optionen --> CSS Medium

die Speicherung im Ordner "CSS" wählen. In diesem Ordner findest Du dann die CSS-Datei des Forums. Dabei darauf achten, dass Du die richtige nimmst; es gibt u.U. mehrere! Diese jetzt mit der CSS-Datei Deiner "normalen" Seite abgleichen, sprich Unstimmigkeiten (doppelte Einträge für <p>, <table> etc.) beheben und als neue Datei speichern.

Dann nur noch in Deiner "normalen" Seite und im Template "headerinclude" des MyBB auf diese neue Datei verlinken und schon sollte es funktionieren ...
 
The User, Formerly Known As "En-Gedi"
 
Zitieren
#6
Im Ordner CSS habe ich nur eine index.html-Datei, sonst nichts. Im Ordner Uploads habe ich die Datei css.php, aber die wird es wohl nicht sein....
Zitieren
#7
Wenn Du die o.a. Änderung im Admin-CP durchführst, sollte die Datei unter dem Namen "theme_1.css" (oder so ähnlich) eigentlich gespeichert werden.

Evtl. hilft es, die Berechtigungen des Ordners "CSS" vorher auf CHMOD 777 zu stellen.

Und richtig ... die css.php hat damit nichts zu tun.
 
The User, Formerly Known As "En-Gedi"
 
Zitieren
#8
Wenn ich mir den Quelltext ansehe, kann ich nicht feststellen, dass du die CSS-Datei deiner Seite eingebunden hast. Das musst du im Template headerinclude machen.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#9
Also die "theme_1.css" habe ich jetzt übrigens gefunden, d.h. ich habe jetzt mein Stylesheet für die Site und das fürs Forum, und nun muss ich der Seite, bei der das Forum eingebunden wird, sagen, dass es die Vorgaben beider Stylesheets berücksichtigen soll.
Hab ich das so richtig verstanden?
Gestern Abend habe ich noch probiert, die beiden Stylesheets kompatibel zu machen (wie von en-gedi) beschrieben, leider ist mir das nicht wirklich gelungen...
In meiner headerinclude steht jedenfalls folgende Zeile:
Code:
<link rel="stylesheet" type="text/css" href="{$theme['css_url']}" />

Und da müsste jetzt noch diese Zeile aus meinem Site-Script rein:
Code:
<LINK REL=stylesheet TYPE="text/css" HREF="styles/style.css">

Könnt ihr mir sagen wie ich das ganze kompatibel mache?
Vielen Dank für eure Hilfe!
Zitieren
#10
Fast geschafft ... aber solange Du mit 2 unterschiedlichen CSS-Dateien arbeitest, wirst Du wohl immer Probleme haben. Wenn z.B. in einer Datei für <p> die Schriftgröße 12px und in der anderen die Schriftgröße 14px angegeben ist, wird immer die in der Reihenfolge zuletzt genannte Größe genommen.

Es wäre wohl am besten, den Inhalt der "theme_1.css" in Deine vorhandene "styles.css" (ans Ende) zu kopieren und dann diese Datei Punkt für Punkt zu überarbeiten, damit doppelte Einträge vermieden werden.

Ist zwar mit einiger Arbeit verbunden und vielleicht wirst Du auch irgendwo Kompromisse eingehen müssen, aber das Ergebnis wird sich sicherlich lohnen: ein perfekt in Seite integriertes MyBB Wink

Diese überarbeitete "styles.css" kannst Du dann wie gewohnt in Deiner bisherige Seite und im Template "headerinclude" des MyBB verlinken.

Dazu einfach die bisherige Zeile in "headerinclude"

Code:
<link rel="stylesheet" type="text/css" href="{$theme['css_url']}" />

ersetzen durch

Code:
<link rel="stylesheet" type="text/css" href="pfad_zu_deinem_styles_ordner/styles.css" />

===

Du kannst die bisherige Konstellation natürlich auch erst mal testen, um zu sehen, ob überhaupt und wo evtl. Fehler auftauchen. Dazu einfach Deine bisherige "styles.css" zusätzlich im Template "headerinclude" eintragen. Wenn Du die o.a. Speicherung des CSS-Mediums als Datei noch aktiviert hast, mit diesem Code:

Code:
<link rel="stylesheet" type="text/css" href="{$mybb->settings['bburl']}/css/theme_1.css" />
<link rel="stylesheet" type="text/css" href="pfad_zu_deinem_styles_ordner/styles.css" />

Für die Speicherung des CSS-Mediums in der Datenbank mit diesem Code:

Code:
<link rel="stylesheet" type="text/css" href="{$theme['css_url']}" />
<link rel="stylesheet" type="text/css" href="pfad_zu_deinem_styles_ordner/styles.css" />
 
The User, Formerly Known As "En-Gedi"
 
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Aufbau des MyBB.de Forums / Vanilla Funktionen Carsten 3 81 03.12.2016, 15:21
Letzter Beitrag: MrBrechreiz
  Breite des Forums Kalle 3 1.223 26.04.2013, 22:54
Letzter Beitrag: Kalle
  Darstellungsfehler des Forums Trust 3 3.655 19.11.2012, 15:52
Letzter Beitrag: Kenny
  feste Breite des Forums Maurizia 7 3.245 04.11.2012, 12:46
Letzter Beitrag: Murphy
  "Name des Forums" entfernen mani2go 7 890 19.04.2012, 10:36
Letzter Beitrag: mani2go