Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Code für den Header mit Link und Bild einfügen
#21
Sry, aber um die Uhrzeit kann ich ned so gut Fehler entdecken, es lag daran dass die schweiften Klammern am Anfang nicht mehr geschlossen wurden. Hier der Code der nun endgültig funktionieren sollte, aber immerhin sind die anderen Fehler schon alle behobenWink:
Code:
<div class="menu">
                <ul>
                
<li>
<a href="{$mybb->settings['bburl']}/index.php"><img src="{$theme['imgdir']}/toplinks/grafiknameindex.gif" alt="" /> Forum</a>
<a href="{$mybb->settings['bburl']}/portal.php"><img src="{$theme['imgdir']}/toplinks/grafiknameportal.gif" alt="" /> Portal</a>
<a href="{$mybb->settings['bburl']}/vgallery.php"><img src="{$theme['imgdir']}/toplinks/grafiknametubegallerie.gif" alt="" /> Tube Video Gallery</a>
<a href="{$mybb->settings['bburl']}/gallerie/index.php"><img src="{$theme['imgdir']}/toplinks/grafiknamegallerie.gif" alt="" /> Gallerie</a>
<a href="{$mybb->settings['bburl']}/games.php"><img src="{$theme['imgdir']}/toplinks/grafiknamespiele.gif" alt="" /> Spiele</a>
<a href="{$mybb->settings['bburl']}/search.php"><img src="{$theme['imgdir']}/toplinks/grafiknamesuche.gif" alt="" /> {$lang->toplinks_search}</a>
<a href="{$mybb->settings['bburl']}/memberlist.php"><img src="{$theme['imgdir']}/toplinks/grafiknamemember.gif" alt="" /> {$lang->toplinks_memberlist}</a>
<a href="{$mybb->settings['bburl']}/calendar.php"><img src="{$theme['imgdir']}/toplinks/grafiknamekalender.gif" alt="" /> {$lang->toplinks_calendar}</a>
<a href="{$mybb->settings['bburl']}/misc.php?action=help"><img src="{$theme['imgdir']}/toplinks/grafiknamehelp.gif" alt="" /> {$lang->toplinks_help}</a>
</li>
</ul>
            </div>
Keinen Support per PN, eMail und Messenger
computerhartware.de
GIGA - Spielen geht immer!
Zitieren
#22
cool jetzt wird es angezeigt, aber leider nicht die bilder zu den links...

wen du müde bist, können wir es auch bis die nächsten tage lassen..
will dich nicht bedrängen..
Zitieren
#23
Dass mit den Bildern musst du selber machen, wenn du z.B. für den Link "index" die Grafik ändern willst, änderst du einfach "grafiknameindex.gif" in den entsprechenden Namen. Natürlich musst du Bilder noch hochladen wie vorher schon mal beschrieben, in images/toplinks.Wink
Keinen Support per PN, eMail und Messenger
computerhartware.de
GIGA - Spielen geht immer!
Zitieren
#24
habe es herausgefunden


ich hab 2 schon fertig und die funktionieren

<li>
<a href="{$mybb->settings['bburl']}/portal.php"><img src="http://www.tunisdeluxe.de/images/toplinks/portal.gif" alt="">Portal
<a href="{$mybb->settings['bburl']}/vgallery.php"><img src="http://www.tunisdeluxe.de/images/toplinks/tube.gif" alt="">Tube Video Gallery


danke dir für deine Hilfe..

vielleicht kannst du erkennen woran es lag..

sollten da noch ein paar script fehler sein, lass es mich wissen...
Zitieren
#25
PHP-Code:
<a name="top" id="top"></a>
    <
div id="container">
        <
div id="header">
            <
table width="100%" class="logo" cellpadding="0" cellspacing="0">
        <
tr>
        <
td style="padding:0px">
            <
a href="{$mybb->settings['bburl']}/index.php"><img src="{$theme['logo']}alt="{$mybb->settings['bbname']}/></a>
{
$whosonline}
            </
td>
            </
tr>
            </
table>
            <
div class="menu">
                <
ul>
                
<
li>
<
a href="{$mybb->settings['bburl']}/portal.php"><img src="http://www.tunisdeluxe.de/images/toplinks/portal.gif" alt="">Portal</a>
<
a href="{$mybb->settings['bburl']}/vgallery.php"><img src="http://www.tunisdeluxe.de/images/toplinks/tube.gif" alt="">Tube Video Gallery</a>
<
a href="{$mybb->settings['bburl']}/gallerie/index.php"><img src="http://www.tunisdeluxe.de/images/toplinks/gallery.gif" alt="">Gallerie</a>
<
a href="{$mybb->settings['bburl']}/games.php"><img src="http://www.tunisdeluxe.de/images/toplinks/game.gif" alt="">Spiele</a>
<
a href="{$mybb->settings['bburl']}/search.php"><img src="http://www.tunisdeluxe.de/images/toplinks/search.gif" alt="" /> {$lang->toplinks_search}</a>
<
a href="{$mybb->settings['bburl']}/memberlist.php"><img src="http://www.tunisdeluxe.de/images/toplinks/memberlist.gif" alt="" /> {$lang->toplinks_memberlist}</a>
<
a href="{$mybb->settings['bburl']}/calendar.php"><img src="http://www.tunisdeluxe.de/images/toplinks/calendar.gif" alt="" /> {$lang->toplinks_calendar}</a>
<
a href="{$mybb->settings['bburl']}/misc.php?action=help"><img src="http://www.tunisdeluxe.de/images/toplinks/help.gif" alt="" /> {$lang->toplinks_help}</a>
</
li>
</
ul>
            </
div>
                    
            <
hr class="hidden" />
            <
div id="panel">
                {
$welcomeblock}
            </
div>
        </
div>
        <
hr class="hidden" />
        <
br class="clear" />
        <
div id="content">
            {
$bannedwarning}
            {
$bbclosedwarning}
            {
$unreadreports}


{
$boardmsg

mit diesem Code funktioniert es, jedoch habe ich unter validator mehr script fehler feststellen müssen.

kann mir da jemand Helfen wie ich das beheben kann?

lieben dank..

Validator
Zitieren
#26
Hallo aman,

zum Validierungsergebnis folgende Hilfen:
  • Zeile 2 - 1. Hinweis / Zeile 37:
    im Template "Portal Templates / Portal" scheinen die End-Tags "</body>" und "</html>" zu fehlen.
    Code:
    ...
    </table>
    {$footer}
    </body>
    </html>
  • Zeile 2 - 2. Hinweis:
    siehe > diesen Beitrag <.
  • Zeilen 54 - 57:
    ändere/ergänze in den angegebenen Zeilen/Links nach "alt="">" in/zu "alt="" />" - z. B.
    PHP-Code:
    <a href="http://www.tunisdeluxe.de/gallerie/index.php"><img src="http://www.tunisdeluxe.de/images/toplinks/gallery.gif" alt="">Gallerie</a
    in
    PHP-Code:
    <a href="http://www.tunisdeluxe.de/gallerie/index.php"><img src="http://www.tunisdeluxe.de/images/toplinks/gallery.gif" alt="" />Gallerie</a
Weitere Antworten und Hinweise findest du auch in den jeweils dazu angegebenen Links bzw. > hier <

Ich hoffe, dies hilft dir weiter.
Zitieren
#27
Boah danke dir, habe jetzt anstatt 50 fehler 32 lol

heute abend wenn ich zuhause bin, werde ich mal die functions.php umändern wie du es mir im link gezeigt hast.

Danke nochmalSmile


achja zwischen den Buttons sind noch freiräume, die sehen nicht gut aus.

wie kann ich das umändern, das die buttons wie vorher dicht zusammen sind?

link ist unten zu sehen!

EDIT:

in welchem template finde kann ich diese fehler umändern?

PHP-Code:
eile    Spalte:    187
224    Fehler
:    div ist an dieser Stelle nicht erlaubtEs fehlt ein `object`, `applet`, `map`, `iframe`, `button`, `ins`, `delElement.
     
Fehlerstelle:    

 
alt="0"  /></td><td class="trow1"><p><div><object width="425" height="335"


     
Spalte:    368
Fehler
:    Im Element `embedist das Attribut `srcnicht erlaubt.
Fehlerstelle:    

llscreen" value="true"></param><embed src="http://www.dailymotion.com/swf/2a 


     
Spalte:    423
Fehler
:    Im Element `embedist das Attribut `typenicht erlaubt.
Fehlerstelle:    

ailymotion.com/swf/2aSKB43jqBGNbjXeo" type="application/x-shockwave-flash" w 


     
Spalte:    460
Fehler:    Im Element `embed` ist das Attribut `width` nicht erlaubt.
Fehlerstelle:    

 type="
application/x-shockwave-flash" width="425" height="335" allowfullscre 


     
Spalte:    472
Fehler:    Im Element `embed` ist das Attribut `height` nicht erlaubt.
Fehlerstelle:    

cation/x-shockwave-flash" 
width="425" height="335" allowfullscreen="true"></ 


     
Spalte:    485
Fehler
:    Im Element `embedist das Attribut `allowfullscreennicht erlaubt.
Fehlerstelle:    

kwave-flash" width="425" height="335" allowfullscreen="true"></embed></objec 


     
Spalte:    361
Fehler:    Unbekanntes Element `embed`. Eine Liste der erlaubten Elemente finden Sie hier.
Fehlerstelle:    

allowfullscreen" 
value="true"></param><embed src="http://www.dailymotion.com 


Angehängte Dateien Thumbnail(s)
   
Zitieren
#28
aman schrieb:Zeile Spalte: 187
224 Fehler: div ist an dieser Stelle nicht erlaubt. Es fehlt ein `object`, `applet`, `map`, `iframe`, `button`, `ins`, `del` Element.
Fehlerstelle:

alt="0" /></td><td class="trow1"><p><div><object width="425" height="335">



Spalte: 368
Fehler: Im Element `embed` ist das Attribut `src` nicht erlaubt.
Fehlerstelle:

llscreen" value="true"></param><embed src="http://www.dailymotion.com/swf/2a



Spalte: 423
Fehler: Im Element `embed` ist das Attribut `type` nicht erlaubt.
Fehlerstelle:

ailymotion.com/swf/2aSKB43jqBGNbjXeo" type="application/x-shockwave-flash" w



Spalte: 460
Fehler: Im Element `embed` ist das Attribut `width` nicht erlaubt.
Fehlerstelle:

type="application/x-shockwave-flash" width="425" height="335" allowfullscre



Spalte: 472
Fehler: Im Element `embed` ist das Attribut `height` nicht erlaubt.
Fehlerstelle:

cation/x-shockwave-flash" width="425" height="335" allowfullscreen="true"></



Spalte: 485
Fehler: Im Element `embed` ist das Attribut `allowfullscreen` nicht erlaubt.
Fehlerstelle:

kwave-flash" width="425" height="335" allowfullscreen="true"></embed></objec



Spalte: 361
Fehler: Unbekanntes Element `embed`. Eine Liste der erlaubten Elemente finden Sie hier.
Fehlerstelle:

allowfullscreen" value="true"></param><embed src="http://www.dailymotion.com
Das MyBB enthält keine Flash-Objekte. Daher musst du die Fehler eingefügt haben.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#29
in welchem template finde ich das, damit ich das wieder ändern kann??
Zitieren
#30
Das weiß ich nicht, da es ja nicht vom MyBB kommt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Logo zentriert bzw. Header mit Bild zentriert Maggan22 3 132 28.10.2016, 20:48
Letzter Beitrag: MrBrechreiz
  Bild mit Link casi99 4 458 16.10.2015, 09:11
Letzter Beitrag: casi99
  Bild im Header einfügen? CasptainTee 9 607 22.05.2014, 15:41
Letzter Beitrag: MrBrechreiz
  Bild auf Startseite einfügen Forumbeginner 1 1.191 11.06.2011, 07:09
Letzter Beitrag: Loone
Question Zweiten (Eigenen css Code für a:link in global.css) ? corun 5 1.433 22.02.2009, 13:29
Letzter Beitrag: linwinman