Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
SEO / Übersicht extern auf HTML
#11
Entferne den Code der Übersicht aus dem Template "index".
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#12
Ok danke dann werd ich es so machen, das eine Problem sollte dann gelöst sein. Smile

Zum zweiten Problem: Ich hab bei 1und1 angerufen und die meinten das mod_rewrite ist definitiv installiert. In meiner htaccess Datei hab ich es auch auf on gestellt.
Sobald ich das SEO-Modul anschalte werden die Thread-Links im Forum zu den gewünschten html-Dateien, aber sie werden nicht gefunden! 404! Woran liegt das?? Muss ich noch irgendwas zusätzlich einstellen?
Zitieren
#13
Lösche aus dem Template index deines Themes die Variable {$overview}.
MyBBoard.de jetzt auf YouTube!
Fehlender Plan wird durch Wahnsinn ersetzt!!Toungue
Gruß Krafdi www.krafdi.de
Zitieren
#14
Das mit der Suchmaschinenoptimierung hab ich jetzt endlich hingekriegt! Die htaccess Datei wurde nicht bearbeitet und ich habe folgenden Code miteingefügt:
PHP-Code:
# //seo_mod_start
RewriteEngine On
# Uncomment the following and add your forum path if rewrites arent working properly
RewriteBase /
RewriteRule ^index.htmlindex.php [L,NE]
RewriteRule ^(.*)-t-([0-9]+).html(.*)$ showthread.php?tid=$2$[QSA,L]
RewriteRule ^(.*)-t-([0-9]+)-([0-9]+).htmlshowthread.php?tid=$2&page=$[QSA,L]
RewriteRule ^(.*)-f-([0-9]+)-([0-9]+).html(.*)$ forumdisplay.php?fid=$2&page=$[QSA,L]
RewriteRule ^(.*)-f-([0-9]+).html(.*)$ forumdisplay.php?fid=$2$[QSA,L]
RewriteRule ^(.*)-f-([0-9]+)-([a-z]+)(-|-[a-z]+)-([0-9]+)-([0-9]+).html(.*)$ forumdisplay.php?fid=$2&sortby=$3&order=$4&datecut=$5&page=$6$[L]
RewriteRule ^(.*)-a-([0-9]+).htmlannouncements.php?aid=$[L]
# //seo_mod_end 

Zitat:Lösche aus dem Template index deines Themes die Variable {$overview}
Hat auch geklappt.

Dank an Michael, Dragon, krafdi!
Zitieren
#15
Hab das auch gerade probiert und ha<<be genau das selbe Probleme: klick.
Hab eure Tipps befolgt. {$overview} gelöscht, in der .htaccess is alles drin, die robots.txt stimmt auch.
Aber es funktioniert trotzdem nicht =(
Wisst Ihr eine Lösung?

Ich bin beim gleichen Paket von 1&1 für 6,99 €.

Meine .htaccess:

Code:
RewriteEngine on

RewriteCond %{HTTP_HOST} !^www\.mountainboard-world\.de$
RewriteRule ^(.*)$ http://www.mountainboard-world.de/$1 [L,R=301]

# //seo_mod_start
RewriteEngine On
# Uncomment the following and add your forum path if rewrites arent working properly
#RewriteBase /mybb/
RewriteRule ^index.html$ index.php [L,NE]
RewriteRule ^(.*)-t-([0-9]+).html(.*)$ showthread.php?tid=$2$3 [QSA,L]
RewriteRule ^(.*)-t-([0-9]+)-([0-9]+).html$ showthread.php?tid=$2&page=$3 [QSA,L]
RewriteRule ^(.*)-f-([0-9]+).html(.*)$ forumdisplay.php?fid=$2$3 [QSA,L]
RewriteRule ^(.*)-f-([0-9]+)-([0-9]+).html(.*)$ forumdisplay.php?fid=$2&page=$3 [QSA,L]
RewriteRule ^(.*)-f-([0-9]+)-([a-z]+)(-|-[a-z]+)-([0-9]+)-([0-9]+).html(.*)$ forumdisplay.php?fid=$2&sortby=$3&order=$4&datecut=$5&page=$6$7 [L]
RewriteRule ^(.*)-a-([0-9]+).html$ announcements.php?aid=$2 [L]
# //seo_mod_end

robots.txt:

Code:
# robots.txt für mountainboard-world.de
User-agent: *
#Disallow: forum/showthread.php*$
Disallow: forum/member.php*$
Disallow: forum/search.php*$
Disallow: forum/memberlist.php*$
Disallow: forum/calendar.php*$
Disallow: forum/newreply.php*$
Disallow: forum/private.php*$
Disallow: forum/newthread.php
Disallow: forum/online.php
Disallow: forum/archive

User-agent: *
#Disallow: forum/showthread.php
Disallow: forum/member.php
Disallow: forum/search.php
Disallow: forum/memberlist.php
Disallow: forum/calendar.php
Disallow: forum/newreply.php
Disallow: forum/private.php
Disallow: forum/newthread.php
Disallow: forum/online.php
Disallow: forum/archive
Disallow: /nicolasschabram alt
Disallow: /Gästebuch
Zitieren
#16
Hat da keiner eine Lösung? Das wäre echt wichtig. Ich bin gerade mit dem Forum umgezogen und es wäre schon gut, wenn der GoogleBot gleich bei der ersten Indexierung statische HTML-Sites hat.
Danke, Nico
Zitieren
#17
Unkommentiere die Zeile RewriteBase und gib den richtigen Pfad an.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#18
Hm, was heißt unkommentieren? Einfach /mybb/ ändern in /forum/?
Dann funktioniert es leider immer noch nicht =(
http://www.mountainboard-world.de/forum/...-f-25.html

Edit: Hab das Plugin erstmal wieder ausgestellt. Das Ergebnis des Links ist aber das gleiche, auch wenn es eingeschaltet ist (404)
Zitieren
#19
Die Zeile ist im Moment auskommentiert, du musst die Raute (#) am Anfang der Zeile entfernen. Außerdem werden in der URL zwei Slashes angezeigt. Das könnte auch eine Ursache sein.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#20
Jiiiiiihaaaaa! Du bist der Größte! Es funktioniert wirklich! Danke Danke Danke!
Beispiel Perfekt!
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  News extern + HTML anzeigen lassen Waluigi 9 1.461 27.10.2009, 19:31
Letzter Beitrag: Blackout
  HTML in der Übersicht Don Carlos 3 589 20.02.2008, 17:06
Letzter Beitrag: Michael
  Übersicht in html datei anzeigen dywoo 1 685 12.08.2006, 13:09
Letzter Beitrag: Michael