Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Providerwechsel -- was ist zu beachten?
#1
@all

ich möchte evtl. meinen Provider wechseln, bei dem ich meine Homepage hochgeladen habe.

Dazu möchte ich einfach meine Homepage von meinem lokalen PC auf den Webserver des neuen Providers hochladen, einschließlich dem Forum.

Läuft das Forum anschließend (Übertrag durch einfaches kopieren) problemlos weiter?
Oder muss das Forum neu installiert werden?
Wie ist das mit der verbundenen MySQL-Datenbank? Sind eventuell Einstellungen zu ändern und wenn ja, wie?

Schon mal vielen Dank im voraus für die Antworten.

Peter
Ein Tag ohne Lachen ist ein verlorener Tag Big Grin

http://www.motouren.de
#2
Das Forum muss nicht neu installiert werden.

Schritte:
1. Alle Dateien des Forums auf den Webspace kopieren.
2. Datenbank importieren
3. Datei config.php (Ordner "inc") öffnen und die Daten für die Datenbankverbindung ändern
4. Ordner upload, sowie upload/avatars und die Dateien config.php und settings.php (Ordner "inc") müssen Schreibrechte besitzen (CHMOD 777)
5. Anmelden im Admin-CP und in den Einstellungen die Board-URL und Cookie-Einstellungen ändern

Fertig! Wink

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Zitat:2. Datenbank importieren

wie geht das ?
Auch Zahnschmerzen tun weh ... ( jetzt nicht mehr)
#4
https://www.mybb.de/content/category/5/91/156/

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
habe oben beschriebenes Verfahren mal auf ein neu angelegtes Testforum angewendet.

alles schön gelaufen,
das Forum erscheint wie erwartet, sogar im Standardforenstyle, werde sogar automatisch eingeloggt,
aber wenn ich das admin-cp aufrufe (in der Browseradresszeile "neues_forum/admin/index.php"),
komme ich auf so eine skurrile Seite: (beachte auch das verünglückte Frame links unten)
einloggen ist aber nicht möglich, gibt immer nur noch mehr so kleine login-Abfrage-Fenster.
Auch Zahnschmerzen tun weh ... ( jetzt nicht mehr)
#6
Auch da kann ich dir helfen. Wink

https://www.mybb.de/content/view/190/156/

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#7
Super, wie konnte ich das vergessen, den Cache löschen - Danke Dir!
jetzt nur noch eines:
ich habe in den Beiträgen viele Links auf andere Threads im Forum gesetzt.
( also absolute Sprungadressen ) kann ich die nicht - vieleicht mit PHPMyAdmin - mit einem Suchen/Ersetzen-Befehl aktualisieren ?
Wäre sonst sehr sehr viel Arbeit, das manuell zu machen.
Bin schon auf Deine Antwort gespannt.
Auch Zahnschmerzen tun weh ... ( jetzt nicht mehr)
#8
Mach ein Backup deiner Datenbank für den Notfall.

Lade dann das angefügte Skript herunter und öffne es mit einem Editor. Gib deine alte und deine neue URL an und speichere die Datei. Lade das Skript in deinen Forenordner und rufe es über den Browser auf.

Danach sollte die alte URL gegen die neue in allen Beiträgen ausgetauscht worden sein.


Angehängte Dateien
.php   fix-urls.php (Größe: 432 Bytes / Downloads: 58)

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#9
Dein Skript funzt perfekt!
Ist sehr beruhigend, ein Forum nach Totalabsturz oder nach Providerumzug wieder aufsetzen zu können.
Vielen Dank!Smile
sindbad123
Auch Zahnschmerzen tun weh ... ( jetzt nicht mehr)
#10
@all

momentan habe ich meine Homepage noch bei united-domains. Durch häufigen Serverausfall habe ich nun doch den Provider gewechselt.

Nun wollte ich gerne ein Backup meiner MySQL-Datenbank erstellen. Dazu habe ich ein Script2 gemäß den Anweisungen erstellt: http://faq.1und1.de/hosting/scripte_date...ctionauto1

Ich habe den Ordner 'DB_backup' in meinem Hauptverzeichnis auf dem FTP-Server erstellt.

Über den Browser habe ich das Skript gestartet. Es kommt immer die Meldung 'DONE .... ', DONE ...'.

Problem, wenn ich nun in den DB_backup-Ordner wechsle, ist der Ordner leer. Ich kann keine Datenbanksicherung finden. Sad

Peter
Ein Tag ohne Lachen ist ein verlorener Tag Big Grin

http://www.motouren.de