Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Providerwechsel -- was ist zu beachten?
#21
Du hast doch sicherlich Zugriff auf phpMyAdmin. Dort exportierst du die Daten aus der alten Datenbank und importierst sie in die neue.

Weitere Infos:
https://www.mybb.de/content/view/168/156/
https://www.mybb.de/content/view/173/156/

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#22
Soweit ist es klar, Danke!!!

Leider tritt noch ein fehler beim importieren auf:
CREATE TABLE `forumadminlog` (
`uid` int( 10 ) unsigned NOT NULL default '0',
`dateline` bigint( 30 ) NOT NULL default '0',
`scriptname` varchar( 50 ) NOT NULL default '',
`action` varchar( 50 ) NOT NULL default '',
`querystring` varchar( 150 ) NOT NULL default '',
`ipaddress` varchar( 50 ) NOT NULL default ''
) ENGINE = MYISAM DEFAULT CHARSET = latin1

Was könnte das sein?
bzw. was hab ich falsch gemacht?
#23
Entferne alle Angaben zum Charset in deinem Dump:
Code:
CREATE TABLE `forumadminlog` (
`uid` int( 10 ) unsigned NOT NULL default '0',
`dateline` bigint( 30 ) NOT NULL default '0',
`scriptname` varchar( 50 ) NOT NULL default '',
`action` varchar( 50 ) NOT NULL default '',
`querystring` varchar( 150 ) NOT NULL default '',
`ipaddress` varchar( 50 ) NOT NULL default ''
) ENGINE = MYISAM;

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#24
Allso wenn ich das richtig verstanden habe, dann soll ich alles was als fehler angzeigt wir entfernen?

Oder ist mit charset nur etwas bestimmtes gemeint?

Hab keine Ahnung in dem BereichSad
#25
MySQL meldet: Dokumentation
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '- phpMyAdmin SQL Dump
-- version 2.6.4-pl3
-- http://www.php

kann das da oben ein grund sein?

die beiden MYphp Admin sind andere versionen??!?
#26
In der letzten Zeile des Queries steht: "DEFAULT CHARSET = latin1". Diesen Teil sollst du entfernen und zwar überall wo er im Dump vorkommt. Bist du dir nicht sicher was du machen sollst, schicke deinen Dump an support[at]mybboard[punkt]de.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#27
Ich hab die Dump abgeschickt.

Da nach entferne immer noch in diesem Bereich ein Fehler angezeigt wurde!
SQL-Befehl:

-- phpMyAdmin SQL Dump -- version 2.6.4-pl3 -- http://www.phpmyadmin.net -- -- Host: *********.com -- Erstellungszeit: 13. Mai 2006 um 02:07 -- Server Version: 4.1.18 -- PHP-Version: 4.4.1 -- -- Datenbank: `*********` -- -- -------------------------------------------------------- -- -- Tabellenstruktur für Tabelle `forumadminlog` -- CREATE TABLE `forumadminlog` ( `uid` int(10) unsigned NOT NULL default '0', `dateline` bigint(30) NOT NULL default '0', `scriptname` varchar(50) NOT NULL default '', `action` varchar(50) NOT NULL default '', `querystring` varchar(150) NOT NULL default '', `ipaddress` varchar(50) NOT NULL default '' ) ENGINE=MyISAM
#28
Import hat geklappt!

hab einfach mit der Zwischenablage gearbeitet und den Charset entfernt!

Leider komm ich von einem Problem in das andereSmile

Wenn ich nun die Admin seite aufrufe erscheint folgende meldung:

mySQL error: 2003
Can't connect to MySQL server on '***********' (60)
Query:

und unter *** steht der alte Server!

ich hab in config.php die Daten geändert, aba es klappt nicht!
Mach bestimmt wieder was falschSad

Danke für eure Hilfe!
#29
Hallo Tweaker,

Gehe bitte noch einmal deine Eintragungen in der config.php durch.
PHP-Code:
$config['hostname'] = "localhost"// sollte localhost sein 
$config['username'] = "webx"// login name mit dem du dich im phpMyAdmin einloggst
$config['password'] = "deinpw"// dein Passwort, welches du auch im phpMyAdmin nutzt
$config['database'] = "usr_webx_x"// Datenbankname, auf der die Daten deines Forum liegen 

Sind deine Einstellungen da korrekt?


Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
#30
ja die einstellungen stimmen alle, leider versucht er doch auf den alten Server zuzugreifen!

Muss ich vielleicht im auf dem Alten Server erst URL ändern und dann die Daten kopieren?