Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehlermeldung beim versenden von privaten Nachrichten
#1
Question 
Halla, mal wieder Toungue

wenn ich auf meinem Board eine PN versenden will kann kommt folgende Fehlermeldung:

Zitat:Warning: mail() has been disabled for security reasons in /srv/www/httpd/phost/m/net/pytalhost/mastermind666/web/inc/functions.php on line 370

Warning: Cannot modify header information - headers already sent by (output started at /srv/www/httpd/phost/m/net/pytalhost/mastermind666/web/inc/functions.php:370) in /srv/www/httpd/phost/m/net/pytalhost/mastermind666/web/inc/functions.php on line 559

und wenn ich auf aktualisieren drücke dann kommt das Board wieder und bringt folgende Meldung:

Zitat:Du hast in den letzten 5 Minuten die gleiche Nachricht an den gleichen Empfänger geschickt.

Die Nachricht wurde gesendet und ist im Ausgangsordner.
Der Empfänger kann auch Antworten. Somit ist sie auch tatsächlich angekommen.

Aber was bedeutet diese Fehlermeldung :question:
Und wie bekomme ich diese wieder weg :question:

MySQLi 5.0.30
PHP Version: 5.2.0
mybb: 1.2.2

Danke
#2
Die Funktion mail() wurde von deinem Host deaktiviert. Da der Empfänger wohl E-Mail-Benachrichtigung eingeschaltet, kommt die Meldung. Die PN kommt trotzdem an. (ohne Benachrichtigung)
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
Könnte das eine Einstellung im phpmyAdmin sein oder kommt das vom Webhoster direkt?

Quasi könnte man das System PN nutzen müsste aber ne Fehlermeldung akzeptieren. *grübel*

Edit:

Interessanterweise kommt eine ähnliche Fehlermeldung wenn ich mich beim ins AdminCP einloggen beim Passwort vertippe.
Code:
Warning: mail() has been disabled for security reasons in /srv/www/httpd/phost/m/net/pytalhost/mastermind666/web/inc/functions.php on line 370
Dat ja komisch da wird doch keine PN oder Mail gesand :question:
#4
Das kommt vom Hoster direkt. (freehoster?) Da kannst du ihn nur anschrieben.
Du müsstest bei allen Benutzern die E-Mail-Benachrichtigung abschalten.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
hm, die Option "E-Mail-Benachrichtigung bei neuen Antworten." und "E-Mail-Benachrichtigung bei neuer privater Nachricht" sind beide ausgeschalten (kein Häckchen drin)
#6
Bei dem, der die PN erhalten soll? Der bekommt sie ja. Also muss bei ihm der Hacken drin sein.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#7
Da hätten wir ja schon das nächste Problem,
wenn ich im Benutzer CP nachschaue dann sind alle Haken raus.
Wenn ich mir im Admin CP die Benutzer anzeigen lassen dann ist immer die Option "E-Mailbenachrichtigung bei neuer PN" Aktiviert.
Und wenn ich auf "nein" stelle und dann wieder den Benutzer anzeige steht es wieder auf "ja" selbst wenn der Haken im Benutzer CP nicht gesetzt ist.So zeigt es im Admin CP immer auf "ja" an.


PS: es ist ein Freehoster Shy *schäm* Wink

Edit: *patsch* ach jetzt hab ich es geschnallt, wenn man die PN versenden will, dann den HAken vorm Versenden rausnehmen das man eine Bestätigungsmail haben will.

Der Haken ist ja Standardmäßig immer gesetzt, kann man diese Hakcen als Standard auch rausnehmen?
#8
Kann es sein, dass die Seite aus dem Cache deines Browsers geladen wird? Bitte lösche den Cache und gucke nochmal nach.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#9
Cache leeren führte dazu das ich mich hier neu einlogen muss. Wink Toungue

Im Ernst:

Habe ich gerade getestet, der Boppel im Admin CP steht immer auf JA
Eigenartiger weise wenn der User im User CP nachschaut ist da kein Haken drin.

Es scheint somit die Einstellung vom Admin CP zu übernehmen. Zeigt es aber nicht an.
#10
Ich habe inzwischen zu meinem Problem von oben rausgefunden das beim Versenden einer PN diese 4 Auswahlhaken "Checkbox" hei?n.

Und ich glaube Sie gefunden zu haben, und zwar in dem Template:
Default Templates -> Private Nachrichten Templates -> private_send

So schaut das ganze Ding aus:

PHP-Code:
<html>
<
head>
<
title>{$lang->compose_pm}</title>
{
$headerinclude}
</
head>
<
body>
{
$header}
<
form action="private.php" method="post" name="input">
<
table width="100%" border="0" align="center">
<
tr>
{
$usercpnav}
<
td valign="top">
{
$preview}
{
$send_errors}
<
table border="0" cellspacing="{$theme['borderwidth']}cellpadding="{$theme['tablespace']}class="tborder">
<
tr>
<
td class="thead" colspan="2"><strong>{$lang->compose_pm}</strong></td>
</
tr>
<
tr>
<
td class="trow1" valign="top"><strong>{$lang->compose_to}</strong></td>
<
td class="trow1"><input type="text" class="textbox" name="to" id="to" size="40" maxlength="{$mybb->settings['maxnamelength']}value="{$to}tabindex="1" /></td>
</
tr>
<
tr>
<
td class="trow2"><strong>{$lang->compose_subject}</strong></td>
<
td class="trow2"><input type="text" class="textbox" name="subject" size="40" maxlength="85" value="{$subject}tabindex="2" /></td>
</
tr>
{
$posticons}
<
tr>
<
td class="trow2" valign="top"><strong>{$lang->compose_message}</strong><br/><br/><div style="margin:auto">{$smilieinserter}</div></td>
<
td class="trow2">
<
textarea name="message" id="message" rows="20" cols="60" tabindex="3">{$message}</textarea>
{
$codebuttons}
</
tr>
<
tr>
<
td class="trow1" valign="top"><strong>{$lang->compose_options}</strong></td>
<
td class="trow1"><span class="smalltext">
<
label><input type="checkbox" class="checkbox" name="options[signature]" value="yes" tabindex="8" {$optionschecked['signature']} />{$lang->options_sig}</label><br />
<
label><input type="checkbox" class="checkbox" name="options[disablesmilies]" value="yes" tabindex="9" {$optionschecked['disablesmilies']} />{$lang->options_disable_smilies}</label><br />
<
label><input type="checkbox" class="checkbox" name="options[savecopy]" value="yes" tabindex="10" {$optionschecked['savecopy']} />{$lang->options_save_copy}</label><br />
<
label><input type="checkbox" class="checkbox" name="options[readreceipt]" value="no" tabindex="11" {$optionschecked['readreceipt']} />{$lang->options_read_receipt}</label><br />
</
span></td>
</
tr>
</
table>
<
br />
<
input type="hidden" name="action" value="do_send" />
<
input type="hidden" name="pmid" value="{$pmid}/>
<
input type="hidden" name="do" value="{$do}/>
<
div style="text-align:center"><input type="submit" class="button" name="submit" value="{$lang->send_message}tabindex="4" accesskey="s" />??<input type="submit" class="button" name="saveasdraft" value="{$lang->save_draft}tabindex="5" />??<input type="submit" class="button" name="preview" value="{$lang->preview}tabindex="6" /></div>
</
td>
</
tr>
</
table>
</
form>
{
$footer}
{
$autocompletejs}
</
body>
</
html

Dann habe ich einfach in diesem Teil:

PHP-Code:
<label><input type="checkbox" class="checkbox" name="options[readreceipt]" value="no" tabindex="11" {$optionschecked['readreceipt']} />{$lang->options_read_receipt}</label><br /> 

den value-Eintrag von "yes" auf "no" ge?ert

Das scheints es aber nicht gewesen zu sein denn der Hacken wird immer noch als Standard gesetzt. Spielt daf?h eine weitere Einstellung eine Rolle?

Edit:
PS: den Cache habe ich auch mal wieder geleert Wink


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  maximale Anzahl der "privaten Nachrichten" Raven 4 899 15.04.2008, 21:00
Letzter Beitrag: NixxusMinimax
  MItgliederliste von privaten Usergruppen ausgeben Kaba 1 547 27.06.2007, 22:36
Letzter Beitrag: Michael
  Fehlermeldung beim versenden von PMs WalkingSun 7 1.007 21.04.2007, 16:39
Letzter Beitrag: WalkingSun
  Fehlermeldung beim Versenden einer PN Blautiger333 1 519 06.01.2007, 17:31
Letzter Beitrag: Michael
  Private Nachrichten und gesendete Nachrichten Basteltrulla 5 810 13.12.2006, 19:36
Letzter Beitrag: Basteltrulla