Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht (30.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
upgrade von 1.8.21 auf 1.8.21: nur von 1.8.20 im Dropdownmenü möglich
#1
Hallo,
beim Upgrade von 1.8.21 auf 1.8.29 wird nach  .../install/upgrade.php   und Anmeldung meine aktuelle Version angegeben: 1.8.21.  Das Dropdown-Menü zum Anklicken der aktuellen Version bietet nur 1.8.20 und ältere Versionen an.
Was ist zu tun?

Vielen Dank!
Humba
Zitieren
#2
Hast du das aktuelle Update-Paket heruntergeladen?

Alle neuen Dateien müssen zuerst auf den Webspace kopiert werden (alte überschrieben oder temporär umbenannt).
Erst danach kennt das Forum überhaupt die neue Version und kann auch den Upgrade-Prozess durchführen.

Vorher ein frisches Datenbank-Backup im ACP erstellen!

[ETS]
MyBB-Forum + innovatives Theme
Live Escape Game Forum
Erste Deutsche und Internationale Community und Diskussionsplattform für Live Escape und Adventure Games.
Unlösbares Problem? -> das Nötel
Zitieren
#3
ja, ich habe das aktuelle Update-Paket 1.8.29 (deutsch) heruntergeladen, entpackt und alle Dateien und Ordner aus "Upload" auf unseren Server ...../forum/install hochgeladen (mit 'Überrschreiben').
..... /install/upgrade.php gibt keine anzuklickende aktuelle Version 1.8.21, sondern nur 1.8.20 und älter zur Auswahl an.
Zitieren
#4
Welches Paket hast du genutzt? Auf unserer Download-Seite gibt es nicht nur ein Paket. Und in Update-Paketen gibt es keinen Ordner "Upload".

Wenn beim Upgrade Versionen fehlen, sind eindeutig nicht alle neuen Dateien vorhanden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Der Ordner "Upload" im Archiv deutet darauf hin, dass du ein vollständiges Installationspaket heruntergeladen hast. Das macht aber nichts - damit würdest du nur unnötig Dateien ersetzen, die durch das Upgrade nicht verändert wurden. Keine Sorge, soweit alles okay!

Doch müssen die korrekten Ordnerstrukturen genauso vorhanden bleiben.
Bitte prüfe die Verzeichnisse und die Inhalte. Im Zweifelsfall (sofern jetzt Dateien an einem völlig falschen Platz liegen) kannst du das Forum kurzerhand in den Offline-Modus setzen und alle Ordner/Dateien auf dem Webspace sauber aus dem Download erneut hochladen.
Dann /install aufrufen und den Upgrade-Prozess durchlaufen.

[ExiTuS]
MyBB-Forum + innovatives Theme
Live Escape Game Forum
Erste Deutsche und Internationale Community und Diskussionsplattform für Live Escape und Adventure Games.
Unlösbares Problem? -> das Nötel
Zitieren
#6
Danke vielmals.
ich habe offensichtlich das gesamte Paket 1.8.29 ins Forum hochgeladen (und geänderte Dateien überschrieben). Mit Update wurde das nicht überschriebene 1.8.21er Update aufgerufen, was natürlich max. von 1.8.20 updaten kann.
Jetzt am besten das echte Upgrade von 1.8.21 zu 1.8.29 drüber schreiben (enthält dann sicherlich das funktionierende Upgrade von 1.8.21? /install macht doch Neuinstallation 1.8.29 - oder?
Notfalls kann ich die Forum-Struktur und Datei von einer Testinstallation ins (geleerte) Forum kopieren und dann das richtige Update (1.8.21 zu 1.8.29) drüber speichern und Update starten.
Zitieren
#7
Humba schrieb:[...] /install macht doch Neuinstallation 1.8.29 - oder?
Prinzipiell ist das Hochladen von aktualisierten Dateien schon ein Großteil des eigentlichen Upgrades.
/install führt den abschließenden Upgrade-Prozess durch und macht alle nötigen Aktualisierungen in der Datenbank.

[ETS]
MyBB-Forum + innovatives Theme
Live Escape Game Forum
Erste Deutsche und Internationale Community und Diskussionsplattform für Live Escape und Adventure Games.
Unlösbares Problem? -> das Nötel
Zitieren
#8
die Doku hilft dir zum gesamten Upgradeprozess eigentlich sehr gut weiter

speziell zum letzten Schritt: https://www.mybb.de/doku/installationakt...g/#upgrade
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#9
Großen Dank, ExiTuS. ließ sich
Nachdem ich nochmal 1.8.29 vom Upload-Verzeichnis hochgeladen hatte, klappte /install einwandfrei: fragte nach der Version, von der aus geupdatet werden soll -> 1.8.21 konnte ich einstellen und auf 1.8.29 aktualisieren.
Ganz prima.
Wegen des irreführenden Tippfehlers Titels (Upgrade von 1.8.21 auf 1.8.21 - anstatt 1.8.29) kann vor mir aus alles gelöscht werden.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Upgrade von 1.8.15 auf 1.8.22 nicht möglich dl-ham 3 721 01.01.2020, 19:10
Letzter Beitrag: dl-ham
  Upgrade von 1.6 auf 1.8 - nur Datenübernahme Dominic82 6 1.182 11.03.2015, 09:25
Letzter Beitrag: UnkreativerUser
  Nach upgrade auf 1.8.2 kein Zugriff auf CSS und Styles möglich Mickilina33 5 1.505 17.11.2014, 18:28
Letzter Beitrag: Mickilina33