Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[geteilt] Registrierung nicht möglich
#11
Wenn die Login-Methode auf Email-Adresse steht, ist es nicht möglich, eine Email-Adresse mehrfach zu verwenden. Wink
Zitieren
#12
Ah okay.

Eine Fehlermeldung wäre wirklich eine Verbesserung :-)
Zitieren
#13
(05.03.2021, 15:30)falcao1010 schrieb: Ich habe das Problem gefunden: Die Mail-Adresse wird bereits benutzt und mehrfache Registrierungen mit der gleichen E-Mail-Adresse sind ausgeschlossen.
Ich habe das ausprobiert. Es erscheint standardmäßig eine eindeutige Fehlermeldung.

Da das ursprüngliche Problem bereits gefunden wurde, trenne ich diese Diskussion vom ursprünglichen Thema.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#14
"erscheint standardmäßig eine eindeutige Fehlermeldung" Wäre nett auch mitzuteilen was die beinhaltet.

Um 17:48 Uhr LIVE getestet mit Forum V 1.8.25 wobei doppelte E_Mails untersagt sind:

1. Neuuser
* Registrierung
> Zustimmungserklärung
>> Name / Passwort
>> bei E-Mailadresse eine Neue eingegeben

* Link erhalten
> Login und Logout ohne Probleme


2. Neuuser
* Registrierung
> Zustimmungserklärung
>> Name / Passwort
>> bei E-Mailadresse eine bereits vorhandene eingegeben

> Zustimmungserklärung
und alles von vorne!

3. Neuuser
* Registrierung
> Zustimmungserklärung
>> Name / Passwort
>> bei E-Mailadresse eine Neue eingegeben

* Link erhalten
> Login und Logout ohne Probleme


4. Neuuser
* Registrierung
> Zustimmungserklärung
>> Name / Passwort
>> bei E-Mailadresse eine bereits vorhandene eingegeben

> Zustimmungserklärung
und alles von vorne!

Denke das dürfte als Test ausreichen. Wo kann da der Fehler liegen?
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#15
@Gerti

Ich habe Deinen Test in mehreren Foren nachgestellt, sowohl nackt auf dem XAMPP, als auch in diversen angepassten Live-Foren .
Meldung:
"Die eingegebene E-Mail-Adresse wird bereits von einem anderen Benutzer verwendet. Bitte gib eine andere E-Mail-Adresse ein."
Zitieren
#16
Könnte es sein, dass ihr das Plugin "Einverständnis Nutzungsbedingungen" verwendet?
Falls ja, ändert mal Zeile 1702 von:
PHP-Code:
if ($mybb->request_method == "post") { 

zu:
PHP-Code:
if ($mybb->request_method == "post" && !isset($mybb->input['regsubmit'])) { 

und testet, ob die Weiterleitung immer noch besteht.
Zitieren
#17
(05.03.2021, 19:59)doylecc schrieb: Könnte es sein, dass ihr das Plugin "Einverständnis Nutzungsbedingungen" verwendet?

Hi doylecc,

ich habe es auch mit diesem Plugin getestet. Es hat keinen Einfluss.
Die Meldung wird auch mit diesem Plugin korrekt ausgegeben. Wink
Zitieren
#18
Bei einem "neu" eingerichteten Forum V1.8.25 erhalte ich bereits bei Eingabe der E-Mailadresse die Meldung
<Zitat>
Die eingegebene E-Mail-Adresse wird bereits von einem anderen Benutzer verwendet. Bitte gib eine andere E-Mail-Adresse ein.
</Zitat>
Da ist also alles korrekt.

@doylecc
Im obigen "Test"-Forum wird die Nutzungsvereinbarung unverändert verwendet. Somit dürfte da die Ursache nciht zu suchen sein.

Irgendetwas muss das Fehlverhatlen verursachen. Werde mal am WE noch einige andere Foren testen.

Fragen:
* wie kann man dem Fehlverhalten auf die Schilche kommen?
* wo genau müsste eigentlich der Verweis stehen wenn bei Angabe einer bereits vergebenen E-Mailadresse anstelle obiger korrekter Meldung auf die Standard-Nutzungsvereinbarung verwiesen wird?
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#19
(06.03.2021, 09:51)Gerti schrieb: * wie kann man dem Fehlverhalten auf die Schilche kommen?

Die Validierung der Formulareingaben wird über Javascript realisiert.
PHP-Code:
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/validate/jquery.validate.min.js?ver=1821"></script

In Deinem Testforum geschiet dies z.B. nicht.
Prüfe mal das Template member_register auf Veränderungen.
Zitieren
#20
(06.03.2021, 11:09)Schnapsnase schrieb: Die Validierung der Formulareingaben wird über Javascript realisiert.
Die Validierung funktioniert auch ohne Javascript, aber logischerweise erst nach dem Abschicken.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Registrierung nicht möglich lachner 2 831 04.03.2021, 23:00
Letzter Beitrag: lachner
  Registrierung nicht möglich / Username wird nicht akzeptiert Santhony 4 526 20.03.2020, 08:32
Letzter Beitrag: Santhony
  Registrierung nicht möglich _Klaro 6 1.135 04.03.2018, 14:13
Letzter Beitrag: Jockl
  [geteilt] Neue Registrierung per Mail an Admin Licht 0 590 09.07.2015, 17:41
Letzter Beitrag: Licht