Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Cannot declare class XMLParser, because the name is already in use in
#1
Hallo mybb Gemeinde,

ich wollte gerade ein neues Forum auf einem Heimserver installieren.
Leider gibt er mir folgende Fehlermeldung auf meinem Browser aus:

Fatal error: Cannot declare class XMLParser, because the name is already in use in [...] on line 17

Hat jmd vllt eine Idee was das sein könnte, bzw. wie ich das beheben kann?

LG
Zitieren
#2
Welche PHP-Version nutzt du - etwas PHP8-dev?
Dann liegt das Problem scheinbar daran, dass die Klasse "XMLParser" sowohl von MyBB als auch von PHP definiert und genutzt wird. Die beißen sich gegenseitig.
Ich habe die Lösung aus dem Stehgreif nicht parat, aber da das Problem bereits bekannt ist, also reicht dieser Hinweis als Anhaltspunkt Wink

Falls es nicht an PHP8 liegen sollte, dann gebe uns bitte ein paar mehr Informationen zu deiner Konfiguration.

[ExiTuS]
Neues Forum: MyBB 1.8.26 + innovatives Theme
Live Escape Game Forum
Erste Deutsche und Internationale Community und Diskussionsplattform für Live Escape und Adventure Games.
Zitieren
#3
Vielen Dank für deine Antwort.

Ich nutze die aktuelle Version von XAMPP, dort ist PHP8.0.0 integriert.
XAMPP ist bei mir auf Standardkonfiguration.

Wenn das ein bekanntes Problem ist dann schau ich mal ob ich dazu was finde. Bisher war ich bei der Suche leider erfolglos. Deshalb dieser Post hier Wink
Zitieren
#4
PHP 8 ist noch zu neu, das macht noch ganz andere Probleme.

Such dir was auf der PHP 7.x Schiene.
Zitieren
#5
Du kannst deine jetzige XAMPP-Konfiguration ganz einfach auf PHP7 umstellen.

- Lade dir das Paket PHP7 herunter und entpacke es (der Sauberkait halber besser in einen separaten Ordner dort, wo auch deine jetzige Installation liegt).
- In der httpd.conf des Apache-Webserver änderst du das "LoadModule" von php8 zu php7 mit entsprechend neuem Pfad und php8 auskommentieren.
- Nur falls nötig, die php.ini bearbeiten und entsprechende Änderungen übernehmen.
- Apache neustarten und fertig!

[ExiTuS]
Neues Forum: MyBB 1.8.26 + innovatives Theme
Live Escape Game Forum
Erste Deutsche und Internationale Community und Diskussionsplattform für Live Escape und Adventure Games.
Zitieren
#6
Vielen dank für eure Hilfe.
Dann Lösch ich das aktuelle XAMPP und installiere eine ältere Version mit PHP7.
Das ist dann Clean.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  MyBB has experienced an internal error and cannot continue. Zero_ace 2 1.437 17.12.2015, 15:05
Letzter Beitrag: Zero_ace
  You are not allowed to use the domain gmx.de as a sender domain. Buggyboy 12 2.893 12.08.2015, 18:46
Letzter Beitrag: Buggyboy
  class="smilie smilie_{$smilie['sid']} {$extra_class}" hkkp 0 611 16.07.2015, 23:03
Letzter Beitrag: hkkp
  Cannot modify header information Artificial Boss 2 641 29.05.2015, 14:32
Letzter Beitrag: Artificial Boss
  I'm sorry, but you can't use this board... Lila Raven 2 889 13.04.2015, 00:38
Letzter Beitrag: Lila Raven