Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.24 veröffentlicht (09.08.20)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Merge System will nicht
#11
(28.09.2020, 08:49)jojo-gfx schrieb: Sinnvoll wäre hier, in der Entwicklung mehr darauf zu achten, dass Pfade wirklich nur in einer Datei, an einer Stelle zu ändern sind und dass es einen wirkungsvollen Cache-Leerungs Prozess gibt, ohne Login als Admin, denn eben der fehlt.
Bevor du den Entwicklern Tipps gibst, solltest du dich mehr mit dem MyBB beschäftigen. Das MyBB speichert an keiner Stelle einen absoluten Pfad, auch nicht im Cache.
Was bei einem Umzug zu beachten ist, kannst du in unserer Doku nachlesen: https://www.mybb.de/doku/haeufig-gestell...-forum-um/

Login-Probleme lassen sich meist auf fehlerhafte Cookie-Einstellungen zurückführen, siehe: https://www.mybb.de/forum/thread-30268.html
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#12
(28.09.2020, 08:49)jojo-gfx schrieb: Beim Pfad ...www/html/ fehlt nun absolut gesehen ein mybb/ und anscheinend wurde dieses noch irgenwo fest verdrahtet, denn ich habe es aus allen Stellen in der settings.php und der config.php eliminiert.
Leider kann ich mich nun aber dennoch nicht mehr einloggen und auch das Capcha wird nicht mehr gefunden, sodass ich mir auch kein neues Passwort schicken lassen könnte.
Du begrenzt Dich zu sehr auf globale Aussagen, was ein Helfen fast unmöglich macht.

Die Angabe einer URL wäre hilfreich, dann könnte man Dir eher analysieren was Du wo einstellen musst.
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Hilfe(n) kann man lediglich anbieten. Wer Hilfe nicht annimmt, dem ist nicht zu helfen!
Aktive Version: MyBB: 1.8.24 | PHP: 7.4.10 | SQL: 5.7.28
Zitieren
#13
Sorry, ist nicht ganz einfach, wenn man von einem Fehler zum nächsten hetzt und wenn ich wüsste, was ich genau posten muss, dann wüste ich auch, wo der Fehlerteufel sitzt. Wink

Ich habe nun das mybb auf dem eigentlichen Server installiert und dann die daten vom alten wbb importiert.
Mit meinen bisherigen Erkenntnissen ging das nun reibungslos.

Allerdings stellt mich nun das Rechtesystem von mybb auf eine harte Probe, sodass ich hier erstmal zusehen muss, wie ich Themen sichtbar schalten kann. Die Foren habe ich hin bekommen ... bzw. bin noch dabei, aber selbst mir als Admin fliegt bei den Themen der Satz um die Ohren, dass ich keine Berechtigung hätte, die Themen eines Forums zu sehen ... da staunt Admin nicht schlecht. Wink

Eine URL will ich hier absichtlich nicht posten, da Google und damit andere User hier noch keinen Weg rein finden sollen, bevor nicht alles abgedichtet ist und ich überhaupt verstehe, was wie wo gehauen und gestochen ist bei mybb. Wink
Per PN aber gern!
Hmm, als Normaluser sieht man die Beiträge... nur als sinnloser Admin nicht... hihi!
Zitieren
#14
So, ich hab es nun ganz gut laufen und ich hoffe, es ist einigermaßen spamdicht.
wer gucken mag: amiga punkt redirectme punkt net

Für technische Tipps bin ich immer dankbar! Smile
Zitieren
#15
Hatte es erst mit "http://" versucht, was jedoch fehl schlug. Mit https://amiga.redirectme.net/ klappte es sofort. Kompliment zu Deinem Forum, sieht echt gut aus.
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Hilfe(n) kann man lediglich anbieten. Wer Hilfe nicht annimmt, dem ist nicht zu helfen!
Aktive Version: MyBB: 1.8.24 | PHP: 7.4.10 | SQL: 5.7.28
Zitieren
#16
Ja, der Port 80 ist noch zu, weil der Server noch zuhause rennt. Wink
Aber an seinem Bestimmungsort wird dann auch http auf https korrekt umgelenkt.

Danke... ist noch etwas finster, das Grün. Da muss ich noch mal das CSS anschauen und das etwas aufhellen. Smile

Rennt auch echt sauschnell, wenn man nicht bei einem knausrigen Hoster auf nem überbuchten Server hängt. Big Grin
Zitieren
#17
Was ich allerdings bemerkt habe ... anscheinend werden Cookies beim Login aggressiv verwendet und ausgewertet.
Ich kann also nicht in einem Browser einfach so den User wechseln, denn dann bekomme ich nur noch Fehlermeldungen und komme nie wieder ins Forum:

Falscher Autorisierungscode! Greifen Sie auf diese Funktion auf die übliche Weise zu? Bitte gehen Sie zurück und versuchen Sie es erneut.

Tatsächlich funktioniert es wieder nach dem Cookies löschen.
Wäre gut, wenn Cookies nach dem Login neu gesetzt werden, wenn diese unstimmig sind.
Zitieren
#18
anscheinend sind nicht alle deine Templates aktuell; prüfe das bitte

und zum Thema "falscher Autorisierungscode" findest du bestimmt reichlich Lösungen hier im Forum
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#19
(30.09.2020, 06:51)jojo-gfx schrieb: Wäre gut, wenn Cookies nach dem Login neu gesetzt werden, wenn diese unstimmig sind.
Die Cookies werden bei jedem Login neu gesetzt (sonst würde dieser nicht funktionieren). Solltest du irgendwann die Cookie-Einstellungen geändert haben, kann es aber zu Cookie-Konflikten kommen. Daher sollten die Cookies im Browser nach Änderung der Einstellungen gelöscht werden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#20
Hatte an dieser instanz nichts geändert und es ging, solange ich den gleichen user benutzt habe.
Na mal schauen, wie es sich weiterhin so verhält.

Cookie Einstellungen und Templates sind alle org..
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Merge-System zeigt Fehler an Niko 9 727 02.10.2019, 13:06
Letzter Beitrag: bv64
  wBB -> MyBB? Mit Merge System? itsmeJAY 3 859 06.02.2019, 07:25
Letzter Beitrag: itsmeJAY
  Merge System - Problem mit Datenbankkonfiguration/table prefix Cassidy 9 2.335 27.12.2018, 20:15
Letzter Beitrag: RobiRobs
  [geteilt] Merge SQL Error 1064 - Fehler beim MyBB Merge System - Version: 1.8.6 AmFiD 0 617 23.05.2018, 13:53
Letzter Beitrag: AmFiD
  Avatar per Merge System Problem BlackBurn 4 851 11.05.2018, 16:20
Letzter Beitrag: BlackBurn