Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.21 veröffentlicht (11.06.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[NG] Fehler im Editor
#11
[center]Scheint noch nicht behoben zu sein. Bei mir jedenfalls nicht nach upgrade auf die 1.8.21[/center]
Zitieren
#12
Ich kann das Problem bei MyBB 1.8.21 nicht reproduzieren.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#13
[center]Aber siehste über deinen Post.

 Heraus kam obiges und das hier.[/center]

Das sollte mittig geschrieben sein und nicht linksbündig.
Zitieren
#14
Der richtige Mycode wäre hier 
Code:
[align=center][/align]
Das wird vom Editor auch so umgesetzt.
Zitieren
#15
Das weiß ich auch

aber es wird nicht automatisch gemacht, das funktioniert ja nicht.
Zitieren
#16
Was ist bei Dir automatisch?

Ich habe es einmal unter Verwendung des Codebuttons geschrieben und einmal den Mycode per Hand eingegeben. Beides funktioniert.
Ich kann Dir nicht folgen. Huh
Zitieren
#17
Der SCeditor wurde nicht explizit für MyBB entwickelt, sondern nur angepasst, daher verarbeitet er von Haus aus auch einige Codes in seiner Vorschau, die in MyBB gar nicht vorhanden sind, wie zB.
Code:
[center]...[/center]

Wenn du diesen Code in deinem Forum nutzen möchtest, kannst du ihn als eigenen MyCode im Admin CP anlegen. Dann funktioniert er nicht nur im Editor, sondern auch in den Beiträgen.
Zitieren
#18
Liebe Foristen,

ich habe das Problem auch (oder ein ähnliches), allerdings tritt es nach meiner Beobachtung nur am Ende eines Beitrags auf: Dort wollte ich gern den Text der letzten Zeile eines Beitrags rechtsbündig haben. Im Editor sah das auch alles gut aus, aber sobald ich den Beitrag absendete, war der Text wieder linksbündig. Einen Text am Beginn des Beitrags zentriert anzeigen zu lassen (und den restlichen Beitrag linksbündig), funktioniert dagegen.

Außerdem habe ich Probleme mit Texten, die ich aus einem Textverarbeitungsprogramm in den Editor einfüge:

1. Die Schriftgröße ist winzig, 
2. Obwohl Beiträge, die ich direkt im Editor schreibe, in Arial (und in vernünftiger Schriftgröße) angezeigt werden, werden aus Textverarbeitung eingefügte Beiträge in Times New Roman dargestellt (obwohl ich in der Textverarbeitung auch Arial verwende)

Außerdem fügt der Editor vor und nach jeder Leerzeile, die der hineinkopierte Text mitbringt, jeweils eine weitere Leerzeile ein, die ich dann von Hand wieder löschen muss (da es sich um ein Forum mit sehr langen, schriftstellerischen Beiträgen handelt, ist das mehr als mühsam und nervt so richtig).

Um das Problem mit der winzigen Schrift und der Schriftart zu lösen, habe ich meine eingefügten Texte im Editor vollständig markiert und Schriftgröße und Schriftart angepasst. Dabei passiert jedoch folgendes: Nicht nur am Anfang und am Ende des gesamten Textes einmalig, sondern vor und nach jedem einzelnen Absatz (!) werden die Kommandos [/size=medium] usw. automatisch eingefügt. Das führt dazu, dass die pro Beitrag erlaubten 65.000 Zeichen ziemlich schnell aufgebraucht sind.

Weiß jemand, ob diese Probleme in der neuen Version (21) behoben sind?

Lieben Dank und freundliche Grüße
a.
Zitieren