Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Errormeldung bei Newreply und Newthread nach PHP Wechsel
#1
Servus Allemiteinand

Weil ich auf meiner Seite einen Shop einrichten wollte, musste ich die PHP Version ändern. Was die alte Version war weiß ich jetzt nicht mehr aber die jetzige PHP Version ist nach dem Upgrade PHP 5.4.


Jedenfall ist es so daß nach dem Upgrade bei der Vorschau von Newreply und Newthread folgende Error Meldung kommt.


   

Diese verschwindet aber wieder wenn ich den Beitrag veröffentliche. Ich habe mir auch die im Errortext angegebenen Zeilen in newthread und newreply angeschaut und dort steht folgendes zu lesen.

PHP-Code:
eval("\$newattach = \"".$templates->get("post_attachments_new")."\";"); 

Ich weiß auch daß meine MYBB Version 1.6.1 schon recht überaltert ist , aber die Version läuft nun mal schon recht lange und voller Zufriedenheit so daß ich vorerst ohne Upgrade auskommen würde.

Meint ihr kann ich diese Errormeldung mit einem Skriptpflaster Big Grin beheben, oder muß da ein gröberes Upgrade her.
Ach ja die Plugins habe ich schon alle ein und ausgeschaltet, ohne eine Besserung zu bekommen.

Im Admin Bereich habe ich auch eine Meldung aber die stört mich nicht so

   

Ich danke jetzt schon mal für eure Mithilfe !!!

Mfg.
Walter
#2
(21.03.2015, 10:59)Plexxart schrieb: Ich weiß auch daß meine MYBB Version 1.6.1 schon recht überaltert ist....
Dann verschiebe ich das Thema auch mal dorthin... Wink


Ich meine mich zu errinnern, dass dieses Problem (illegal string offset) mit MyBB 1.6.10 gefixt wurde. MyBB 1.6.1 ist nun wirklich schon ganz schön alt und ob das schon reibungslos mit PHP 5.4 lief, kann ich nicht sagen.

Zu dem ACP-Fehler habe ich diesen Beitrag gefunden. Hier sollte MyBB 1.6.9 Abhilfe geschafft haben... Wink
viele Grüße
Jockl
übersetzte und eigene Plugins
#3
Wie Jockl schon schrieb, ist deine Version nicht mit PHP 5.4 kompatible, schließlich ist das erst über ein Jahr später veröffentlicht worden. Zudem klaffen gravierende Sicherheitslücken in einer derart veralteten Version.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#4
(21.03.2015, 11:04)Jockl schrieb:
(21.03.2015, 10:59)Plexxart schrieb: Ich weiß auch daß meine MYBB Version 1.6.1 schon recht überaltert ist....
Dann verschiebe ich das Thema auch mal dorthin... Wink


Ich meine mich zu errinnern, dass dieses Problem (illegal string offset) mit MyBB 1.6.10 gefixt wurde. MyBB 1.6.1 ist nun wirklich schon ganz schön alt und ob das schon reibungslos mit PHP 5.4 lief, kann ich nicht sagen.

Zu dem ACP-Fehler habe ich diesen Beitrag gefunden. Hier sollte MyBB 1.6.9 Abhilfe geschafft haben... Wink

Danke Jockl für die rasche Antwort, es scheint also so, daß ich ohne ein Upgrade nicht auskomme --oder ?

L.G.
Walter
#5
Richtig. Schon alleine wegen der von Stefan erwähnten Sicherheitslücken.... Wink

Ab MyBB 1.6.5 gab es Änderungen im Plugin-System, was eine entsprechende Planung des Upgrades voraussetzt, aber prinzipiell sehe ich da kein größeres Problem auf Dich zukommen.
viele Grüße
Jockl
übersetzte und eigene Plugins


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  NewReply Textarea/Div Container mockauer 1 1.007 30.08.2013, 23:01
Letzter Beitrag: Jockl
  Einfache Newthread-Version für Gäste dietmar80 19 3.461 17.03.2012, 13:45
Letzter Beitrag: maxxs
  Errormeldung beim Versuch ein neues Forum od. Kategorie zu erstellen Plexxart 7 3.063 11.01.2011, 16:55
Letzter Beitrag: Plexxart
  editpost.php und newthread.php funktioniert nicht mehr GlobalPlayer 2 2.832 09.11.2010, 02:31
Letzter Beitrag: GlobalPlayer