Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehlermeldung nach Upgrade von 1.6.12 auf 1.8.3
#1
Hallööchen,

ich wollte heute mein Board mit der version 1.6.12 auf die letzte Version 1.8.3 upgraden. Ich erhalte am Schluss immer die Fehlermeldung:

Upgrade Complete

Fatal error: Call to a member function run_hooks() on a non-object in /homepages/17/d509187019/htdocs/kopter/board1/inc/class_parser.php on line 116


Ich kan das Board dann zwar aufrufen (Sieht aber schei... aus) aber bei der Anmeldung fürs ACP kommt die Nächste Fehlermeldung:

Fatal error: Call to undefined method pluginSystem::run_hooks_by_ref() in

/homepages/17/d509187019/htdocs/kopter/board1/admin/modules/downloads/module_meta.php on line 33


Alle Plugins wurden vorher deaktiviert und deinstalliert. Habe es mehrfach probiert, immer das gleiche...


Kann mir da jemand helfen ?
Zitieren
#2
Schau mal bitte => https://www.mybb.de/forum/thread-30281.h...oks_by_ref
MfG Sven
Zitieren
#3
(08.01.2015, 17:26)SvePu schrieb: Schau mal bitte => https://www.mybb.de/forum/thread-30281.h...oks_by_ref


Habe ich schon gelesen, hat aber nicht wirklich was geholfen und schlau werde ich daraus auch nicht. Was kann ich denn mehr machen als alle Plugins deaktivieren und die, die sich lassen deinstallieren ?

Habe jetzt alles weg gelassen und nur rein das komplett Paket 1.8.3 hoch geladen und dann das Update mit der alten Datenbank gemacht. Da kam der Fehler zwar immer noch aber ich kam anschliessend ins Admin center. Der Fehler mit den Plugins muss also irgendwo in der Datenbank zu finden sein ????? Aber das übersteigt meine Kenntnisse.

Ich habe es jetzt soweit wieder eingerichtet, was allerdings jetzt nicht mehr geht sind die Smilies. Sie werden zwar angezeigt, jedoch lassen sie sich nicht mehr durch Klick in den Text einfügen. Auch der "MEHR" link bleibt ohne Reaktion

Link zum Board

Wäre schön wenn mir einer helfen könnte.


Ich sehe gerade da geht noch viel mehr nicht. Ich kann auch keine Beiträge mehr löschen, wenn ich eine Checkbox anklicke bleibt die Zahl im "LOS" Button auf 0
Zitieren
#4
Kann das sein, dass du Plugins verwendest, die nicht für MyBB 1.8 geeignet sind, oder Templates veraltet sind?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Hallo voyager9,

ich bin auch gerade beim update und habe mir dazu eine Kopie des Forums auf meinem Rechner installiert.
Dass das Board sch... aussieht, bekommst Du eventuell durch Zurücksetzen der Templates gebacken. Du musst dann aber wohl eventuell früher eingearbeitete manuelle Änderungen nachziehen. Bei mir hat es jedenfalls geholfen.
Einen fatalen Fehler hatte ich auch. Bei mir war das alte ProPortal dran schuld, war auch in der Meldung aufgeführt. ich habe es aus dem Verzeichnis modules gelöscht und dann war das auch erledigt.
PHP Version 5.6.31
Mybb Version 1.8.19
(Stand 10/2018)

Grüße, André
Zitieren
#6
(09.01.2015, 18:09)StefanT schrieb: Kann das sein, dass du Plugins verwendest, die nicht für MyBB 1.8 geeignet sind, oder Templates veraltet sind?

Wie schon geschrieben, ich habe die Plugins vorher alle "deaktiviert" und die, die gingen auch "Deinstalliert" Was kann ich denn sonst noch tun ?

Nachdem die Fehlermeldung aber nicht behoben wurde, habe ich das komplette board gelöscht (bis auf den Upload Ordner) und das komplett Forum 1.8.3 hoch geladen. Somit dürften gar keine Plugin Scripte mehr vorhanden gewesen sein. Die alte Datenbank vom 1.6.12 habe ich hoch geladen und das Upgrade Script aufgerufen. TROTZDEM kam am Ende die gleiche Fehlermeldung:

Fatal error: Call to a member function run_hooks() on a non-object in ......../inc/class_parser.php on line 116

und eben diese Zeile beinhaltet ein Plugin Verweis....

Also müssen Plugindaten in der Datenbank enthalten sein, welche ich aber nicht zu meiner Lebensaufgabe im Suchen und Entfernen machen kann, in der Hoffnung dass hinterher das Board noch läuft...

Kurz, was sich nicht im Pluginmanager definitiv entfernen und deinstallieren lässt, habe ich hinterher keinen Einfluss mehr drauf....


Zumindest auf diese Weise konnte ich mich anschliessend im Admin CP wieder Anmelden, das Template zurück setzen und somit das Board wieder "einigermaßen" zum laufen kriegen.


Meine jetzigen Probleme sind ein brauchbares ansprechendes Theme zu finden. Ich würde ja das Default Theme lassen, aber die Post werden ziemlich unübersichtlich dargestellt. Ich fände es schöner, wenn diese etwas mehr voneinander abgegrenzt dargestellt würden, siehe Screenshot:

   

Könnte mir hierbei evtl jemand helfen? Ich kenne mich mit der Scriptsprache null aus

Wenn man es so aussehen lassen kann wie in diesem Screenshot (so war es vorher)

   

Dann wäre ich schon sehr zufrieden Leider ist das alte Theme mit dem 1.8.3 nicht mehr kompatibel Sad


Desweiteren habe ich das plugin "Recent Threads (5.0) installiert, welches mir die letzten posts immer nur UNTERHALB der Foren anzeigt. Kann man das evtl auch so hinbiegen, dass sie oben ÜBER den foren erscheinen ? Unterhalb finde ich ziemlich unbrauchbar.

Vielen Dank für eure Hilfe...
Zitieren
#7
Schau mal hier

https://www.mybb.de/erweiterungen/18x/th...ult-theme/
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#8
Suuper Thumbs_up Sieht ja schonmal gut aus, aber die Posts werden auch hier nicht mehr so abgegrenzt wie vorher. Aber immerhin schonmal besser als vorher Smile

Jetzt müsste ich nur noch die Recent Threads nach OBEN bekommen, dann wäre ich glücklich Big Grin
Zitieren
#9
Was die "recent threads" angeht: hast Du dieses Plugin eingesetzt? Wäre nicht schlecht, wenn man nicht immer raten und solche Antworten ständig aus der Nase der Threadersteller ziehen müsste.... Wink

Wenn es sich um das Plugin handelt, dann musst Du vermutlich den Hinweis in dem Plugin berücksichtigen
Zitat:3) Go to your index template and verify the variables {$recentthread_headerinclude} and {$recentthreadtable} exist.
und die Variable {$recentthreadtable} an den gewünschten Platz setzen.
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#10
Ja, es ist genau dieses plugin. Ich dachte mit dem Namen und der Versionsnummer wäre klar um welches plugin es sich handelt.


(10.01.2015, 18:20)voyager9 schrieb: Desweiteren habe ich das plugin "Recent Threads (5.0) installiert....


Den Hinweis habe ich auch gelesen und es steht bei mir im Index template schon an oberster Stelle... Oder ist das falsch ?

   
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Upgrade von 1.8.6 auf 1.8.8 - Fehlermeldung CallHerJule 5 943 07.11.2016, 14:07
Letzter Beitrag: MrBrechreiz
  Fehlermeldung bei Upgrade von 1.6.17 nach 1.8.5 Bogus 15 2.135 09.08.2015, 13:17
Letzter Beitrag: Bogus
  Fehlermeldung nach Upgrade Andreas19 16 1.128 15.01.2015, 18:18
Letzter Beitrag: Andreas19
  Nach upgrade auf 1.8.2 kein Zugriff auf CSS und Styles möglich Mickilina33 5 797 17.11.2014, 18:28
Letzter Beitrag: Mickilina33