Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehlermeldung nach Upgrade
#1
Hallo Leute,

Ich habe eben mein Forum von 1.6.6. auf die 1.8.3 aktualisiert. Leider kommt jetzt diese Fehlermeldung:

Warning: require_once(/www/htdocs/inc/init.php): failed to open stream: No such file or directory in /www/htdocs/forum/index.php on line 17

Fatal error: require_once(): Failed opening required '/www/htdocs/inc/init.php' (include_path='.:/usr/share/php:..') in /www/htdocs/forum/index.php on line 17

Kann mir jemand helfen ?
Zitieren
#2
Wo kommt die Fehlermeldung? Im ACP, im Frontend, beim Threadlesen, während des Upgrades? Ein paar mehr Infos wären schon nett.
Zitieren
#3
Hallo,

Diese Meldung erscheint direkt auf der Indexseite des Forums. Im Admin CP steht noch diese zusätzliche Meldung:

Fatal error: Call to undefined method pluginSystem::run_hooks_by_ref() in /www/htdocs/forum/inc/class_form.php on line 803
Zitieren
#4
Das zweite ist ein Fehler, der an einer veralteten Datei liegt. Lade die "admin/inc/class_form.php" neu hoch. Die entsprechende Zeile ist übrigens schon in 1.6.6 geändert worden.
Am besten gehst du im ACP mal auf die Datei Überprüfung und lädst alle Dateien die dort als geändert angezeigt werden neu hoch.

PS: Editier am besten auch deinen geänderten Admin Pfad aus deinem obigen Beitrag.
Zitieren
#5
Die Datei habe ich eben hochgeladen. Die Meldungen bestehen weiterhin. Die Dateiüberprüfung habe ich eben durchgeführt, viele Dateien sind grau gefärbt und sind als "fehlend" markiert.
Zitieren
#6
Hast du die Datei auch in dein angepasstes Verzeichnis hochgeladen? Zumindest der Fehler im ACP ist ganz eindeutig auf die veraltete Version der entsprechenden Datei zurückzuführen.

Welche sind den als fehlend markiert? Das sollten eigentlich wenn Dateien in den Ordnern "install" oder "images" sein.

Wird dir auf der Hauptseite des ACP denn 1.8.3 als deine aktuelle Version angezeigt?
Zitieren
#7
Schätze das es richtig Probleme gibt Sad Fehlende Dateien sind neben der install-Dateien auch solche hier:

jscripts/codemirror/LICENSE

Fehlend
/jscripts/codemirror/addon/comment/comment.js
Fehlend
/jscripts/codemirror/addon/comment/continuecomment.js
Fehlend
/jscripts/codemirror/addon/dialog/dialog-mybb.css
Fehlend
/jscripts/codemirror/addon/dialog/dialog.css
Fehlend
/jscripts/codemirror/addon/dialog/dialog.js
Fehlend
/jscripts/codemirror/addon/dialog/index.html
Fehlend
/jscripts/codemirror/addon/display/fullscreen.css
Fehlend
/jscripts/codemirror/addon/display/fullscreen.js
Fehlend
/jscripts/codemirror/addon/display/placeholder.js
Fehlend
/jscripts/codemirror/addon/display/rulers.js
Fehlend
/jscripts/codemirror/addon/edit/closebrackets.js
Fehlend
/jscripts/codemirror/addon/edit/closetag.js
Fehlend
/jscripts/codemirror/addon/edit/continuelist.js
Fehlend
/jscripts/codemirror/addon/edit/matchbrackets.js
Fehlend
/jscripts/codemirror/addon/edit/matchtags.js
Fehlend
/jscripts/codemirror/addon/edit/trailingspace.js
Fehlend
/jscripts/codemirror/addon/fold/brace-fold.js
Fehlend
/jscripts/codemirror/addon/fold/comment-fold.js
Fehlend
/jscripts/codemirror/addon/fold/foldcode.js
Fehlend

...und noch weitere. Habe schon solch ein Upgradeskript durchgeführt, damals hatte es geklappt. Weiß nicht mehr weiter. Die Dateien die verändert wurden, habe ich neu hochgeladen, nichts passiert.

Ach so, im Admin CP wird 1.8.3 angezeigt Sad
Zitieren
#8
Hast du nur das changed_files Paket von 1.8.3 benutzt? Alle diese Dateien sind zwischen 1.6.6 und 1.8.3 dazugekommen.
Zitieren
#9
Hi,

Ich habe das Gesamtpaket benutzt. Ob ich nochmal das Gesamtpaket hochlade ?
Zitieren
#10
Da die Dateien fehlen, ist beim Hochladen irgendetwas schief gegangen. Wink Daher ist ein erneutes Hochladen sicher empfehlenswert.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Fehlermeldung bei Upgrade von 1.6.17 nach 1.8.5 Bogus 15 2.137 09.08.2015, 13:17
Letzter Beitrag: Bogus
  Fehlermeldung nach Upgrade von 1.6.12 auf 1.8.3 voyager9 14 1.525 11.01.2015, 14:51
Letzter Beitrag: voyager9