Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
SSL in MyBB 1.8
#11
hkkp, ist es inakzeptabel, wenn du andere Hilfeleistende kritisierst ohne selbst dem Fragenden zu helfen.

Jockl hat, nachdem sich bereits 3 andere User mit guten Tipps die Zähne ausgebissen haben, auf ein Forum hingewiesen, in dem einige User aktiv sind, die sich sehr gut mit Apache auskennen. Dies ist völlig legitim, wenn wir hier nicht weiterkommen und der Themen-Ersteller dringend eine Lösung benötigt.
Was Probleme mit den Rewrite-Regeln von Apache mit dem MyBB zu tun haben und selbstverständlich sein soll, erschließt sich mir leider nicht.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#12
Code:
In MyBB 1.8 finde ich allerdings keine Einstellung, in der man SSL einschalten kann.

schon klar. allerdings gebe ich dem user diesbezüglich recht...
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#13
Warum sollte es eine Einstellung geben? Dem MyBB ist das völlig egal und SSL muss serverseitig konfiguriert werden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#14
da hab ich falsch gedacht...
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#15
Gibt es nun eine vernünftige Lösung?
Zitieren
#16
Eine Lösung für was? Oben wurden ja mehrere Vorschläge gemacht, hast du diese bereits ausprobiert?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#17
Ist die Lösung aus folgendem Beitrag noch aktuell, wenn man SSL einrichten möchte?

https://www.mybb.de/forum/thread-30938-p...#pid206215

PS: Ich nutze die Plugins Google Seo und Mybb Go Mobile, falls dies hier relevant ist.
Zitieren
#18
Beim Themen-Ersteller hat es zwar aus irgendeinem Grund nicht funktioniert, aber prinzipiell sollte das so funktionieren. Zu dem Thema gibt es aber auch sehr viel Treffer bei Google.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#19
Da ich seit gestern auch mit meiner Seite eine SSL Verschlüsselung habe, und dies hier gut rein passt, teile ich mein Wissen über meine Einstellungen, um die eigene Seite über https zu erreichen.

Vorweg sei gesagt, das es Abweichungen geben kann. Hier nun meine Änderungen von http auf https.

Ist das Zertifikat serverseitig eingerichtet und auf deine Domain geschaltet, dann sollte dennoch deine Seite erreichbar sein. Hier müsste nun die Seite recht zerschossen aussehen, da die Scripte noch immer in den Einstellungen auf http verweisen. Das Anmelden im ACP, wird nur noch auf dem Index stattfinden, klickt man weiter auf einen anderen Link, innerhalb des ACP´s, wird man rausgeschmissen. Grund hierfür sind die Cookies. Öffnet eure settings.php und ändert in

$settings['bburl'] = "";

das http zu https. Das Gleiche macht ihr in

$settings['homeurl'] = "";


Der nächste Schritt hat bei mir nur SO funktioniert.

Löscht den Inhalt der Cookiedomain

zB. von
$settings['cookiedomain'] = ".blabla";
zu
$settings['cookiedomain'] = "";

und den Cookiepath

zB. von
$settings['cookiepath'] = "/forum/";
zu
$settings['cookiepath'] = "/";

Speichert die settings.php und ladet diese wieder zurück in den inc Ordner. Anmelden im ACP, und nun sollte es möglich sein, bei weiteren Klicks auf Links angemeldet zu bleiben.

Wichtig: Damit die Änderungen beibehalten bleiben, müsst ihr im ACP unter Seiten-Details diese Einstellungen nun nochmals vornehmen, damit sie auch in der Datenbank gespeichert werden.

URL zum Forum = http zu https
URL der Homepage = http zu https
Cookie-Domain = LEER LASSEN
Cookie-Pfad = zu / ändern, wenn dies nicht schon der Fall sein sollte


Optional, könnt ihr unter Cookies nur über HTTPS auf Ja stellen.

Speichern, und dann sollte eure Seite via https erreichbar sein.

Falls euch im FF ein gelbes Warndreieck über den grauen Schloss zuzwinkert, dann habt ihr auf der momentanen Seite einen MIXED CONTENT. Das heisst, irgendwo wird zum Beispiel ein verlinktes oder fremdverlinktes Bild mit http verlinkt. Korrigiert dies, dann sollte das Schloss grün werden, wenn nicht ist noch mehr von MIXED CONTENT vorhanden.


Ich hoffe das ich nicht all zu viel sinnloses geschrieben habe, und ihr damit zurecht kommt. Rolleyes
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#20
Hallo,

super erklärt, MrBrechreiz , hat bei mir auf Anhieb geklappt !!

Jetzt habe ich nur das Problem, daß ich mich nicht mehr als Admin abmelden kann Sad
Schönen Gruß
Peter



Ich hab´gerade aus dem Fenster geguckt, um zu sehen, wie das Wetter ist.
AUS DEM FENSTER......OBWOHL MEIN HANDY NEBEN MIR LIEGT !!
Cool Wie im Mittelalter
Cool
Zitieren