Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.14 veröffentlicht (30.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
SSL in MyBB 1.8
#1
Hallo,

gestern habe ich mir ein Comodo SSL Zertifikat gekauft, um dies auf meinem Forum und meiner Website zu verwenden. In MyBB 1.8 finde ich allerdings keine Einstellung, in der man SSL einschalten kann. Muss ich einfach die Foren URL von "http://foru..." zu "https://foru..." ändern oder andere Einstellungen vornehmen?

Für MyBB 1.6 gab es ausserdem einen SSL Switcher, der Besucher, die die Seite über "http://foru..." aufrufen, direkt auf die verschlüsselte Seite weiterleiten.


Wie ist dies in MyBB 1.8 möglich?

Grüße
Benni
Zitieren
#2
Hey,

da kannst du ganz einfacher über .htaccess erzwingen.

Da ich selbst kein Forum mit ssl betreibe müsstest du in den Einstellungen mal gucken, sollte aber reichen aus dem http ein https zu machen.

Anschließen noch im root des Forums in die .htaccess folgendes schreiben (bzw neu anlegen wenn keine vorhandne ist):

Code:
RewriteBase /
RewriteEngine on

RewriteCond %{SERVER_PORT} !443
RewriteRule (.*) https://%{HTTP_HOST}$1 [R=301,L]

Das ganze prüft ob Port 443 (SSL) genutzt wird, wenn nicht wird automatisch auf ssl gewechselt.
Zitieren
#3
(08.11.2014, 15:05)Juventiner schrieb: Hey,

da kannst du ganz einfacher über .htaccess erzwingen.

Da ich selbst kein Forum mit ssl betreibe müsstest du in den Einstellungen mal gucken, sollte aber reichen aus dem http ein https zu machen.

Anschließen noch im root des Forums in die .htaccess folgendes schreiben (bzw neu anlegen wenn keine vorhandne ist):


Code:
RewriteBase /
RewriteEngine on

RewriteCond %{SERVER_PORT} !443
RewriteRule (.*) https://%{HTTP_HOST}$1 [R=301,L]

Das ganze prüft ob Port 443 (SSL) genutzt wird, wenn nicht wird automatisch auf ssl gewechselt.


Das habe ich reingschrieben, da stimmt etwas mit der Weiterleitung nicht. Es wird auf diese Seite weitergeleitet:

https://forum.gamenowde.comforum/index.p...um/=forum/
Zitieren
#4
http://www.inmotionhosting.com/support/w...ccess-file
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#5
Alles befolgt.

Die htacces sieht nun (für die Hauptseite) wie folgt aus:

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://gamenowde.com/$1 [R,L]
# Pretty Permalinks
RewriteRule ^(images)($|/) - [L]
RewriteCond %{REQUEST_URI} !^action=logout [NC]
RewriteCond %{REQUEST_URI} !^action=login [NC
Options +FollowSymLinks -MultiViews


Weiterhin wird falsch weitergeleitet.
Zitieren
#6
Vielleicht funktioniert es damit:

Code:
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

Dadurch sollte auch die Subdomain "forum" eingeschlossen sein.
MfG Sven
Zitieren
#7
Nein, weiterhin funktioniert es nicht.
Zitieren
#8
Ich könnte schnell eine Lösung gebrauchen, da meine Seite nicht erreichbar ist.
Zitieren
#9
Du könntest Dich damit auch an einschlägige Foren für Server-Admins wenden.....

z.B.: http://serversupportforum.de/forum/
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#10
hallo jockle, sorry, dies lese ich gerade. aber wenn mybb ein forum anbietet, dann sollte ja wohl ssl selbstverständlich sein...
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  SSL - Keine sichere Verbindung.Neues Zertifikat einrichten? falcao1010 4 134 04.12.2017, 18:48
Letzter Beitrag: falcao1010
  SSL Zertifikat KaSo 3 711 06.03.2015, 11:37
Letzter Beitrag: StefanT