Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.12 veröffentlicht (22.05.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Forum funktioniert nicht mehr unter PHP 5.4
#1
Lightning 
Mein lieber Webhoster hat gestern Nacht auf PHP 5.4 umgestellt; jetzt ist mein Forum nicht mehr erreichbar. Auf Nachfrage schreibt er:

Zitat:und zwar sind Ihre Scripte veraltet. Wir hatten vor Monaten in einem Rundschreiben mitgeteilt, dass wir die Server aktualisieren müssen, auf Grund von Sicherheitslücken in älteren Versionen. Wir haben Server #20 auf PHP 5.4 aktualisiert und Ihr Script verwendet noch Befehle, die es in PHP 5.4 nicht mehr gibt.

Z. B. wurde in PHP5.4 die Funktion mod_fcgid: stderr: PHP Fatal error: Call-time pass-by-reference has been removed

entfernt, diese verwenden Sie.

Dieses Problem haben Sie bei jedem Webhoster, der aktuelle Software einsetzt. Hier appelieren wir an Sie, dass Sie Ihre Scripte anpassen und zeitgemäß halten.

So muss es bspw. statt &$treffer nun $treffer lauten. Mein Kollege hat angefangen dies anzupassen. Alle anderen Dateien müssten Sie anpassen. Mein Kollege kann dies gegen Dienstleistung für Sie erledigen.

Gibt es hier irgendwo ein Update, ein Patch oder eine Anleitung, wie ich (als Nicht-IT-ler) die Skripte anpassen kann? Ich habe die aktuelle Version der Forensoftware.
Ist das sehr schwierig und/oder zeitaufwändig?
#2
Entweder verwendest du nicht die aktuelle MyBB-Version oder Plugins, die nicht mit PHP 5.4 kompatible sind. Ohne Angabe, wo die Fehler auftreten, kann man da nur raten.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
Tja; das kann ich leider auch nur. Das Forum ist schlicht nicht erreichbar: http://www.mpathie-forum.de/

Was sind denn die "typischen" Skripte, die man anpassen muss und was genau ist zu tun?

Würde denn ein Upgrade mit einer ganz frischen Installationsdatei vielleicht helfen? Möglicherweise ist irgendwas bei all den vielen Updates/Upgrades der letzten 5 Jahre schief gegangen?

Und wie entfernt man Plugins, wenn man nicht ins ACP kommt? Einfach /inc/plugins löschen ist bestimmt keine so gute Idee.
#4
Kann dir dein Hoster nicht die konkrete Fehlermeldung geben?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
Ich frag noch mal an, aber ich kenne die Typen. Die wollen nur extra Kasse machen, indem sie mir beim Skripteändern "helfen".
So etwas haben die schon mal abziehen wollen nach einem Serverwechsel. Aber da waren es nur ein paar Zeilen Code, die ich ändern musste. Und dafür wollten sie richtig Asche.
Ich kann das hier nicht einschätzen: vielleicht muss ich nur ein paar Zeilen ändern, vielleicht viele.
Hat denn sonst keiner dieses Problem? Angeblich haben auch andere Webhoster auf PHP 5.4 umgestellt...
#6
Wie sieht es aus mit deiner .htasses ?
#7
(24.03.2014, 16:10)Paccy schrieb: Hat denn sonst keiner dieses Problem?
Wir wissen doch noch nicht einmal, was das Problem ist. Rolleyes
(24.03.2014, 16:10)Paccy schrieb: Angeblich haben auch andere Webhoster auf PHP 5.4 umgestellt...
PHP 5.4 ist auch schon über 2 Jahre alt und dementsprechend schon auf einigen Servern im Einsatz. Teilweise wird auch schon PHP 5.5 eingesetzt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#8
Mein Hoster schreibt:

Zitat:Herr --- hatte Ihnen die Fehlermeldung bereits geschickt:
mod_fcgid: stderr: PHP Fatal error: Call-time
pass-by-reference has been removed

Dies betrifft im Prinzip Dereferenzierung von Variablen, also Variablen, welche mit &$ eingeleitet sind, anstatt mit lediglich mit $

Diese Aufrufe finden Sie in mehreren Scripten Ihres Forums.

Weitere Informationen zu diesem Thema finden Sie unter:
https://php.net/manual/en/migration53.deprecated.php

Kann hier jemand etwas damit anfangen??? Blush
#9
Du könntest das mal ausprobieren, um die Plugins zu deaktivieren.
(22.12.2012, 14:28)Jockl schrieb: Öffne die Datei inc/init.php, suche die Zeile
PHP-Code:
define("TIME_NOW"time()); 
und füge danach
PHP-Code:
define("NO_PLUGINS"1); 
ein.
Sollte damit das Forum wieder funktionieren, liegt es an einem Plugin und Du solltest zusehen, dass Du Dir aktualisierte Versionen der Plugins besorgst.
viele Grüße
Jockl
übersetzte und eigene Plugins
#10
Vielen Dank, Jockl!!!! Big Grin

Es lag tatsächlich an einem Plugin, bei dem ich lediglich ein paar Mal &$ durch $ ersetzen musste. Jetzt ist alles gut. Alleine hätte ich das nie herausgefunden! Vielen, lieben Dank!!! Smile


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Thumbsdown Forum funktioniert nicht mehr wernerz 15 3.720 01.12.2013, 00:17
Letzter Beitrag: mschumac
  Die Positionierung von Text direkt unter dem Bild funktioniert anscheinend nicht mehr hamport 2 431 16.11.2013, 18:38
Letzter Beitrag: hamport
  index.php ersetzt - jetzt funktioniert Forum mehr viocelli 1 1.041 31.10.2011, 13:52
Letzter Beitrag: StefanT
  Forum funktioniert während upgrade nicht mehr moro 3 1.188 26.02.2011, 12:59
Letzter Beitrag: moro
  editpost.php und newthread.php funktioniert nicht mehr GlobalPlayer 2 2.077 09.11.2010, 02:31
Letzter Beitrag: GlobalPlayer