Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.20 veröffentlicht (27.02.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
EMails werden nicht verschickt.
#1
Hallo,

ich hatte vor kurzem einen Serverumzug und ich habe mich durch dutzende Probleme geschlagen, jedoch komme ich hier nicht mehr weiter.

Es werden keine EMails versendet, z.B. wenn man eine Aktivierungsmail bekommen sollte, kommt die einfach nicht an.
Ich hoste die Website auf einem eigenem Rootserver und die PHP mail() Funktion müsste von daher automatisch aktiviert sein.

Sollte man ein Test durchführen, kommt die im AdminCP folgende Meldung: MyBB was unable to send the email using the PHP mail() function.

Das ist die /inc/mailhandlers/php.php

PHP-Code:
<?php
/**
 * MyBB 1.6
 * Copyright 2010 MyBB Group, All Rights Reserved
 *
 * Website: http://mybb.com
 * License: http://mybb.com/about/license
 *
 * $Id: php.php 5828 2012-05-08 16:06:16Z Tomm $
 */

// Disallow direct access to this file for security reasons
if(!defined("IN_MYBB"))
{
    die(
"Direct initialization of this file is not allowed.<br /><br />Please make sure IN_MYBB is defined.");
}

/**
 * PHP mail handler class.
 */
class PhpMail extends MailHandler
{
    
/**
     * Additional parameters to pass to PHPs mail() function.
     *
     * @var string
    */
    
public $additional_parameters '';

    
/**
     * Sends the email.
     *
     * @return true/false whether or not the email got sent or not.
     */    
    
function send()
    {
        global 
$lang$mybb;

        
// For some reason sendmail/qmail doesn't like \r\n
        
$this->sendmail = @ini_get('sendmail_path');
        if(
$this->sendmail)
        {
            
$this->headers str_replace("\r\n""\n"$this->headers);
            
$this->message str_replace("\r\n""\n"$this->message);
            
$this->delimiter "\n";
        }
        
        
// Some mail providers ignore email's with incorrect return-to path's so try and fix that here
        
$this->sendmail_from = @ini_get('sendmail_from');
        if(
$this->sendmail_from != $mybb->settings['adminemail'])
        {
            @
ini_set("sendmail_from"$mybb->settings['adminemail']);
        }

        
// If safe mode is on, don't send the additional parameters as we're not allowed to
        
if(ini_get('safe_mode') == || strtolower(ini_get('safe_mode')) == 'on')
        {
            
$sent = @mail($this->to$this->subject$this->messagetrim($this->headers));
        }
        else
        {
            
$sent = @mail($this->to$this->subject$this->messagetrim($this->headers), $this->additional_parameters);
        }
        
$function_used 'mail()';

        if(!
$sent)
        {
            
$this->fatal_error("MyBB was unable to send the email using the PHP {$function_used} function.");
            return 
false;
        }

        return 
true;
    }
}
?>

Gibt es hierfür eine Lösung?

Mit freundlichen Grüßen
UVCMD
#2
Siehe: https://www.mybb.de/forum/thread-22049.html
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
Danke für die sehr schnelle Hilfe, jedoch kannte ich diesen Beitrag schon.
Der Fehler ist sooo dumm, meinerseits...
Also so habe ich es hinbekommen:

1. Postfix zu installieren ist eine sehr gute Idee Rolleyes So kam zumindest die Fehleranzeige im ACP nicht mehr zustande.

2. Dann habe ich einen Reverse-DNS-Eintrag eingerichtet.

3. Folgende Postfixkonfigurationen:

Code:
myhostname = "Reverse-DNS-Eintrag"
mydestination = "Reverse-DNS-Eintrag", localhost.localdomain, , localhost

Trotzdem bin ich sehr dankbar für den schnellen Support.

Mit freundlichen Grüßen
UVCMD


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Massenmail wird nicht verschickt Maggan22 14 1.945 25.10.2011, 17:29
Letzter Beitrag: Assaki
  MyBB verschickt keine Emails cody96 12 3.894 16.07.2011, 13:15
Letzter Beitrag: cody96
  Aktivierungs mail wird nicht verschickt Schbasti_01 14 3.183 18.04.2011, 20:37
Letzter Beitrag: StefanT
  Bei Abbonierten Themen werden keine E-mails verschickt?! VisualBoard 11 1.942 30.01.2011, 13:31
Letzter Beitrag: VisualBoard