Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Forum in Webseite/Webseite in Forum integrieren?
#31
Nach deiner beschriebenen Ordnerstruktur sollte es "../header.php" sein.
Zitieren
#32
Müsste aber normalerweise auch mit dem absoluten Pfad funktionieren. Sobald eigendlich der Pfad stimmt zeigt es mir eine weiße Seite statt das Forum, mach ich einen rechtschreibfehler oder falschen Pfad bsp nur /page/header.php dann zeigt es mir wieder das Forum an, das ist das komische.
Zitieren
#33
Wenn du eine weiße Seite erhältst, dann werden durch die PHP-Konfiguration offenbar PHP-Fehler unterdrückt. Sofern du Zugriff auf die Konfiguration hast, solltest du das ändern, sonst kann man ewig nach dem Fehler suchen. Ansonsten könnten auch die Error-Logs des Webservers Hinweise oder Fehlermeldungen enthalten.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#34
Hey,

ja stimmt da könnt ich mal nachschauen, wo könnte ich das konfigurieren das diese nicht unterdrückt werden?

Danke
Zitieren
#35
Das kommt darauf an, ob du Webspace oder einen eigenen (v)Server hast. Bei ersterem vermutlich im Panel deines Anbieters, beim Server in der php.ini.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#36
Ja, habe einen eigenen vserver, werde mal schnell nachschauen, melden mich dann wieder. Danke.
Hey,

aber da haben die Pfade so nicht gepasst, jetzt hab ich absolute Links drin da meckert er nicht, also auch keine logs. Das in der PHP.ini Datei habe ich bis jetzt noch nicht gefunden wo genau des da drin angeben wird.

PHP-Code:
PHP Warning:  include(../page/sliderpanel.php): failed to open streamNo such file or directory in /var/www/page/forum/global.php on line 23
PHP Warning
:  include(): Failed opening '../page/sliderpanel.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear'in /var/www/page/forum/global.php on line 23
PHP Warning
:  include(../page/menu.php): failed to open streamNo such file or directory in /var/www/page/forum/global.php on line 28
PHP Warning
:  include(): Failed opening '../page/menu.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear'in /var/www/page/forum/global.php on line 28
PHP Warning
:  include(../page/footer.php): failed to open streamNo such file or directory in /var/www/page/forum/global.php on line 33
PHP Warning
:  include(): Failed opening '../page/footer.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear'in /var/www/page/forum/global.php on line 33 
Zitieren
#37
http://de2.php.net/manual/en/errorfunc.c...lay-errors
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#38
Habs nun so, danach den apache restartet. Aber eine Fehlermeldung wird mir noch nicht angezeigt:

*Link auf Wunsch entfernt*


; This directive controls whether or not and where PHP will output errors,
; notices and warnings too. Error output is very useful during development, but
; it could be very dangerous in production environments. Depending on the code
; which is triggering the error, sensitive information could potentially leak
; out of your application such as database usernames and passwords or worse.
; It's recommended that errors be logged on production servers rather than
; having the errors sent to STDOUT.
; Possible Values:
; Off = Do not display any errors
; stderr = Display errors to STDERR (affects only CGI/CLI binaries!)
; On or stdout = Display errors to STDOUT
; Default Value: On
; Development Value: On
; Production Value: Off
; http://php.net/display-errors
display_errors = On
Zitieren
#39
Dann produziert dein Script die weiße Seite...
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#40
ich glaub da stimmt etwas mit den includes nicht, wenn ich nur eine Seite einbinde bsp. nur den footer sofort ist die Seite wieder weiß. Wenn ich die kompletten includes entferne funktioniert es wieder bzw. includiere ich eine andere Seite funktioniert auch nicht also bsp. wenn ich eine Seite von einem anderen Webspace include.

ob_start();
include 'URL'; //Deine Datei
$menu = ob_get_contents(); //Mit dieser Variable wird die Datei später aufgerufen
ob_end_clean();

fehlt an dem script evtl. irgendwas?
Zitieren