Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
class_core.php Fehler schon in Zeile 18
#1
Hallo zusammen,

ich wollte gerade myBB installieren, Dateistruktur habe ich 1:1 übernommen und die Berechtigungen gesetzt.
Mein HP-Paket (1&1 Homepage Perfect) sollte eigentlich die Systenvoraussetzungen unterstützen, hoffe ich:
https://www.1und1.info/xml/order/FirmenH...kId=weiter

Leider bekomme ich beim Aufruf immer folgenden Fehler:
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /-Pfad zum Forum-/inc/class_core.php on line 18

In der Forensuche habe ich Beschreibungen zu ähnlichen Fehlern gefunden, aber nicht zu einem so frühen Zeitpunkt der Installation. Kann es sein daß meine PHP-Version doch nicht kompatibel ist? Sollte ich dann lieber die 1.4 ausprobieren?

Danke für Eure Hilfe!
#2
(21.04.2011, 15:51)svx schrieb: Kann es sein daß meine PHP-Version doch nicht kompatibel ist? Sollte ich dann lieber die 1.4 ausprobieren?

Welche PHP-Version nutzt du denn?

Schau mal hier: https://www.mybb.de/forum/thread-16862.html
#3
Naja auf der 1&1-Homepage steht in der Beschreibung des Pakets "PHP4, PHP5, PHP6 (beta)" (siehe Link im ersten Posting)
Ich weiß nicht ob man die Version irgendwo auswählen muss, habe dazu nichts gefunden.

EDIT: habe in einem anderen Thread folgende Aussage gefunden:
"Dateien, die als PHP5 ausgeführt werden sollen, müssen allerdings per Standard die Dateiendung .php5 tragen.
Dies können Sie aber leicht selbst mit einer eigenen .htaccess-Datei selbst ändern.
Notwendiger Eintrag in der .htaccess-Datei: AddHandler x-httpd-php5 .php"

EDIT: danke, hab's gefunden, .htaccess erstellt und läuft. puh, erster Schritt geschafft...
#4
Puh, also damit kann ich gar nichts anfangen.

Kann man das auch für Laien formulieren? Hab den selben Fehler und kann mit htaccess usw. nichts anfangen.

Verwende den Dreamweaver CS3, falls das was hilft. In linie 18 steht:

public $version = "1.6.3";

Danke und viele Grüße
Birgit

/edit: hab jetzt etwas nachgelesen - also es ist eine Datei, mit der z.B. Passwörter vergeben werden können oder andere Zugriffsrechte etc. Hab jetzt so eine Datei erstellt, aber es passiert nichts - mache also etwas falsch oder web.de bietet diese Funktion nicht Sad
#5
Das MyBB benötigt PHP 5.1, bei dir läuft aber eine ältere PHP-Version.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#6
Hm, ok. Und was muss ich jetzt tun?

/edit: scheinbar runterladen und ausprobieren - ich versuchs mal.

Danke für die Hilfe.

LG Birgit
#7
Ich weiß nicht, wie das bei deinem Anbieter ist, aber probiere das doch mal mit der .htaccess oder vielleicht kannst du etwas mit Google rausfinden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#8
Das steht in den Leistungen von web.de drin:

FTP Zugang + +
PHP4, PHP5 + +
MySQL-Datenbank + +


Danach müssten die ja schon php5 haben - also liegt das Problem bei mir?
#9
Standardmäßig ist aber PHP 4 eingestellt und das ist nunmal uralt (PHP 5 erschien 2004).
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#10
Ja hab ich gelesen, dass es das schon so lang gibt.

Gut, dann wende ich mich an web.de und hoffe mal, dass die auf mehr Aktualität aus sind.

Vielen Dank für die Hilfe

LG Birgit Smile