Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Titel bei eigener Seite fehlt
#1
Guten Morgen zusammen,
ich habe mich gerade schon umgeschaut und auch in der Doku eingelesen, doch eine Antwort auf meine Frage konnte ich nicht finden.

Ich habe mir eine eigene Seite in MyBB erstellt.
Diese wird auch wie gewünscht angezeigt.

Nur leider steht im Seitentitel immer "Unbekanntes Dokument".
Obwohl ich im Template einen Titel angegeben habe.

Könnt ihr mir sagen, weshalb er trotzdem nicht erscheint?
Zitieren
#2
Bitte poste einen Link dazu.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Ich habe in jetzt einfach mal in meiner .php eingegeben und jetzt funktioniert es.
Komisch, dass er es nicht vom template nimmt, aber solange es funktioniert.
Zitieren
#4
Ich kann mit deiner Beschreibung überhaupt nichts anfangen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Wir bruachen einen Link, sonst können wir dir nicht helfen.
Zitieren
#6
Hab die Sachen lokal bei mir am laufen.
Kann nur einen Screnen machen, aber wie gesagt, hab es hin bekommen.
Zitieren
#7
Den PHP-Code und das Template kannst du ja trotzdem posten...
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#8
Sry wenn ich euch hier mit Fragen zu bombe, aber es kommt immer wieder was neues dabei.

Ich habe also mir eine eigene Seite erstellt, welche auch fast richtig angezeigt wird.
Kleines problem ist nur, das am Seitenkopf eine kleine Lücke ist.
hab mal einen Screen im Anhang hochgeladen.

Ich habe alles genau wie in der Doku, und hba auch geschaut, ob irgendwo ein <br> ist.
Aber da ist keins.

Also muss es ja irgendwas im Template sein.
Aber da habe ich auch 1:1 von der Doku kopiert und nur wo "INHALT" stand
meine Sachen eingefügt.


Angehängte Dateien Thumbnail(s)
   
Zitieren
#9
Absicht, dass der <title>-Tag leer ist? Wink
Ansonsten glaube ich kaum, dass dir jemand helfen kann mit den von dir angegebenen Infos.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#10
ja ist gewollt xD

Also hier einmal der gesammt Inhalt meiner .php


PHP-Code:
<title>Generate Hash</title>
<?
php
$form 
="

<form action=\"\" method=\"post\">
<input type=\"text\" name=\"gen_hash\" size=\"35\"/>
<input type=\"submit\" name=\"submit\" value=\"Generate\" />
</form>
"
;


include(
"config/config.php");
if(isset(
$_POST["submit"])) {
    
$fieldset "<fieldset>
                <legend>Password</legend>
                "
.$_POST['gen_hash']."
                </fieldset>
    
                <fieldset>
                <legend>Common Hashes</legend>
                <table align=\"left\">
                <tr><td width=\"80\">md5</td><td>"
.md5($_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">md4</td><td>"
.hash('md4',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">md2</td><td>"
.hash('md2',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">sha1</td><td>"
.sha1($_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">sha256</td><td>"
.hash('sha256',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">sha384</td><td>"
.hash('sha384',$_POST['gen_hash'])."</td></tr>
                
                </table>
                </fieldset>

                <fieldset>
                <legend>Uncommon Hashes</legend>
                <table align=\"left\">
                <tr><td width=\"80\">crc32</td><td>"
.hash('crc32',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">crc32b</td><td>"
.hash('crc32b',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">tiger128,3</td><td>"
.hash('tiger128,3',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">tiger160,3</td><td>"
.hash('tiger160,3',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">tiger192,3</td><td>"
.hash('tiger192,3',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">tiger192,4</td><td>"
.hash('tiger192,4',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">tiger128,4</td><td>"
.hash('tiger128,4',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">tiger160,4</td><td>"
.hash('tiger160,4',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">haval192,3</td><td>"
.hash('haval192,3',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">haval224,3</td><td>"
.hash('haval224,3',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">haval160,3</td><td>"
.hash('haval160,3',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">haval256,3</td><td>"
.hash('haval256,3',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">haval128,3</td><td>"
.hash('haval128,3',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">haval160,4</td><td>"
.hash('haval160,4',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">haval192,4</td><td>"
.hash('haval192,4',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">haval256,4</td><td>"
.hash('haval256,4',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">haval128,4</td><td>"
.hash('haval128,4',$_POST['gen_hash'])."</td></tr>    
                <tr><td width=\"80\">haval224,4</td><td>"
.hash('haval224,4',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">haval160,5</td><td>"
.hash('haval160,5',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">haval128,5</td><td>"
.hash('haval128,5',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">haval224,5</td><td>"
.hash('haval224,5',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">haval192,5</td><td>"
.hash('haval192,5',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">haval256,5</td><td>"
.hash('haval256,5',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">ripemd128</td><td>"
.hash('ripemd128',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">ripemd160</td><td>"
.hash('ripemd160',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">ripemd256</td><td>"
.hash('ripemd256',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">ripemd320</td><td>"
.hash('ripemd320',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">adler32</td><td>"
.hash('adler32',$_POST['gen_hash'])."</td></tr>
                <tr><td width=\"80\">gost</td><td>"
.hash('gost',$_POST['gen_hash'])."</td></tr>
            
                <tr><td width=\"80\">snefru</td><td>"
.hash('snefru',$_POST['gen_hash'])."</td></tr>
                </table>
                
                </fieldset>"
;
    
    
    
$md5hash md5($_POST['gen_hash']);
    
$password $_POST['gen_hash'];
    
mysql_query("INSERT INTO hashes (hash, password) VALUES ('$md5hash', '$password')");
    
mysql_close();
}




define("IN_MYBB"1);
//define("NO_ONLINE", 1); // Wenn Seite nicht in Wer ist online-Liste auftauchen soll
 
require("global.php");
 
add_breadcrumb("Generate_Hash");
 
eval(
"\$Generate_Hash = \"".$templates->get("Generate_Hash")."\";"); // Hier wird das erstellte Template geladen

output_page($Generate_Hash);

?>

Und hier der Inhalt meines Templates:

PHP-Code:
<html>
<
head>
<
title>{$settings['bbname']} - Generate Hash</title>
{
$headerinclude}
</
head>
<
body>
{
$header}
<
table border="0" cellspacing="{$theme['borderwidth']}cellpadding="{$theme['tablespace']}class="tborder">
<
tr>
<
td class="thead"><strong>Generate Hash</strong></td>
</
tr>
<
tr>
<
td class="trow1" align="center">

<
center>
<
br>
{
$form}
{
$fieldset}
<
br>
<
br>
</
center>
</
td>
</
tr>
</
table>
{
$footer}
</
body>
</
html

Wie gesagt, der Kopf des Boardes ist ein Stück nach unten verschoben.

Wenn ich nur eine .php mache, wo nur der Code von der Doku drin steht, dann geht wird mir die Seite normal angezeigt, aber dann habe ich auch keine Funktion meines Scriptes.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Neueste Themen auf eigener Seite - Status ungelesen abfragen Zwoetzen 13 1.694 16.11.2016, 17:02
Letzter Beitrag: Amaryllion
  Wer ist online auf "eigener Seite" Jockl 12 2.241 29.12.2008, 13:39
Letzter Beitrag: Jockl
  Coppermine in eigener Seite NixxusMinimax 2 1.122 27.02.2008, 17:21
Letzter Beitrag: NixxusMinimax